summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlain Penders <alain@gentoo.org>2003-03-22 14:23:23 +0000
committerAlain Penders <alain@gentoo.org>2003-03-22 14:23:23 +0000
commit418af01acd825eaac5b043591172b9d13a6aa8ab (patch)
tree1a165f5684f76dd537b16fccdb4f6848f9b4601e /dev-util/lincvs
parentNew ebuilds for streamtuner plugins. Closes #17937, 17943 (diff)
downloadhistorical-418af01acd825eaac5b043591172b9d13a6aa8ab.tar.gz
historical-418af01acd825eaac5b043591172b9d13a6aa8ab.tar.bz2
historical-418af01acd825eaac5b043591172b9d13a6aa8ab.zip
LinCVS 1.1.4
Diffstat (limited to 'dev-util/lincvs')
-rw-r--r--dev-util/lincvs/ChangeLog7
-rw-r--r--dev-util/lincvs/files/digest-lincvs-1.1.41
-rw-r--r--dev-util/lincvs/files/lincvs-1.1.4-gentoo.diff30
-rw-r--r--dev-util/lincvs/lincvs-1.1.4.ebuild37
4 files changed, 74 insertions, 1 deletions
diff --git a/dev-util/lincvs/ChangeLog b/dev-util/lincvs/ChangeLog
index 2f50681ebff7..ed55276c2f7f 100644
--- a/dev-util/lincvs/ChangeLog
+++ b/dev-util/lincvs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/lincvs
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/lincvs/ChangeLog,v 1.14 2003/03/18 15:49:46 alain Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/lincvs/ChangeLog,v 1.15 2003/03/22 14:23:23 alain Exp $
+
+*lincvs-1.1.4 (22 Mar 2003)
+
+ 22 Mar 2003; Alain Penders <alain@gentoo.org> lincvs-1.1.4.ebuild:
+ New version added.
*lincvs-1.1.3 (18 Mar 2003)
diff --git a/dev-util/lincvs/files/digest-lincvs-1.1.4 b/dev-util/lincvs/files/digest-lincvs-1.1.4
new file mode 100644
index 000000000000..70f5fdada676
--- /dev/null
+++ b/dev-util/lincvs/files/digest-lincvs-1.1.4
@@ -0,0 +1 @@
+MD5 2b1a79481c3bcb2c6dace972af4e769d lincvs-1.1.4-0-generic-src.tgz 444626
diff --git a/dev-util/lincvs/files/lincvs-1.1.4-gentoo.diff b/dev-util/lincvs/files/lincvs-1.1.4-gentoo.diff
new file mode 100644
index 000000000000..6a282d62ef06
--- /dev/null
+++ b/dev-util/lincvs/files/lincvs-1.1.4-gentoo.diff
@@ -0,0 +1,30 @@
+--- LinCVS.orig/lincvs 2003-03-13 04:08:16.000000000 -0500
++++ LinCVS/lincvs 2003-03-13 04:08:38.000000000 -0500
+@@ -1,9 +1,2 @@
+ #!/bin/sh
+-
+-echo Adapt the absolute path to LinCVS/lincvs.bin
+-echo and copy this startscript into a directory
+-echo of your PATH!
+-
+-#exec "/absolute_path_to_LinCVS/AppRun" "$@"
+-#for instance
+-#exec "/usr/local/apps/LinCVS/AppRun" "$@"
+\ No newline at end of file
++exec /usr/share/LinCVS/AppRun
+diff -ur src.orig/cmainwindow.ui src/cmainwindow.ui
+--- src.orig/cmainwindow.ui 2003-02-22 08:39:57.000000000 -0500
++++ src/cmainwindow.ui 2003-03-13 04:34:40.000000000 -0500
+@@ -104,10 +104,10 @@
+ <iconset>module_add_16x16.xpm</iconset>
+ </property>
+ <property name="text">
+- <string>&amp;Add project to workbech ...</string>
++ <string>&amp;Add project to workbench ...</string>
+ </property>
+ <property name="toolTip">
+- <string>Adds a new project to the workbech</string>
++ <string>Adds a new project to the workbench</string>
+ </property>
+ <property name="whatsThis">
+ <string>Add an existing project to the workbench</string>
diff --git a/dev-util/lincvs/lincvs-1.1.4.ebuild b/dev-util/lincvs/lincvs-1.1.4.ebuild
new file mode 100644
index 000000000000..4e918b9f3ced
--- /dev/null
+++ b/dev-util/lincvs/lincvs-1.1.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/lincvs/lincvs-1.1.4.ebuild,v 1.1 2003/03/22 14:23:23 alain Exp $
+
+IUSE="kde"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A Graphical CVS Client"
+SRC_URI="http://ppprs1.phy.tu-dresden.de/~trogisch/${PN}/download/LinCVS/${P}/${P}-0-generic-src.tgz"
+HOMEPAGE="http://www.lincvs.org"
+
+SLOT="0"
+KEYWORDS="x86 ~sparc"
+LICENSE="GPL-2"
+
+DEPEND="kde? ( >=kde-base/kdelibs-2 )
+ >=x11-libs/qt-3.0.5
+ >=cvs-1.9"
+
+RDEPEND="${DEPEND}
+ dev-util/cvs"
+
+src_compile() {
+ # Patch wrapper script
+ patch -p0 < ${FILESDIR}/${PN}-${PV}-gentoo.diff
+
+ qmake -o Makefile lincvs.pro
+ sed -e "s/^\tstrip/#\tstrip/" -i Makefile
+ emake || die "make failed"
+ emake install || die "make install failed"
+}
+
+src_install () {
+ mkdir -p ${D}/usr/share
+ cp -pR ${S}/LinCVS ${D}/usr/share
+ dobin ${S}/LinCVS/lincvs
+}