summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-02-14 22:23:40 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-02-14 22:23:40 +0000
commitd669663b179d7ff13e67b719471443b8213b834c (patch)
tree887735ff2a7e123e3436bed32c05586ea40b899c /dev-util/gtk-doc
parentVersion bump. Now provides gtkdoc-rebase, refs bug #262491. (diff)
downloadhistorical-d669663b179d7ff13e67b719471443b8213b834c.tar.gz
historical-d669663b179d7ff13e67b719471443b8213b834c.tar.bz2
historical-d669663b179d7ff13e67b719471443b8213b834c.zip
Version bump. gtkdoc-rebase moved to gtk-doc-am, refs bug #262491.
Package-Manager: portage-2.2_rc62/cvs/Linux x86_64
Diffstat (limited to 'dev-util/gtk-doc')
-rw-r--r--dev-util/gtk-doc/ChangeLog9
-rw-r--r--dev-util/gtk-doc/gtk-doc-1.13.ebuild83
2 files changed, 90 insertions, 2 deletions
diff --git a/dev-util/gtk-doc/ChangeLog b/dev-util/gtk-doc/ChangeLog
index 1922561138b1..7cb54f1c5154 100644
--- a/dev-util/gtk-doc/ChangeLog
+++ b/dev-util/gtk-doc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/gtk-doc
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gtk-doc/ChangeLog,v 1.114 2009/10/26 17:58:47 armin76 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gtk-doc/ChangeLog,v 1.115 2010/02/14 22:23:40 eva Exp $
+
+*gtk-doc-1.13 (14 Feb 2010)
+
+ 14 Feb 2010; Gilles Dartiguelongue <eva@gentoo.org> +gtk-doc-1.13.ebuild:
+ Version bump. gtkdoc-rebase moved to gtk-doc-am, refs bug #262491.
26 Oct 2009; Raúl Porcel <armin76@gentoo.org> gtk-doc-1.11.ebuild:
ia64/m68k/s390/sh/sparc stable wrt #285586
diff --git a/dev-util/gtk-doc/gtk-doc-1.13.ebuild b/dev-util/gtk-doc/gtk-doc-1.13.ebuild
new file mode 100644
index 000000000000..04a31ee71435
--- /dev/null
+++ b/dev-util/gtk-doc/gtk-doc-1.13.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gtk-doc/gtk-doc-1.13.ebuild,v 1.1 2010/02/14 22:23:40 eva Exp $
+
+EAPI="2"
+
+inherit eutils elisp-common gnome2
+
+DESCRIPTION="GTK+ Documentation Generator"
+HOMEPAGE="http://www.gtk.org/gtk-doc/"
+
+LICENSE="GPL-2 FDL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="debug doc emacs test"
+
+RDEPEND=">=dev-libs/glib-2.6
+ >=dev-lang/perl-5.6
+ >=app-text/openjade-1.3.1
+ dev-libs/libxslt
+ >=dev-libs/libxml2-2.3.6
+ ~app-text/docbook-xml-dtd-4.3
+ app-text/docbook-xsl-stylesheets
+ ~app-text/docbook-sgml-dtd-3.0
+ >=app-text/docbook-dsssl-stylesheets-1.40
+ emacs? ( virtual/emacs )"
+
+DEPEND="${RDEPEND}
+ ~dev-util/gtk-doc-am-${PV}
+ >=dev-util/pkgconfig-0.19
+ >=app-text/scrollkeeper-0.3.14
+ >=app-text/gnome-doc-utils-0.3.2
+ test? ( app-text/scrollkeeper-dtd )"
+
+SITEFILE=61${PN}-gentoo.el
+
+DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README TODO"
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Remove global Emacs keybindings.
+ epatch "${FILESDIR}/${PN}-1.8-emacs-keybindings.patch"
+}
+
+src_compile() {
+ gnome2_src_compile
+
+ use emacs && elisp-compile tools/gtk-doc.el
+}
+
+src_install() {
+ gnome2_src_install
+
+ # Don't install those files, they are in gtk-doc-am now
+ rm "${D}"/usr/share/aclocal/gtk-doc.m4 || die "failed to remove gtk-doc.m4"
+ rm "${D}"/usr/bin/gtkdoc-rebase || die "failed to remove gtkdoc-rebase"
+
+ if use doc; then
+ docinto doc
+ dodoc doc/*
+ docinto examples
+ dodoc examples/*
+ fi
+
+ if use emacs; then
+ elisp-install ${PN} tools/gtk-doc.el*
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ if use emacs; then
+ elisp-site-regen
+ elog "gtk-doc does no longer define global key bindings for Emacs."
+ elog "You may set your own key bindings for \"gtk-doc-insert\" and"
+ elog "\"gtk-doc-insert-section\" in your ~/.emacs file."
+ fi
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}