summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2012-11-26 19:59:19 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2012-11-26 19:59:19 +0000
commitd7fa98d8c63dd7e1323780948dfc4fd9bb739d95 (patch)
treef44487634197df06b395f8396602e45392a0776b /dev-util/glade/glade-3.12.2.ebuild
parentCleanup. (diff)
downloadhistorical-d7fa98d8c63dd7e1323780948dfc4fd9bb739d95.tar.gz
historical-d7fa98d8c63dd7e1323780948dfc4fd9bb739d95.tar.bz2
historical-d7fa98d8c63dd7e1323780948dfc4fd9bb739d95.zip
Add suggestion to install devhelp, bug #416495.
Package-Manager: portage-2.2.0_alpha142/cvs/Linux x86_64 Manifest-Sign-Key: 0xC6085806
Diffstat (limited to 'dev-util/glade/glade-3.12.2.ebuild')
-rw-r--r--dev-util/glade/glade-3.12.2.ebuild32
1 files changed, 20 insertions, 12 deletions
diff --git a/dev-util/glade/glade-3.12.2.ebuild b/dev-util/glade/glade-3.12.2.ebuild
index 36d8a329f488..22b22d85bb06 100644
--- a/dev-util/glade/glade-3.12.2.ebuild
+++ b/dev-util/glade/glade-3.12.2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/glade/glade-3.12.2.ebuild,v 1.1 2012/09/22 10:06:06 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/glade/glade-3.12.2.ebuild,v 1.2 2012/11/26 19:59:15 eva Exp $
EAPI="4"
-GNOME2_LA_PUNT="yes"
GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
inherit autotools eutils gnome2 versionator
@@ -42,16 +42,6 @@ DEPEND="${RDEPEND}
# dev-libs/gobject-introspection-common
# gnome-base/gnome-common
-pkg_setup() {
- DOCS="AUTHORS ChangeLog NEWS README TODO"
- G2CONF="${G2CONF}
- --disable-static
- --enable-libtool-lock
- --disable-scrollkeeper
- $(use_enable introspection)
- $(use_enable python)"
-}
-
src_prepare() {
# To avoid file collison with other slots, rename help module.
# Prevent the UI from loading glade:3's gladeui devhelp documentation.
@@ -60,6 +50,16 @@ src_prepare() {
gnome2_src_prepare
}
+src_configure() {
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+ G2CONF="${G2CONF}
+ --disable-static
+ --enable-libtool-lock
+ $(use_enable introspection)
+ $(use_enable python)"
+ gnome2_src_configure
+}
+
src_install() {
# modify Name in .desktop file to avoid confusion with other slots
sed -e 's:^\(Name.*=Glade\):\1 '$(get_version_component_range 1-2): \
@@ -69,3 +69,11 @@ src_install() {
-i doc/html/gladeui.devhelp2 || die "sed of gladeui.devhelp2 failed"
gnome2_src_install
}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ if ! has_version dev-util/devhelp ; then
+ elog "You may want to install dev-util/devhelp for integration API"
+ elog "documentation support."
+ fi
+}