summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2012-10-04 15:52:19 +0000
committerSebastian Pipping <sping@gentoo.org>2012-10-04 15:52:19 +0000
commit34c59180a905e6aeaacf921af0ff9bb822a955ee (patch)
treefc3afc0b6eb8a8ed6a40a46591e4224fe3d74698 /dev-util/cpptest/cpptest-1.1.2.ebuild
parentVersion bump (diff)
downloadhistorical-34c59180a905e6aeaacf921af0ff9bb822a955ee.tar.gz
historical-34c59180a905e6aeaacf921af0ff9bb822a955ee.tar.bz2
historical-34c59180a905e6aeaacf921af0ff9bb822a955ee.zip
dev-util/cpptest: 1.1.2
Package-Manager: portage-2.1.10.65/cvs/Linux x86_64
Diffstat (limited to 'dev-util/cpptest/cpptest-1.1.2.ebuild')
-rw-r--r--dev-util/cpptest/cpptest-1.1.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-util/cpptest/cpptest-1.1.2.ebuild b/dev-util/cpptest/cpptest-1.1.2.ebuild
new file mode 100644
index 000000000000..1cc1d5f73691
--- /dev/null
+++ b/dev-util/cpptest/cpptest-1.1.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cpptest/cpptest-1.1.2.ebuild,v 1.1 2012/10/04 15:52:19 sping Exp $
+
+EAPI=2
+
+DESCRIPTION="Simple but powerful unit testing framework for C++"
+HOMEPAGE="http://cpptest.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+src_configure() {
+ econf \
+ $(use_enable doc) \
+ --htmldir=/usr/share/doc/${PF}/html/
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc AUTHORS BUGS NEWS README || die
+
+ find "${D}" -type f -name '*.la' -delete || die
+}