summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2004-04-01 00:51:52 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2004-04-01 00:51:52 +0000
commit4b8e238e6fbcb6fc08751e01dc3ef72d364733bb (patch)
tree8705e167f33991a1b972f3b182938aaed7877741 /dev-util/cook/cook-2.24.ebuild
parentadded ~amd64 to keywords (diff)
downloadhistorical-4b8e238e6fbcb6fc08751e01dc3ef72d364733bb.tar.gz
historical-4b8e238e6fbcb6fc08751e01dc3ef72d364733bb.tar.bz2
historical-4b8e238e6fbcb6fc08751e01dc3ef72d364733bb.zip
New upstream release. Fixes #38709.
Diffstat (limited to 'dev-util/cook/cook-2.24.ebuild')
-rw-r--r--dev-util/cook/cook-2.24.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-util/cook/cook-2.24.ebuild b/dev-util/cook/cook-2.24.ebuild
new file mode 100644
index 000000000000..1f7fa25baddd
--- /dev/null
+++ b/dev-util/cook/cook-2.24.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cook/cook-2.24.ebuild,v 1.1 2004/04/01 00:51:52 karltk Exp $
+
+DESCRIPTION="tool for constructing files; a drop in replacement for make"
+SRC_URI="http://www.canb.auug.org.au/~millerp/cook/${P}.tar.gz"
+HOMEPAGE="http://www.canb.auug.org.au/~millerp/cook/cook.html"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc"
+
+DEPEND="sys-devel/bison"
+
+src_compile() {
+ econf || die "./configure failed"
+ make || die # doesn't seem to like emake
+}
+
+src_install() {
+ # we'll hijack the RPM_BUILD_ROOT variable which is intended for a
+ # similiar purpose anyway
+ make RPM_BUILD_ROOT=${D} install || die
+}