summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-06-04 15:34:18 +0000
committerTim Harder <radhermit@gentoo.org>2011-06-04 15:34:18 +0000
commit98e003efc24b0822bf92a2b403701a6a2d855c26 (patch)
tree2d17058b207125a7268a310b33b05ba13790a088 /dev-util/cmockery/cmockery-0.1.2.ebuild
parent[bump] dev-perl/Test-WWW-Mechanize-1.320.0 (diff)
downloadhistorical-98e003efc24b0822bf92a2b403701a6a2d855c26.tar.gz
historical-98e003efc24b0822bf92a2b403701a6a2d855c26.tar.bz2
historical-98e003efc24b0822bf92a2b403701a6a2d855c26.zip
Initial import (bug #339070).
Package-Manager: portage-2.2.0_alpha37/cvs/Linux x86_64
Diffstat (limited to 'dev-util/cmockery/cmockery-0.1.2.ebuild')
-rw-r--r--dev-util/cmockery/cmockery-0.1.2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-util/cmockery/cmockery-0.1.2.ebuild b/dev-util/cmockery/cmockery-0.1.2.ebuild
new file mode 100644
index 000000000000..af98ccc61ba9
--- /dev/null
+++ b/dev-util/cmockery/cmockery-0.1.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmockery/cmockery-0.1.2.ebuild,v 1.1 2011/06/04 15:34:18 radhermit Exp $
+
+EAPI=4
+
+inherit autotools
+
+DESCRIPTION="A lightweight library to simplify writing unit tests for C applications"
+HOMEPAGE="http://code.google.com/p/cmockery/"
+SRC_URI="http://cmockery.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples static-libs"
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ sed -i -e "/dist_doc_DATA/{N;d}" Makefile.am
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ dohtml doc/*
+
+ if use examples ; then
+ docinto examples
+ dodoc src/example/*
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ use static-libs || find "${D}" -name '*.la' -exec rm -f '{}' +
+}