summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSandro Bonazzola <sanchan@gentoo.org>2006-08-09 19:30:02 +0000
committerSandro Bonazzola <sanchan@gentoo.org>2006-08-09 19:30:02 +0000
commitf5e3ae001c53b6d495562c7bcdd0b9e69f129d84 (patch)
tree5a696df6669bbaeaaa4114894dd40bb1bfe9d917 /dev-tinyos/nesc
parentRemoved 'qt' USE flag per bug #137785 (diff)
downloadhistorical-f5e3ae001c53b6d495562c7bcdd0b9e69f129d84.tar.gz
historical-f5e3ae001c53b6d495562c7bcdd0b9e69f129d84.tar.bz2
historical-f5e3ae001c53b6d495562c7bcdd0b9e69f129d84.zip
Version bump. Should fix bug #142263.
Package-Manager: portage-2.1.1_pre4-r4
Diffstat (limited to 'dev-tinyos/nesc')
-rw-r--r--dev-tinyos/nesc/ChangeLog8
-rw-r--r--dev-tinyos/nesc/files/digest-nesc-1.2.7a3
-rw-r--r--dev-tinyos/nesc/nesc-1.2.7a.ebuild60
3 files changed, 70 insertions, 1 deletions
diff --git a/dev-tinyos/nesc/ChangeLog b/dev-tinyos/nesc/ChangeLog
index 5ec027b38abd..952b450d5851 100644
--- a/dev-tinyos/nesc/ChangeLog
+++ b/dev-tinyos/nesc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-tinyos/nesc
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tinyos/nesc/ChangeLog,v 1.9 2006/08/09 18:32:03 sanchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tinyos/nesc/ChangeLog,v 1.10 2006/08/09 19:30:02 sanchan Exp $
+
+*nesc-1.2.7a (09 Aug 2006)
+
+ 09 Aug 2006; Sandro Bonazzola <sanchan@gentoo.org> -nesc-1.2.6-r1.ebuild,
+ +nesc-1.2.7a.ebuild:
+ Version bump. Should fix bug #142263.
09 Aug 2006; Sandro Bonazzola <sanchan@gentoo.org> nesc-1.2.6-r1.ebuild:
Masking due to bug #142263. Still here untill I can produce a 1.2.7a ebuild.
diff --git a/dev-tinyos/nesc/files/digest-nesc-1.2.7a b/dev-tinyos/nesc/files/digest-nesc-1.2.7a
new file mode 100644
index 000000000000..e380e9742232
--- /dev/null
+++ b/dev-tinyos/nesc/files/digest-nesc-1.2.7a
@@ -0,0 +1,3 @@
+MD5 13928224cb8e6dd3d9412ca904f12dd3 nesc-1.2.7a.tar.gz 1156734
+RMD160 c322df1521f3cd8961c2de81d13e59ffdd1bede0 nesc-1.2.7a.tar.gz 1156734
+SHA256 f2f63cac8d72b0a9ffbdd65472018ce9194d9ef89f8ef7d0e33180a4818455e1 nesc-1.2.7a.tar.gz 1156734
diff --git a/dev-tinyos/nesc/nesc-1.2.7a.ebuild b/dev-tinyos/nesc/nesc-1.2.7a.ebuild
new file mode 100644
index 000000000000..f544c602cf2f
--- /dev/null
+++ b/dev-tinyos/nesc/nesc-1.2.7a.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tinyos/nesc/nesc-1.2.7a.ebuild,v 1.1 2006/08/09 19:30:02 sanchan Exp $
+
+inherit eutils
+
+DESCRIPTION="An extension to gcc that knows how to compile nesC applications"
+HOMEPAGE="http://nescc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/nescc/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc"
+DEPEND=">=dev-lang/perl-5.8.5-r2
+ >=dev-tinyos/tos-1.1.0
+ >=virtual/jdk-1.4.2"
+
+RDEPEND=">=dev-lang/perl-5.8.5-r2
+ >=dev-tinyos/tos-1.1.0
+ >=virtual/jre-1.4.2
+ dev-perl/XML-Simple"
+
+pkg_setup() {
+ if [ -z "${TOSDIR}" ]
+ then
+ # best to make an assumption
+ export TOSDIR=/usr/src/tinyos-1.x/tos
+ fi
+
+ if [ ! -d "${TOSDIR}" ]
+ then
+ eerror "In order to compile nesc you have to set the"
+ eerror "\$TOSDIR environment properly."
+ eerror ""
+ eerror "You can achieve this by emerging >=dev-tinyos/tos-1.1.15"
+ eerror "or by exporting TOSDIR=\"path to your tinyos dir\""
+ die "Couldn't find a valid TinyOS home"
+ else
+ einfo "Building nesC for ${TOSDIR}"
+ fi
+}
+
+src_compile() {
+ econf --disable-dependency-tracking || die "econf failed"
+ # language setting needed, otherwise gcc version
+ # will sometimes not be detected right
+ LANGUAGE=C emake || die "emake failed"
+}
+
+src_install() {
+ LANGUAGE=C einstall || die "einstall failed"
+ if use doc
+ then
+ dohtml -r -a html,jpg,pdf,txt doc/*
+ fi
+ newdoc README NEWS
+ dodoc doc/README
+ newdoc tools/java/net/tinyos/nesc/dump/README README.dump
+ newdoc tools/java/net/tinyos/nesc/wiring/README README.wiring
+}