summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-09-24 16:20:43 +0000
committerHans de Graaff <graaff@gentoo.org>2012-09-24 16:20:43 +0000
commit99fb0d85b21973b36e279dffe0560d970af167fe (patch)
tree6e3a7a93e7a919829d25b27d262d9ed9487574e8 /dev-ruby
parentVersion bump. (diff)
downloadhistorical-99fb0d85b21973b36e279dffe0560d970af167fe.tar.gz
historical-99fb0d85b21973b36e279dffe0560d970af167fe.tar.bz2
historical-99fb0d85b21973b36e279dffe0560d970af167fe.zip
Cleanup.
Package-Manager: portage-2.1.11.9/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/unf_ext/ChangeLog5
-rw-r--r--dev-ruby/unf_ext/unf_ext-0.0.4.ebuild41
-rw-r--r--dev-ruby/uuidtools/ChangeLog5
-rw-r--r--dev-ruby/uuidtools/uuidtools-2.1.2.ebuild31
-rw-r--r--dev-ruby/vlad/ChangeLog5
-rw-r--r--dev-ruby/vlad/vlad-2.2.4.ebuild28
6 files changed, 12 insertions, 103 deletions
diff --git a/dev-ruby/unf_ext/ChangeLog b/dev-ruby/unf_ext/ChangeLog
index 756b92d09b47..e796b3a57a85 100644
--- a/dev-ruby/unf_ext/ChangeLog
+++ b/dev-ruby/unf_ext/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ruby/unf_ext
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/unf_ext/ChangeLog,v 1.3 2012/08/14 16:57:17 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/unf_ext/ChangeLog,v 1.4 2012/09/24 16:18:30 graaff Exp $
+
+ 24 Sep 2012; Hans de Graaff <graaff@gentoo.org> -unf_ext-0.0.4.ebuild:
+ Cleanup.
14 Aug 2012; Diego E. Pettenò <flameeyes@gentoo.org> unf_ext-0.0.5.ebuild:
Disable test task (drops rake dependency for USE=test); use Test::Unit 2 and
diff --git a/dev-ruby/unf_ext/unf_ext-0.0.4.ebuild b/dev-ruby/unf_ext/unf_ext-0.0.4.ebuild
deleted file mode 100644
index 9443ee2853d0..000000000000
--- a/dev-ruby/unf_ext/unf_ext-0.0.4.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/unf_ext/unf_ext-0.0.4.ebuild,v 1.1 2012/04/09 07:07:28 graaff Exp $
-
-EAPI=4
-
-USE_RUBY="ruby18 ruby19 ree18"
-
-RUBY_FAKEGEM_DOCDIR="doc"
-
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-inherit ruby-fakegem multilib
-
-DESCRIPTION="Unicode Normalization Form support library for CRuby"
-HOMEPAGE="http://sourceforge.jp/projects/unf/"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="doc test"
-
-ruby_add_bdepend "doc? ( dev-ruby/hoe dev-ruby/jeweler )
- test? ( dev-ruby/shoulda )"
-
-all_ruby_prepare() {
- sed -i -e '/bundler/,/end/ s:^:#:' Rakefile test/helper.rb || die
-}
-
-each_ruby_configure() {
- ${RUBY} -Cext/unf_ext extconf.rb || die
-}
-
-each_ruby_compile() {
- emake -Cext/unf_ext
- cp ext/unf_ext/*$(get_modname) lib/ || die
-}
-
-each_ruby_test() {
- ${RUBY} -S testrb test/test_*.rb || die
-}
diff --git a/dev-ruby/uuidtools/ChangeLog b/dev-ruby/uuidtools/ChangeLog
index 66e7a2ab01c9..9462cd7e5324 100644
--- a/dev-ruby/uuidtools/ChangeLog
+++ b/dev-ruby/uuidtools/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ruby/uuidtools
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/uuidtools/ChangeLog,v 1.26 2012/07/20 05:48:52 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/uuidtools/ChangeLog,v 1.27 2012/09/24 16:19:26 graaff Exp $
+
+ 24 Sep 2012; Hans de Graaff <graaff@gentoo.org> -uuidtools-2.1.2.ebuild:
+ Cleanup.
*uuidtools-2.1.3 (20 Jul 2012)
diff --git a/dev-ruby/uuidtools/uuidtools-2.1.2.ebuild b/dev-ruby/uuidtools/uuidtools-2.1.2.ebuild
deleted file mode 100644
index 6cd0c860c378..000000000000
--- a/dev-ruby/uuidtools/uuidtools-2.1.2.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/uuidtools/uuidtools-2.1.2.ebuild,v 1.2 2012/07/10 08:31:50 flameeyes Exp $
-
-EAPI=2
-
-USE_RUBY="ruby18 ruby19 jruby ree18"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
-
-RUBY_FAKEGEM_TASK_DOC="doc"
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Simple library to generate UUIDs"
-HOMEPAGE="http://uuidtools.rubyforge.org/"
-SRC_URI="mirror://rubyforge/${PN}/${P}.tgz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~x86-macos"
-IUSE=""
-
-# Rakefile does not work without rspec (and is quite difficult to work
-# it around).
-ruby_add_bdepend "
- doc? ( >=dev-ruby/rspec-1.0.8:0 )"
-
-RUBY_PATCHES=( ${P}-macaddress.patch )
diff --git a/dev-ruby/vlad/ChangeLog b/dev-ruby/vlad/ChangeLog
index 360a6358c333..0a1e094348f5 100644
--- a/dev-ruby/vlad/ChangeLog
+++ b/dev-ruby/vlad/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ruby/vlad
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/vlad/ChangeLog,v 1.18 2012/04/22 07:30:15 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/vlad/ChangeLog,v 1.19 2012/09/24 16:20:43 graaff Exp $
+
+ 24 Sep 2012; Hans de Graaff <graaff@gentoo.org> -vlad-2.2.4.ebuild:
+ Cleanup.
*vlad-2.2.5 (22 Apr 2012)
diff --git a/dev-ruby/vlad/vlad-2.2.4.ebuild b/dev-ruby/vlad/vlad-2.2.4.ebuild
deleted file mode 100644
index d545d0cfc482..000000000000
--- a/dev-ruby/vlad/vlad-2.2.4.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/vlad/vlad-2.2.4.ebuild,v 1.1 2011/12/22 07:07:59 graaff Exp $
-
-EAPI=4
-USE_RUBY="ruby18"
-
-RUBY_FAKEGEM_TASK_DOC="docs"
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="considerations.txt History.txt README.txt"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Pragmatic application deployment automation, without mercy."
-HOMEPAGE="http://rubyhitsquad.com/Vlad_the_Deployer.html"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-ruby_add_bdepend ">=dev-ruby/hoe-2.9.2 test? ( dev-ruby/minitest )"
-ruby_add_rdepend ">=dev-ruby/rake-remote_task-2.0.0"
-
-all_ruby_prepare() {
- # Keep Isolate from managing the dependencies.
- sed -i -e '/isolate/ s:^:#:' Rakefile || die
-}