summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-12-27 18:56:11 +0000
committerHans de Graaff <graaff@gentoo.org>2010-12-27 18:56:11 +0000
commit3e5e9bcc22f18ba12b1631cc5e22b71f3b92fbdb (patch)
tree13661a4830d69d21c981a68b9145dce8abe4db58 /dev-ruby
parentFix #349840 (incorrect symlinks to /bin/rpm) (diff)
downloadhistorical-3e5e9bcc22f18ba12b1631cc5e22b71f3b92fbdb.tar.gz
historical-3e5e9bcc22f18ba12b1631cc5e22b71f3b92fbdb.tar.bz2
historical-3e5e9bcc22f18ba12b1631cc5e22b71f3b92fbdb.zip
Drop ruby19 support to create a stable candidate.
Package-Manager: portage-2.1.9.25/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/daemons/ChangeLog8
-rw-r--r--dev-ruby/daemons/daemons-1.1.0-r1.ebuild30
-rw-r--r--dev-ruby/daemons/daemons-1.1.0.ebuild4
-rw-r--r--dev-ruby/gem_plugin/ChangeLog8
-rw-r--r--dev-ruby/gem_plugin/gem_plugin-0.2.3-r1.ebuild4
-rw-r--r--dev-ruby/gem_plugin/gem_plugin-0.2.3-r2.ebuild28
6 files changed, 76 insertions, 6 deletions
diff --git a/dev-ruby/daemons/ChangeLog b/dev-ruby/daemons/ChangeLog
index deb1e0e89de0..70822b71fb7e 100644
--- a/dev-ruby/daemons/ChangeLog
+++ b/dev-ruby/daemons/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/daemons
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/daemons/ChangeLog,v 1.48 2010/10/08 09:41:34 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/daemons/ChangeLog,v 1.49 2010/12/27 18:54:51 graaff Exp $
+
+*daemons-1.1.0-r1 (27 Dec 2010)
+
+ 27 Dec 2010; Hans de Graaff <graaff@gentoo.org> daemons-1.1.0.ebuild,
+ +daemons-1.1.0-r1.ebuild:
+ Drop ruby19 support to create a stable candidate.
08 Oct 2010; Hans de Graaff <graaff@gentoo.org> -daemons-1.0.10-r1.ebuild:
Remove old version.
diff --git a/dev-ruby/daemons/daemons-1.1.0-r1.ebuild b/dev-ruby/daemons/daemons-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..60c06237e362
--- /dev/null
+++ b/dev-ruby/daemons/daemons-1.1.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/daemons/daemons-1.1.0-r1.ebuild,v 1.1 2010/12/27 18:54:51 graaff Exp $
+
+EAPI="2"
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_EXTRADOC="Releases README TODO"
+RUBY_FAKEGEM_DOCDIR="html"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Wrap existing ruby scripts to be run as a daemon"
+HOMEPAGE="http://daemons.rubyforge.org/"
+
+LICENSE="|| ( Ruby GPL-2 ) MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="examples"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ use examples || return
+
+ insinto /usr/share/doc/${PF}/
+ doins -r examples || die "Failed to install examples"
+}
diff --git a/dev-ruby/daemons/daemons-1.1.0.ebuild b/dev-ruby/daemons/daemons-1.1.0.ebuild
index 36b8844e255c..fc649979320a 100644
--- a/dev-ruby/daemons/daemons-1.1.0.ebuild
+++ b/dev-ruby/daemons/daemons-1.1.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/daemons/daemons-1.1.0.ebuild,v 1.1 2010/07/19 06:53:23 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/daemons/daemons-1.1.0.ebuild,v 1.2 2010/12/27 18:54:51 graaff Exp $
EAPI="2"
-USE_RUBY="ruby18 ree18 ruby19 jruby"
+USE_RUBY="ruby18 ree18 jruby"
RUBY_FAKEGEM_EXTRADOC="Releases README TODO"
RUBY_FAKEGEM_DOCDIR="html"
diff --git a/dev-ruby/gem_plugin/ChangeLog b/dev-ruby/gem_plugin/ChangeLog
index eb67da3ee1f4..6320450fc819 100644
--- a/dev-ruby/gem_plugin/ChangeLog
+++ b/dev-ruby/gem_plugin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/gem_plugin
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gem_plugin/ChangeLog,v 1.21 2010/01/23 23:08:14 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gem_plugin/ChangeLog,v 1.22 2010/12/27 18:56:11 graaff Exp $
+
+*gem_plugin-0.2.3-r2 (27 Dec 2010)
+
+ 27 Dec 2010; Hans de Graaff <graaff@gentoo.org>
+ gem_plugin-0.2.3-r1.ebuild, +gem_plugin-0.2.3-r2.ebuild:
+ Drop ruby19 support to create a stable candidate.
23 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org>
gem_plugin-0.2.3-r1.ebuild:
diff --git a/dev-ruby/gem_plugin/gem_plugin-0.2.3-r1.ebuild b/dev-ruby/gem_plugin/gem_plugin-0.2.3-r1.ebuild
index 113fffb396df..7de50ec6a18e 100644
--- a/dev-ruby/gem_plugin/gem_plugin-0.2.3-r1.ebuild
+++ b/dev-ruby/gem_plugin/gem_plugin-0.2.3-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gem_plugin/gem_plugin-0.2.3-r1.ebuild,v 1.2 2010/01/23 23:08:14 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gem_plugin/gem_plugin-0.2.3-r1.ebuild,v 1.3 2010/12/27 18:56:11 graaff Exp $
EAPI="2"
-USE_RUBY="ruby18 ruby19 jruby"
+USE_RUBY="ruby18 jruby"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_TASK_TEST=""
diff --git a/dev-ruby/gem_plugin/gem_plugin-0.2.3-r2.ebuild b/dev-ruby/gem_plugin/gem_plugin-0.2.3-r2.ebuild
new file mode 100644
index 000000000000..649f8345331c
--- /dev/null
+++ b/dev-ruby/gem_plugin/gem_plugin-0.2.3-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gem_plugin/gem_plugin-0.2.3-r2.ebuild,v 1.1 2010/12/27 18:56:11 graaff Exp $
+
+EAPI="2"
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+
+RUBY_FAKEGEM_EXTRAINSTALL="resources"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A plugin system based only on rubygems that uses dependencies only."
+# Hosted by mongrel's rubyforge
+HOMEPAGE="http://mongrel.rubyforge.org/"
+
+LICENSE="mongrel"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+each_fakegem_test() {
+ ${RUBY} -Ilib test/test_plugins.rb || die "tests failed"
+}