summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2002-04-22 01:07:15 +0000
committerAron Griffis <agriffis@gentoo.org>2002-04-22 01:07:15 +0000
commit9a990f653ca9c01cbe8024da19e94b056cb84ee1 (patch)
tree613e38ff115dc83554c8d5af32b38781cbc7a297 /dev-ruby/ruby-panel-applet
parentupdated package (diff)
downloadhistorical-9a990f653ca9c01cbe8024da19e94b056cb84ee1.tar.gz
historical-9a990f653ca9c01cbe8024da19e94b056cb84ee1.tar.bz2
historical-9a990f653ca9c01cbe8024da19e94b056cb84ee1.zip
Updated lots of ruby-gtk/gnome stuff. Modified ruby-gtk to use the
unified tarball so that all these other ebuilds can use the same tarball. This makes building easier, too, since the ruby-gtk header files are available for each ebuild (otherwise we'd have to install them).
Diffstat (limited to 'dev-ruby/ruby-panel-applet')
-rw-r--r--dev-ruby/ruby-panel-applet/ruby-panel-applet-0.27.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ruby/ruby-panel-applet/ruby-panel-applet-0.27.ebuild b/dev-ruby/ruby-panel-applet/ruby-panel-applet-0.27.ebuild
new file mode 100644
index 000000000000..8f57f9f4d8cb
--- /dev/null
+++ b/dev-ruby/ruby-panel-applet/ruby-panel-applet-0.27.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Jerry Alexandratos <jerry@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-panel-applet/ruby-panel-applet-0.27.ebuild,v 1.1 2002/04/22 01:07:15 agriffis Exp $
+
+S=${WORKDIR}/ruby-gnome-all-${PV}/panel-applet
+DESCRIPTION="Ruby Gnome Panel bindings"
+SRC_URI="http://prdownloads.sourceforge.net/ruby-gnome/ruby-gnome-all-${PV}.tar.gz"
+HOMEPAGE="http://ruby-gnome.sourceforge.net/"
+
+DEPEND=">=dev-lang/ruby-1.6.4-r1
+ >=dev-ruby/ruby-gnome-${PV}"
+
+src_compile() {
+ ruby extconf.rb || die "ruby extconf.rb failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ make site-install DESTDIR=${D}
+ dodoc [A-Z]*
+ cp -dr sample ${D}/usr/share/doc/${PF}
+}