summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2005-03-31 00:45:49 +0000
committerRob Cakebread <pythonhead@gentoo.org>2005-03-31 00:45:49 +0000
commit6608ab4fa4f11dd0a494b732959acfbbd807a6b5 (patch)
treeb9a0b84895977762aa3b7fe89684f4bb36160645 /dev-ruby/redcloth
parentAdded check for MY_P. Removed src_test (diff)
downloadhistorical-6608ab4fa4f11dd0a494b732959acfbbd807a6b5.tar.gz
historical-6608ab4fa4f11dd0a494b732959acfbbd807a6b5.tar.bz2
historical-6608ab4fa4f11dd0a494b732959acfbbd807a6b5.zip
Reverted to using MY_P after fixing eclass to recognize MY_P. Closes bug# 87304
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'dev-ruby/redcloth')
-rw-r--r--dev-ruby/redcloth/ChangeLog5
-rw-r--r--dev-ruby/redcloth/Manifest16
-rw-r--r--dev-ruby/redcloth/files/digest-redcloth-3.0.32
-rw-r--r--dev-ruby/redcloth/redcloth-3.0.3.ebuild22
4 files changed, 37 insertions, 8 deletions
diff --git a/dev-ruby/redcloth/ChangeLog b/dev-ruby/redcloth/ChangeLog
index e0432e3d7285..bc87ee7033ea 100644
--- a/dev-ruby/redcloth/ChangeLog
+++ b/dev-ruby/redcloth/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ruby/redcloth
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/redcloth/ChangeLog,v 1.4 2005/03/30 17:49:43 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/redcloth/ChangeLog,v 1.5 2005/03/31 00:45:49 pythonhead Exp $
+
+ 31 Mar 2005; Rob Cakebread <pythonhead@gentoo.org> redcloth-3.0.3.ebuild:
+ Reverted to using MY_P after fixing eclass to recognize MY_P. Closes bug# 87304
*redcloth-3.0.3 (30 Mar 2005)
diff --git a/dev-ruby/redcloth/Manifest b/dev-ruby/redcloth/Manifest
index 92db15653352..31c39381d09b 100644
--- a/dev-ruby/redcloth/Manifest
+++ b/dev-ruby/redcloth/Manifest
@@ -1,6 +1,16 @@
-MD5 174d8449be50f367b8d3b1533ea590e2 redcloth-3.0.3.ebuild 514
-MD5 72db558f75e520c75ff7f52bc1c8516e ChangeLog 835
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 6581990bee8491bbb2b432dca2ae5b40 ChangeLog 999
MD5 1a24e0b48460c02e20931fceded24e1a metadata.xml 254
+MD5 bd6be6c982bd8e443125c4dc4d3ece0f redcloth-3.0.3.ebuild 956
MD5 579dbfc457f6f2e8e8974f5043227e9c redcloth-3.0.2.ebuild 913
+MD5 063890b46cdc8872cd1fcc32263e3b21 files/digest-redcloth-3.0.3 62
MD5 b9838cf4682185a89eca06878760ad48 files/digest-redcloth-3.0.2 65
-MD5 7ae47aa30e7bfcf4a2fd60d2076ca7dd files/digest-redcloth-3.0.3 62
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.0 (GNU/Linux)
+
+iD8DBQFCS0hMz2gxt1z4IGYRAjYQAJ9FSQt0Ed+4TE8wxZakw7JQ7k8m/gCg6j27
+K8W4CEzHyiiJn4Lw9BAT2Hg=
+=lLyd
+-----END PGP SIGNATURE-----
diff --git a/dev-ruby/redcloth/files/digest-redcloth-3.0.3 b/dev-ruby/redcloth/files/digest-redcloth-3.0.3
index 36e5ac97c56e..db05ea6d2bd4 100644
--- a/dev-ruby/redcloth/files/digest-redcloth-3.0.3
+++ b/dev-ruby/redcloth/files/digest-redcloth-3.0.3
@@ -1 +1 @@
-MD5 a12563b9bd3240328ac9b4eb471ea3ba redcloth-3.0.3.gem 23040
+MD5 a12563b9bd3240328ac9b4eb471ea3ba RedCloth-3.0.3.gem 23040
diff --git a/dev-ruby/redcloth/redcloth-3.0.3.ebuild b/dev-ruby/redcloth/redcloth-3.0.3.ebuild
index 64943a1ef452..2d3024773fbb 100644
--- a/dev-ruby/redcloth/redcloth-3.0.3.ebuild
+++ b/dev-ruby/redcloth/redcloth-3.0.3.ebuild
@@ -1,12 +1,13 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/redcloth/redcloth-3.0.3.ebuild,v 1.1 2005/03/30 17:49:43 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/redcloth/redcloth-3.0.3.ebuild,v 1.2 2005/03/31 00:45:49 pythonhead Exp $
inherit ruby gems
+MY_P="RedCloth-${PV}"
DESCRIPTION="A module for using Textile in Ruby"
HOMEPAGE="http://www.whytheluckystiff.net/ruby/redcloth/"
-SRC_URI="http://rubyforge.org/frs/download.php/2898/${P}.gem"
+SRC_URI="http://rubyforge.org/frs/download.php/2898/${MY_P}.gem"
LICENSE="BSD"
SLOT="0"
@@ -16,4 +17,19 @@ IUSE=""
USE_RUBY="any"
DEPEND="virtual/ruby"
-S=${WORKDIR}/${P}
+S=${WORKDIR}/${MY_P}
+
+
+pkg_postinst() {
+ einfo "NOTE: This package is now installed via a 'gem'."
+ einfo "Previous versions used a standard tarball."
+ einfo "No packages in portage required ${PN}, so you won't be affected unless"
+ einfo "you have written ruby code which requires ${PN}. In that case you'll need"
+ einfo "to add this:"
+ einfo " "
+ einfo "require 'rubygems'"
+ einfo " "
+ einfo "before:"
+ einfo "require '${PN}'"
+}
+