summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Legler <a3li@gentoo.org>2009-11-28 11:20:27 +0000
committerAlex Legler <a3li@gentoo.org>2009-11-28 11:20:27 +0000
commitd23a51420d0645279a9146451274a92fe29bc1c8 (patch)
treed45291c4cbca2f448b5b91a553d283df75055828 /dev-ruby/rails
parentRevision bump, security bug 294797. Remove stale patch (diff)
downloadhistorical-d23a51420d0645279a9146451274a92fe29bc1c8.tar.gz
historical-d23a51420d0645279a9146451274a92fe29bc1c8.tar.bz2
historical-d23a51420d0645279a9146451274a92fe29bc1c8.zip
Revision bump, security bug 294797.
Package-Manager: portage-2.2_rc52/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/rails')
-rw-r--r--dev-ruby/rails/ChangeLog7
-rw-r--r--dev-ruby/rails/rails-2.2.3-r1.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/dev-ruby/rails/ChangeLog b/dev-ruby/rails/ChangeLog
index a2b3c9e1c903..c46e1afa82e7 100644
--- a/dev-ruby/rails/ChangeLog
+++ b/dev-ruby/rails/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rails
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.158 2009/11/28 09:34:07 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.159 2009/11/28 11:20:27 a3li Exp $
+
+*rails-2.2.3-r1 (28 Nov 2009)
+
+ 28 Nov 2009; Alex Legler <a3li@gentoo.org> +rails-2.2.3-r1.ebuild:
+ Revision bump, security bug 294797.
*rails-2.3.5 (28 Nov 2009)
diff --git a/dev-ruby/rails/rails-2.2.3-r1.ebuild b/dev-ruby/rails/rails-2.2.3-r1.ebuild
new file mode 100644
index 000000000000..d8aa701d9a9a
--- /dev/null
+++ b/dev-ruby/rails/rails-2.2.3-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/rails-2.2.3-r1.ebuild,v 1.1 2009/11/28 11:20:27 a3li Exp $
+
+inherit ruby gems
+USE_RUBY="ruby18"
+
+DESCRIPTION="ruby on rails is a web-application and persistance framework"
+HOMEPAGE="http://www.rubyonrails.org"
+
+LICENSE="MIT"
+SLOT="2.2"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="fastcgi"
+DEPEND=">=dev-lang/ruby-1.8.5
+ >=app-admin/eselect-rails-0.14
+ >=dev-ruby/rake-0.8.3
+ ~dev-ruby/activerecord-2.2.3
+ ~dev-ruby/activeresource-2.2.3
+ ~dev-ruby/activesupport-2.2.3
+ ~dev-ruby/actionmailer-2.2.3
+ =dev-ruby/actionpack-2.2.3-r1"
+
+RDEPEND="${DEPEND}
+ fastcgi? ( >=dev-ruby/ruby-fcgi-0.8.6 )
+ >=dev-ruby/rubygems-1.3.1"
+
+src_install() {
+ gems_src_install
+ # Rename slotted files that may clash so that eselect can handle
+ # them
+ mv "${D}/usr/bin/rails" "${D}/usr/bin/rails-${PV}"
+ sed -i -e "s/>= 0/${PV}/" "${D}/usr/bin/rails-${PV}"
+ mv "${D}/${GEMSDIR}/bin/rails" "${D}/${GEMSDIR}/bin/rails-${PV}"
+}
+
+pkg_postinst() {
+ einfo "To select between slots of rails, use:"
+ einfo "\teselect rails"
+
+ eselect rails update
+}
+
+pkg_postrm() {
+ eselect rails update
+}