summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-08-30 22:46:22 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-08-30 22:46:22 +0000
commita734ed0905ec1bb41f27f34be9508700751380ee (patch)
tree382ed4790402d270e9e16818792b9a8fb926617e /dev-ruby/json
parenthttp://my.opera.com/desktopteam/blog/2010/08/30/speed-typing (diff)
downloadhistorical-a734ed0905ec1bb41f27f34be9508700751380ee.tar.gz
historical-a734ed0905ec1bb41f27f34be9508700751380ee.tar.bz2
historical-a734ed0905ec1bb41f27f34be9508700751380ee.zip
Re-remove json 1.2.2 since chef-* was fixed.
Package-Manager: portage-2.2_rc72/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/json')
-rw-r--r--dev-ruby/json/ChangeLog5
-rw-r--r--dev-ruby/json/json-1.2.2.ebuild65
2 files changed, 4 insertions, 66 deletions
diff --git a/dev-ruby/json/ChangeLog b/dev-ruby/json/ChangeLog
index 80218ade17b4..31deaf5954cb 100644
--- a/dev-ruby/json/ChangeLog
+++ b/dev-ruby/json/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ruby/json
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/ChangeLog,v 1.42 2010/08/30 22:30:08 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/ChangeLog,v 1.43 2010/08/30 22:46:22 flameeyes Exp $
+
+ 30 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org> -json-1.2.2.ebuild:
+ Re-remove json 1.2.2 since chef-* was fixed.
30 Aug 2010; Mark Loeser <halcy0n@gentoo.org> +json-1.2.2.ebuild:
Add version 1.2.2 back since app-admin/chef-* depends upon it
diff --git a/dev-ruby/json/json-1.2.2.ebuild b/dev-ruby/json/json-1.2.2.ebuild
deleted file mode 100644
index 12fa8c6c369c..000000000000
--- a/dev-ruby/json/json-1.2.2.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/json-1.2.2.ebuild,v 1.8 2010/08/30 22:30:08 halcy0n Exp $
-
-EAPI=2
-USE_RUBY="ruby18"
-
-RUBY_FAKEGEM_TASK_DOC="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGES TODO README"
-RUBY_FAKEGEM_DOCDIR="doc"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A JSON implementation as a Ruby extension."
-HOMEPAGE="http://json.rubyforge.org/"
-LICENSE="|| ( Ruby GPL-2 )"
-SRC_URI="mirror://rubygems/${P}.gem"
-
-KEYWORDS="amd64 ~hppa ia64 ~ppc ~ppc64 sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
-SLOT="0"
-IUSE=""
-
-RDEPEND="${RDEPEND}"
-DEPEND="${DEPEND}
- dev-util/ragel"
-
-ruby_add_bdepend "dev-ruby/rake
- test? ( virtual/ruby-test-unit )"
-
-all_ruby_prepare() {
- # Avoid building the extension twice!
- sed -i \
- -e 's| => :compile_ext||' \
- -e 's| => :clean||' \
- Rakefile || die "rakefile fix failed"
-}
-
-each_ruby_compile() {
- if [[ $(basename ${RUBY}) != "jruby" ]]; then
- ${RUBY} -S rake compile_ext || die "extension compile failed"
- fi
-}
-
-each_ruby_test() {
- # We have to set RUBYLIB because otherwise the tests will run
- # against the sytem-installed json; at the same time, we cannot
- # use the -I parameter because rake won't let it pass to the
- # testrb call that is executed down the road.
-
- RUBYLIB="${RUBYLIB}${RUBYLIB+:}lib:ext/json/ext" \
- ${RUBY} -S rake test_pure || die "pure ruby tests failed"
-
- if [[ $(basename ${RUBY}) != "jruby" ]]; then
- RUBYLIB="${RUBYLIB}${RUBYLIB+:}lib:ext/json/ext" \
- ${RUBY} -Ilib:ext/json/ext -S rake test_ext || die " ruby extension tests failed"
- fi
-}
-
-each_ruby_install() {
- each_fakegem_install
- if [[ $(basename ${RUBY}) != "jruby" ]]; then
- ruby_fakegem_newins ext/json/ext/generator.so lib/json/generator.so
- ruby_fakegem_newins ext/json/ext/parser.so lib/json/parser.so
- fi
-}