summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-12-10 06:41:14 +0000
committerHans de Graaff <graaff@gentoo.org>2014-12-10 06:41:14 +0000
commit0cd0027dae547210d57f115f0b3c8671e0797e5e (patch)
tree5d4ffca3ed4dad9d0a4ee688792bf437f718c7c3 /dev-ruby/json/json-1.7.7.ebuild
parentVersion bump. (diff)
downloadhistorical-0cd0027dae547210d57f115f0b3c8671e0797e5e.tar.gz
historical-0cd0027dae547210d57f115f0b3c8671e0797e5e.tar.bz2
historical-0cd0027dae547210d57f115f0b3c8671e0797e5e.zip
Cleanup.
Package-Manager: portage-2.2.14/cvs/Linux x86_64 Manifest-Sign-Key: 0x8883FA56A308A8D7!
Diffstat (limited to 'dev-ruby/json/json-1.7.7.ebuild')
-rw-r--r--dev-ruby/json/json-1.7.7.ebuild65
1 files changed, 0 insertions, 65 deletions
diff --git a/dev-ruby/json/json-1.7.7.ebuild b/dev-ruby/json/json-1.7.7.ebuild
deleted file mode 100644
index 87b478d546bc..000000000000
--- a/dev-ruby/json/json-1.7.7.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/json-1.7.7.ebuild,v 1.17 2014/08/05 16:00:36 mrueg Exp $
-
-EAPI=5
-USE_RUBY="ruby19 jruby"
-
-RUBY_FAKEGEM_TASK_DOC="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGES TODO README.rdoc README-json-jruby.markdown"
-RUBY_FAKEGEM_DOCDIR="doc"
-
-RUBY_FAKEGEM_GEMSPEC="json.gemspec"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="A JSON implementation as a Ruby extension"
-HOMEPAGE="http://json.rubyforge.org/"
-LICENSE="|| ( Ruby GPL-2 )"
-
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-SLOT="0"
-IUSE=""
-
-RDEPEND="${RDEPEND}"
-DEPEND="${DEPEND}
- dev-util/ragel"
-
-ruby_add_bdepend "dev-ruby/rake"
-
-all_ruby_prepare() {
- # Avoid building the extension twice!
- # And use rdoc instead of sdoc which we don't have packaged
- # And don't call git to list files. We're using the pregenerated spec anyway.
- sed -i \
- -e 's| => :compile||' \
- -e 's| => :clean||' \
- -e 's|sdoc|rdoc|' \
- -e 's|`git ls-files`|""|' \
- Rakefile || die "rakefile fix failed"
-}
-
-each_ruby_compile() {
- # Since 1.5.0 a Java extension is provided but it does not compile.
- if [[ $(basename ${RUBY}) != "jruby" ]]; then
- ${RUBY} -S rake compile || die "extension compile failed"
- fi
-}
-
-each_ruby_test() {
- JSON=pure \
- ${RUBY} -Iext:lib -S testrb tests/test_*.rb || die "pure ruby tests failed"
-
- if [[ $(basename ${RUBY}) != "jruby" ]]; then
- JSON=ext \
- ${RUBY} -Iext:lib -S testrb tests/test_*.rb || die "ext ruby tests failed"
- fi
-}
-
-each_ruby_install() {
- each_fakegem_install
- if [[ $(basename ${RUBY}) != "jruby" ]]; then
- ruby_fakegem_newins ext/json/ext/generator$(get_modname) lib/json/ext/generator$(get_modname)
- ruby_fakegem_newins ext/json/ext/parser$(get_modname) lib/json/ext/parser$(get_modname)
- fi
-}