summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-10-02 07:27:18 +0000
committerHans de Graaff <graaff@gentoo.org>2010-10-02 07:27:18 +0000
commit6878a44ff8d4933f23be1cd44bb8212cc48bb372 (patch)
tree977bc4d1fc3f811c4ec17e1abac42d5d9e0899f9 /dev-ruby/haml/haml-3.0.21.ebuild
parentapgdiff: version bump (diff)
downloadhistorical-6878a44ff8d4933f23be1cd44bb8212cc48bb372.tar.gz
historical-6878a44ff8d4933f23be1cd44bb8212cc48bb372.tar.bz2
historical-6878a44ff8d4933f23be1cd44bb8212cc48bb372.zip
Version bump.
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/haml/haml-3.0.21.ebuild')
-rw-r--r--dev-ruby/haml/haml-3.0.21.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-ruby/haml/haml-3.0.21.ebuild b/dev-ruby/haml/haml-3.0.21.ebuild
new file mode 100644
index 000000000000..88109fbde84b
--- /dev/null
+++ b/dev-ruby/haml/haml-3.0.21.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/haml-3.0.21.ebuild,v 1.1 2010/10/02 07:24:29 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+
+RUBY_FAKEGEM_EXTRADOC="CONTRIBUTING README.md"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="init.rb VERSION VERSION_NAME"
+
+inherit ruby-fakegem
+
+DESCRIPTION="HAML - a ruby web page templating engine"
+HOMEPAGE="http://haml.hamptoncatlin.com/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+# TODO: haml has some emacs modes that it could be installing, in case
+IUSE=""
+
+# The html engine requires hpricot
+ruby_add_rdepend dev-ruby/hpricot
+
+# It could use merb during testing as well, but it's not mandatory
+ruby_add_bdepend "
+ test? (
+ virtual/ruby-test-unit
+ dev-ruby/erubis
+ dev-ruby/rails
+ dev-ruby/ruby_parser
+ )
+ doc? (
+ dev-ruby/yard
+ dev-ruby/maruku
+ )"