summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-16 03:46:36 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-16 03:46:36 +0000
commit4b09ec50e6dcd6521c0f649718615dce8648d485 (patch)
tree76ba19045731a9897b7ccba6b5a6d5d50703b1f0 /dev-ruby/fcgi/fcgi-0.8.8-r2.ebuild
parentvanilla-2.6.32.59 + genpatches-2.6.32-48 + grsecurity-2.9.1-2.6.32.59-2012081... (diff)
downloadhistorical-4b09ec50e6dcd6521c0f649718615dce8648d485.tar.gz
historical-4b09ec50e6dcd6521c0f649718615dce8648d485.tar.bz2
historical-4b09ec50e6dcd6521c0f649718615dce8648d485.zip
Move to new location.
Package-Manager: portage-2.2.0_alpha120/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'dev-ruby/fcgi/fcgi-0.8.8-r2.ebuild')
-rw-r--r--dev-ruby/fcgi/fcgi-0.8.8-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/fcgi/fcgi-0.8.8-r2.ebuild b/dev-ruby/fcgi/fcgi-0.8.8-r2.ebuild
new file mode 100644
index 000000000000..e977b4809d0a
--- /dev/null
+++ b/dev-ruby/fcgi/fcgi-0.8.8-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fcgi/fcgi-0.8.8-r2.ebuild,v 1.1 2012/08/16 03:43:57 flameeyes Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_NAME="${PN/ruby-/}"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README README.signals ChangeLog"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="FastCGI library for Ruby"
+HOMEPAGE="http://rubyforge.org/projects/fcgi/"
+
+KEYWORDS="amd64 ~hppa ppc ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+LICENSE="Ruby"
+
+DEPEND="dev-libs/fcgi"
+RDEPEND="${DEPEND}"
+
+IUSE=""
+SLOT="0"
+
+each_ruby_compile() {
+ case ${RUBY} in
+ *ruby18|*rubyee18)
+ pushd ext/fcgi
+ ${RUBY} extconf.rb || die "extconf failed"
+ emake || die "emake ext failed"
+ popd
+ cp ext/fcgi/fcgi.so lib || die
+ ;;
+ esac
+}