summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-06-09 17:09:58 +0000
committerHans de Graaff <graaff@gentoo.org>2011-06-09 17:09:58 +0000
commitdea79aede108cda78e68194a75023ad62fcf061f (patch)
tree0e460f9489a14fd4225802af2c23e206649160de /dev-ruby/activesupport
parentReally remove old (diff)
downloadhistorical-dea79aede108cda78e68194a75023ad62fcf061f.tar.gz
historical-dea79aede108cda78e68194a75023ad62fcf061f.tar.bz2
historical-dea79aede108cda78e68194a75023ad62fcf061f.zip
Version bump.
Package-Manager: portage-2.1.9.42/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/activesupport')
-rw-r--r--dev-ruby/activesupport/ChangeLog7
-rw-r--r--dev-ruby/activesupport/activesupport-2.3.12.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-ruby/activesupport/ChangeLog b/dev-ruby/activesupport/ChangeLog
index 6653bf1298c9..fc7404ff0ea3 100644
--- a/dev-ruby/activesupport/ChangeLog
+++ b/dev-ruby/activesupport/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activesupport
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.139 2011/06/09 15:23:46 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.140 2011/06/09 17:06:55 graaff Exp $
+
+*activesupport-2.3.12 (09 Jun 2011)
+
+ 09 Jun 2011; Hans de Graaff <graaff@gentoo.org> +activesupport-2.3.12.ebuild:
+ Version bump.
09 Jun 2011; Hans de Graaff <graaff@gentoo.org> -activesupport-2.2.3.ebuild:
Remove old version.
diff --git a/dev-ruby/activesupport/activesupport-2.3.12.ebuild b/dev-ruby/activesupport/activesupport-2.3.12.ebuild
new file mode 100644
index 000000000000..5bcd159d2938
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-2.3.12.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-2.3.12.ebuild,v 1.1 2011/06/09 17:06:55 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="http://rubyforge.org/projects/activesupport/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/builder-2.1.2:0 >=dev-ruby/tzinfo-0.3.16 >=dev-ruby/i18n-0.4.1:0.4"
+
+all_ruby_prepare() {
+ # Remove the bundled packages!
+ rm -r lib/active_support/vendor/{tzinfo,builder,i18n}-* \
+ || die "failed to remove vendor packages"
+
+ # This patch removes the fallback to local vendorized gems, as
+ # well as fixing the dependencies for i18n to use the correct
+ # slot.
+ epatch "${FILESDIR}"/${PN}-2.3.9-unvendorize.patch
+
+ # don't support older mocha versions as the optional codepath
+ # breaks JRuby
+ epatch "${FILESDIR}"/${PN}-2.3.5-mocha-0.9.5.patch
+}