summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-11-17 20:20:40 +0000
committerHans de Graaff <graaff@gentoo.org>2014-11-17 20:20:40 +0000
commitf69840f32302748f1d93016d612a560cdd0d045d (patch)
tree32f0d294ebab0de22bc821e69ab5b23746a0e9b4 /dev-ruby/actionmailer/actionmailer-4.1.8.ebuild
parentebuild maintenance (diff)
downloadhistorical-f69840f32302748f1d93016d612a560cdd0d045d.tar.gz
historical-f69840f32302748f1d93016d612a560cdd0d045d.tar.bz2
historical-f69840f32302748f1d93016d612a560cdd0d045d.zip
Version bump for security bug 529635.
Package-Manager: portage-2.2.8-r2/cvs/Linux x86_64 Manifest-Sign-Key: 0x8883FA56A308A8D7!
Diffstat (limited to 'dev-ruby/actionmailer/actionmailer-4.1.8.ebuild')
-rw-r--r--dev-ruby/actionmailer/actionmailer-4.1.8.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-ruby/actionmailer/actionmailer-4.1.8.ebuild b/dev-ruby/actionmailer/actionmailer-4.1.8.ebuild
new file mode 100644
index 000000000000..d29810adea27
--- /dev/null
+++ b/dev-ruby/actionmailer/actionmailer-4.1.8.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/actionmailer-4.1.8.ebuild,v 1.1 2014/11/17 20:19:39 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionmailer.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "~dev-ruby/actionpack-${PV}
+ >=dev-ruby/mail-2.5.4:2.5"
+ruby_add_bdepend "test? (
+ dev-ruby/test-unit:2
+ dev-ruby/mocha:0.14
+)"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/\/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+ # Make sure we use the test-unit gem since ruby18 does not provide
+ # all the test-unit features needed.
+ sed -i -e '1igem "test-unit"' test/abstract_unit.rb || die
+
+ # Avoid a test failing only on attachment ordering, since this is a
+ # security release.
+ sed -i -e '/adding inline attachments while rendering mail works/askip "gentoo: fails on ordering"' test/base_test.rb || die
+}