summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2005-04-08 14:35:49 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2005-04-08 14:35:49 +0000
commiteb73675ac11586247fecf26d0389791d4e945162 (patch)
treef9afe979a0b29182c75c33693b245b886bd955f6 /dev-python
parentStable on ppc64 (diff)
downloadhistorical-eb73675ac11586247fecf26d0389791d4e945162.tar.gz
historical-eb73675ac11586247fecf26d0389791d4e945162.tar.bz2
historical-eb73675ac11586247fecf26d0389791d4e945162.zip
initial import
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/twisted-lore/ChangeLog8
-rw-r--r--dev-python/twisted-lore/Manifest4
-rw-r--r--dev-python/twisted-lore/files/digest-twisted-lore-0.1.01
-rw-r--r--dev-python/twisted-lore/metadata.xml6
-rw-r--r--dev-python/twisted-lore/twisted-lore-0.1.0.ebuild31
5 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/twisted-lore/ChangeLog b/dev-python/twisted-lore/ChangeLog
new file mode 100644
index 000000000000..bfe660706a8e
--- /dev/null
+++ b/dev-python/twisted-lore/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for dev-python/twisted-lore
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-lore/ChangeLog,v 1.1 2005/04/08 14:35:49 lordvan Exp $
+
+ 08 Apr 2005; Thomas Raschbacher <lordvan@gentoo.org> twisted-lore-0.1.0:
+ initial import
+ twisted-lore was part of the main twisted release
+
diff --git a/dev-python/twisted-lore/Manifest b/dev-python/twisted-lore/Manifest
new file mode 100644
index 000000000000..f893840c9e52
--- /dev/null
+++ b/dev-python/twisted-lore/Manifest
@@ -0,0 +1,4 @@
+MD5 1a3af35a8e4df806bd2b9db7c09eea2a twisted-lore-0.1.0.ebuild 806
+MD5 9c51b5b74729b376c2004ad9a388c041 ChangeLog 365
+MD5 19df39ef54fc4a8677998f19bb6046ac metadata.xml 218
+MD5 c36a230912611e4218de6f5eb5e3d710 files/digest-twisted-lore-0.1.0 69
diff --git a/dev-python/twisted-lore/files/digest-twisted-lore-0.1.0 b/dev-python/twisted-lore/files/digest-twisted-lore-0.1.0
new file mode 100644
index 000000000000..43dcffc1a2d7
--- /dev/null
+++ b/dev-python/twisted-lore/files/digest-twisted-lore-0.1.0
@@ -0,0 +1 @@
+MD5 c38eea006be598081778d79c98fc8a42 TwistedLore-0.1.0.tar.bz2 58386
diff --git a/dev-python/twisted-lore/metadata.xml b/dev-python/twisted-lore/metadata.xml
new file mode 100644
index 000000000000..37d1f8e02e49
--- /dev/null
+++ b/dev-python/twisted-lore/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+<maintainer><email>lordvan@gentoo.org</email></maintainer>
+</pkgmetadata>
diff --git a/dev-python/twisted-lore/twisted-lore-0.1.0.ebuild b/dev-python/twisted-lore/twisted-lore-0.1.0.ebuild
new file mode 100644
index 000000000000..ce005c6683bf
--- /dev/null
+++ b/dev-python/twisted-lore/twisted-lore-0.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-lore/twisted-lore-0.1.0.ebuild,v 1.1 2005/04/08 14:35:49 lordvan Exp $
+
+inherit distutils
+
+# for alphas,..
+MY_PV="${PV/_alpha/a}"
+MY_PN="TwistedLore"
+MY_P="${MY_PN}-${MY_PV}"
+DESCRIPTION="An NNTP protocol implementation with client and server(?)"
+HOMEPAGE="http://twistedmatrix.com/projects/lore/"
+SRC_URI="http://tmrc.mit.edu/mirror/twisted/Lore/0.1/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc ~alpha ~sparc"
+IUSE="doc"
+
+DEPEND=">=dev-python/twisted-2.0.0"
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dodir /usr/share/doc/${P}
+ cp -r ${S}/docs ${D}/usr/share/doc/${P}/
+ fi
+}