summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-04-19 10:14:00 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-04-19 10:14:00 +0000
commit7ed58844e0576b7c08cc35c3b55514c5c35e3ee9 (patch)
tree51413d905c6c65fb342746cfda18ad68bb37f48b /dev-python/xlrd
parentBump (diff)
downloadhistorical-7ed58844e0576b7c08cc35c3b55514c5c35e3ee9.tar.gz
historical-7ed58844e0576b7c08cc35c3b55514c5c35e3ee9.tar.bz2
historical-7ed58844e0576b7c08cc35c3b55514c5c35e3ee9.zip
Bump
Package-Manager: portage-2.2.0_alpha100/cvs/Linux x86_64
Diffstat (limited to 'dev-python/xlrd')
-rw-r--r--dev-python/xlrd/ChangeLog7
-rw-r--r--dev-python/xlrd/xlrd-0.7.7.ebuild28
2 files changed, 34 insertions, 1 deletions
diff --git a/dev-python/xlrd/ChangeLog b/dev-python/xlrd/ChangeLog
index 3720f843caef..ccf15ec33bc3 100644
--- a/dev-python/xlrd/ChangeLog
+++ b/dev-python/xlrd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/xlrd
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/xlrd/ChangeLog,v 1.3 2012/03/03 09:52:25 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/xlrd/ChangeLog,v 1.4 2012/04/19 10:10:20 patrick Exp $
+
+*xlrd-0.7.7 (19 Apr 2012)
+
+ 19 Apr 2012; Patrick Lauer <patrick@gentoo.org> +xlrd-0.7.7.ebuild:
+ Bump
*xlrd-0.7.3 (03 Mar 2012)
diff --git a/dev-python/xlrd/xlrd-0.7.7.ebuild b/dev-python/xlrd/xlrd-0.7.7.ebuild
new file mode 100644
index 000000000000..dee2ab8abebb
--- /dev/null
+++ b/dev-python/xlrd/xlrd-0.7.7.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/xlrd/xlrd-0.7.7.ebuild,v 1.1 2012/04/19 10:10:19 patrick Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Library for developers to extract data from Microsoft Excel (tm) spreadsheet files"
+HOMEPAGE="http://pypi.python.org/pypi/xlrd"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc-aix ~hppa-hpux ~ia64-hpux ~x86-interix ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+RESTRICT_PYTHON_ABIS="3.*"
+
+src_prepare() {
+ distutils_src_prepare
+ # add shebang to runxlrd.py
+ sed -i -e '1i#!/usr/bin/env python' scripts/runxlrd.py || die
+}