summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-17 20:08:29 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-17 20:08:29 +0000
commitefaaeb9e09ac64198286eab5112f5ba498440733 (patch)
treede4e92150fbe6c2b1f18c2fda51b8140d2c3116b /dev-python/wtforms
parentVersion bump. (diff)
downloadhistorical-efaaeb9e09ac64198286eab5112f5ba498440733.tar.gz
historical-efaaeb9e09ac64198286eab5112f5ba498440733.tar.bz2
historical-efaaeb9e09ac64198286eab5112f5ba498440733.zip
Version bump.
Package-Manager: portage-2.2_rc83_p15/cvs/Linux x86_64
Diffstat (limited to 'dev-python/wtforms')
-rw-r--r--dev-python/wtforms/ChangeLog8
-rw-r--r--dev-python/wtforms/Manifest4
-rw-r--r--dev-python/wtforms/wtforms-0.6.1.ebuild56
3 files changed, 66 insertions, 2 deletions
diff --git a/dev-python/wtforms/ChangeLog b/dev-python/wtforms/ChangeLog
index a7cdc6c2fb2b..5220f44da073 100644
--- a/dev-python/wtforms/ChangeLog
+++ b/dev-python/wtforms/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/wtforms
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wtforms/ChangeLog,v 1.6 2010/06/14 07:46:11 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wtforms/ChangeLog,v 1.7 2010/09/17 20:08:29 arfrever Exp $
+
+*wtforms-0.6.1 (17 Sep 2010)
+
+ 17 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +wtforms-0.6.1.ebuild:
+ Version bump.
14 Jun 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org> wtforms-0.6.ebuild:
x86 stable wrt bug #322287
diff --git a/dev-python/wtforms/Manifest b/dev-python/wtforms/Manifest
index cd2fb67772b3..4444cc01725e 100644
--- a/dev-python/wtforms/Manifest
+++ b/dev-python/wtforms/Manifest
@@ -1,4 +1,6 @@
+DIST WTForms-0.6.1.zip 215659 RMD160 94ce74489e399424478933cf5475595f854e1182 SHA1 ef20687046aea8facf6f7b363cc6794efac11bac SHA256 776c9e15cc283a7454ff5c2a0407af38e7c6e7b81d0daa354bdfbf89bc73a061
DIST WTForms-0.6.zip 199112 RMD160 a0f3fe760e22a3ba26a4ea388e8a402a0c43a45c SHA1 ef6d3c60377deea1eec1bc9d20a0fa281dba5054 SHA256 117e70e51ef8851d8d465d507f6f1a19b7a1dd6a3c651ad1efe47e1af8e5ad3a
+EBUILD wtforms-0.6.1.ebuild 1209 RMD160 1bca9c0212b8840fbac166534197eb3ad3452c40 SHA1 8b81e9e77dd2b2bcfbe1860c503d30b18e2bc6fe SHA256 d043dce248ed8b85d65609d1573490b53fe79263de6f357cb44b32e5b79c22de
EBUILD wtforms-0.6.ebuild 1229 RMD160 8e13c920fbdb19052ffee960df4d4cb436cd5242 SHA1 b9495d66d8d7196ed7b972b2847fa13095bd3a39 SHA256 e00ae52d5e33ff17a87e780ff817d83b8b5045df4818b43ed974cc6e9aa47215
-MISC ChangeLog 925 RMD160 b37972fbae14d98e31c5102792426d2e66fe44cf SHA1 e1c9e4e1866baa49c7e97dc613960f1f02b54452 SHA256 3995cecc3f251da2e5c1d8ca80d09953d0de95fdeff2929354f498fa9b115252
+MISC ChangeLog 1068 RMD160 3009d3d06479ca9fddfc8361f3e6c51efaac647d SHA1 fbdcf3e6a36a7b5e020266ce40b7fac57c70d572 SHA256 e288ed938088f57e0c58642b7186c1153988e0357240669de12d6e34d71b697f
MISC metadata.xml 259 RMD160 4b781a038008fac445e4154045f964b64ad59e75 SHA1 9809d89f3360f9f7537c2bb480d6bcbe942c6ea0 SHA256 0fb1da675767b69b5bd240d135effe2fc500e8b997a5f4eed212e5b26d027972
diff --git a/dev-python/wtforms/wtforms-0.6.1.ebuild b/dev-python/wtforms/wtforms-0.6.1.ebuild
new file mode 100644
index 000000000000..0e2ad01754ad
--- /dev/null
+++ b/dev-python/wtforms/wtforms-0.6.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wtforms/wtforms-0.6.1.ebuild,v 1.1 2010/09/17 20:08:29 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+MY_PN="WTForms"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Flexible forms validation and rendering library for python web development"
+HOMEPAGE="http://wtforms.simplecodes.com/ http://pypi.python.org/pypi/WTForms"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="app-arch/unzip
+ doc? ( >=dev-python/sphinx-0.6 )"
+RDEPEND=""
+
+DOCS="AUTHORS.txt CHANGES.txt README.txt"
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ cd docs
+ PYTHONPATH=".." emake html || die "Building of documentation failed"
+ fi
+}
+
+src_test() {
+ cd tests
+ testing() {
+ "$(PYTHON)" runtests.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r docs/_build/html/* || die "Installation of documentation failed"
+ fi
+}