summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-04-17 23:09:11 +0000
committerMike Frysinger <vapier@gentoo.org>2012-04-17 23:09:11 +0000
commit1be940c8ab43a28418e624d7a6285169b2ef8034 (patch)
tree40b0508dc2db3a635c8ffbd60a68adec1626efb4 /dev-python/ws4py/ws4py-9999.ebuild
parentAdd arm love. (diff)
downloadhistorical-1be940c8ab43a28418e624d7a6285169b2ef8034.tar.gz
historical-1be940c8ab43a28418e624d7a6285169b2ef8034.tar.bz2
historical-1be940c8ab43a28418e624d7a6285169b2ef8034.zip
Initial ebuild import for ChromiumOS.
Package-Manager: portage-2.2.0_alpha100/cvs/Linux x86_64
Diffstat (limited to 'dev-python/ws4py/ws4py-9999.ebuild')
-rw-r--r--dev-python/ws4py/ws4py-9999.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/ws4py/ws4py-9999.ebuild b/dev-python/ws4py/ws4py-9999.ebuild
new file mode 100644
index 000000000000..10b73c7a38f7
--- /dev/null
+++ b/dev-python/ws4py/ws4py-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ws4py/ws4py-9999.ebuild,v 1.1 2012/04/17 23:09:11 vapier Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2"
+
+inherit distutils
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/Lawouach/WebSocket-for-Python.git"
+ inherit git-2
+else
+ inherit vcs-snapshot
+ SRC_URI="https://github.com/Lawouach/WebSocket-for-Python/tarball/v${PV} -> ${P}-src.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="WebSocket support for Python"
+HOMEPAGE="https://github.com/Lawouach/WebSocket-for-Python"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+#IUSE="client server"
+
+# The gevent package isn't in the tree yet.
+#RDEPEND="client? ( >=dev-python/gevent-0.13.6 )
+# server? ( >=dev-python/gevent-0.13.6 )"
+DEPEND=""
+
+src_install() {
+ distutils_src_install
+ #use client || rm -rf "${ED}$(python_get_sitedir)"/ws4py/client
+ #use server || rm -rf "${ED}$(python_get_sitedir)"/ws4py/server
+ rm -rf "${ED}$(python_get_sitedir)"/ws4py/{client,server}
+}