summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2011-12-24 08:50:30 +0000
committerPatrick Lauer <patrick@gentoo.org>2011-12-24 08:50:30 +0000
commit72045abec8f9306eb2c714249e6c8b69c663abea (patch)
treeabc8c7f567d5079dc1becb86ba423dfb3b9de73d /dev-python/setproctitle/setproctitle-1.1.3.ebuild
parentAdded prefix offset fixes and keyworded for ~-linux, tested by me (diff)
downloadhistorical-72045abec8f9306eb2c714249e6c8b69c663abea.tar.gz
historical-72045abec8f9306eb2c714249e6c8b69c663abea.tar.bz2
historical-72045abec8f9306eb2c714249e6c8b69c663abea.zip
Bump #393103
Package-Manager: portage-2.2.0_alpha81/cvs/Linux x86_64
Diffstat (limited to 'dev-python/setproctitle/setproctitle-1.1.3.ebuild')
-rw-r--r--dev-python/setproctitle/setproctitle-1.1.3.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/setproctitle/setproctitle-1.1.3.ebuild b/dev-python/setproctitle/setproctitle-1.1.3.ebuild
new file mode 100644
index 000000000000..b242e73dbd0c
--- /dev/null
+++ b/dev-python/setproctitle/setproctitle-1.1.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/setproctitle/setproctitle-1.1.3.ebuild,v 1.1 2011/12/24 08:50:30 patrick Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils toolchain-funcs
+
+DESCRIPTION="Allow customization of the process title."
+HOMEPAGE="http://code.google.com/p/py-setproctitle/ http://pypi.python.org/pypi/setproctitle"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
+DOCS="HISTORY README"
+
+src_prepare() {
+ python_copy_sources
+
+ conversion() {
+ [[ "${PYTHON_ABI}" == 2.* ]] && return
+ 2to3-${PYTHON_ABI} -w --no-diffs tests > /dev/null
+ }
+ python_execute_function \
+ --action-message 'Applying patches for $(python_get_implementation) $(python_get_version)' \
+ --failure-message 'Applying patches for $(python_get_implementation) $(python_get_version) failed' \
+ -s conversion
+}
+
+distutils_src_test_pre_hook() {
+ ln -fs pyrun-${PYTHON_ABI} tests/pyrun
+}
+
+src_test() {
+ build_pyrun() {
+ echo $(tc-getCC) ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} -I$(python_get_includedir) -o tests/pyrun-${PYTHON_ABI} tests/pyrun.c $(python_get_library -l)
+ $(tc-getCC) ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} -I$(python_get_includedir) -o tests/pyrun-${PYTHON_ABI} tests/pyrun.c $(python_get_library -l)
+ }
+ python_execute_function -q -s build_pyrun
+
+ distutils_src_test
+}