summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-01 04:34:23 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-01 04:34:23 +0000
commitdfc1a50ca88b694d7e0d564f4ce1d624cde3572f (patch)
tree239910f632dbd236fbf48038c5f6888231d5b2bc /dev-python/rope/rope-0.9.3.ebuild
parentSet SUPPORT_PYTHON_ABIS. (diff)
downloadhistorical-dfc1a50ca88b694d7e0d564f4ce1d624cde3572f.tar.gz
historical-dfc1a50ca88b694d7e0d564f4ce1d624cde3572f.tar.bz2
historical-dfc1a50ca88b694d7e0d564f4ce1d624cde3572f.zip
Fix returning of tests results.
Package-Manager: portage-HEAD/cvs/Linux x86_64
Diffstat (limited to 'dev-python/rope/rope-0.9.3.ebuild')
-rw-r--r--dev-python/rope/rope-0.9.3.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/dev-python/rope/rope-0.9.3.ebuild b/dev-python/rope/rope-0.9.3.ebuild
index 3f73e8ee5d81..d58f7e294656 100644
--- a/dev-python/rope/rope-0.9.3.ebuild
+++ b/dev-python/rope/rope-0.9.3.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/rope/rope-0.9.3.ebuild,v 1.2 2010/06/30 02:05:22 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rope/rope-0.9.3.ebuild,v 1.3 2010/07/01 04:34:23 arfrever Exp $
EAPI="3"
PYTHON_DEPEND="2:2.5"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="2.4 3.*"
-inherit distutils
+inherit distutils eutils
DESCRIPTION="Python refactoring library"
HOMEPAGE="http://rope.sourceforge.net/ http://pypi.python.org/pypi/rope"
@@ -21,6 +21,11 @@ IUSE=""
DEPEND=""
RDEPEND=""
+src_prepare() {
+ distutils_src_prepare
+ epatch "${FILESDIR}/${P}-fix_tests_results.patch"
+}
+
src_test() {
testing() {
PYTHONPATH="build-${PYTHON_ABI}/lib:." "$(PYTHON)" ropetest/__init__.py