summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-02-15 15:13:07 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-02-15 15:13:07 +0000
commit95a2360134eb4a2e729ff1e57750b8e3f30cc7a1 (patch)
tree4848731a9538db5b4909b6b6d8e7038c4a69ad56 /dev-python/pyyaml/pyyaml-3.08.ebuild
parentBump to 2.6 (diff)
downloadhistorical-95a2360134eb4a2e729ff1e57750b8e3f30cc7a1.tar.gz
historical-95a2360134eb4a2e729ff1e57750b8e3f30cc7a1.tar.bz2
historical-95a2360134eb4a2e729ff1e57750b8e3f30cc7a1.zip
Bump to 3.08
Package-Manager: portage-2.2_rc23/cvs/Linux x86_64
Diffstat (limited to 'dev-python/pyyaml/pyyaml-3.08.ebuild')
-rw-r--r--dev-python/pyyaml/pyyaml-3.08.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pyyaml/pyyaml-3.08.ebuild b/dev-python/pyyaml/pyyaml-3.08.ebuild
new file mode 100644
index 000000000000..1b2f9289e3bd
--- /dev/null
+++ b/dev-python/pyyaml/pyyaml-3.08.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyyaml/pyyaml-3.08.ebuild,v 1.1 2009/02/15 15:13:07 patrick Exp $
+
+NEED_PYTHON="2.3"
+
+inherit distutils
+
+MY_P="PyYAML-${PV}"
+
+DESCRIPTION="YAML parser and emitter for Python"
+HOMEPAGE="http://pyyaml.org/wiki/PyYAML"
+SRC_URI="http://pyyaml.org/download/${PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="examples libyaml"
+
+DEPEND="libyaml? ( dev-libs/libyaml dev-python/pyrex )"
+RDEPEND="libyaml? ( dev-libs/libyaml )"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="yaml"
+
+src_unpack() {
+ distutils_src_unpack
+ if use libyaml; then
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-libyaml.diff"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/.
+ fi
+}