summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris PeBenito <pebenito@gentoo.org>2004-04-26 20:01:53 +0000
committerChris PeBenito <pebenito@gentoo.org>2004-04-26 20:01:53 +0000
commit7bab4d284df0a951ed266c5b51428b87a045fd93 (patch)
tree2be537fd360ea03e9b82bd54ede862f9da74a1d3 /dev-python/python-selinux
parentAdd die following econf for bug 48950 (diff)
downloadhistorical-7bab4d284df0a951ed266c5b51428b87a045fd93.tar.gz
historical-7bab4d284df0a951ed266c5b51428b87a045fd93.tar.bz2
historical-7bab4d284df0a951ed266c5b51428b87a045fd93.zip
add getcon and setexec functions
Diffstat (limited to 'dev-python/python-selinux')
-rw-r--r--dev-python/python-selinux/ChangeLog8
-rw-r--r--dev-python/python-selinux/Manifest5
-rw-r--r--dev-python/python-selinux/files/digest-python-selinux-2.130
-rw-r--r--dev-python/python-selinux/files/python-selinux-2.13.c.bz2bin0 -> 5882 bytes
-rw-r--r--dev-python/python-selinux/python-selinux-2.13.ebuild36
5 files changed, 47 insertions, 2 deletions
diff --git a/dev-python/python-selinux/ChangeLog b/dev-python/python-selinux/ChangeLog
index e290aaec5a3f..cbc78e1d399f 100644
--- a/dev-python/python-selinux/ChangeLog
+++ b/dev-python/python-selinux/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-selinux
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/ChangeLog,v 1.16 2004/04/08 19:21:28 pebenito Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/ChangeLog,v 1.17 2004/04/26 20:01:53 pebenito Exp $
+
+*python-selinux-2.13 (26 Apr 2004)
+
+ 26 Apr 2004; Chris PeBenito <pebenito@gentoo.org>
+ +python-selinux-2.13.ebuild:
+ Add getcon and setexec functions.
08 Apr 2004; Chris PeBenito <pebenito@gentoo.org>
python-selinux-2.12.ebuild:
diff --git a/dev-python/python-selinux/Manifest b/dev-python/python-selinux/Manifest
index af515faa6613..b373794cb440 100644
--- a/dev-python/python-selinux/Manifest
+++ b/dev-python/python-selinux/Manifest
@@ -1,8 +1,11 @@
+MD5 4348c2280ea2aaf8a496399d9ff8932e python-selinux-2.13.ebuild 871
MD5 3c4912511a7e2207b5341e7e85187f47 python-selinux-2.10.ebuild 848
-MD5 0867d04f7e742d1ed25b3d5adc8a191c ChangeLog 2864
+MD5 ee0e2e8a4667c9f4b88fb36974139889 ChangeLog 3020
MD5 c998c579cfc08c6860f78304a67cfce9 metadata.xml 525
MD5 ecbf7863c0edb08417cbb2d101a9deb7 python-selinux-2.12.ebuild 868
MD5 6e19040173f4f45c94e294a4bb326a55 files/python-selinux-2.12.c.bz2 5621
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-python-selinux-2.10 0
+MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-python-selinux-2.13 0
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-python-selinux-2.12 0
+MD5 d22d8cef09dba627632e2c5783451a18 files/python-selinux-2.13.c.bz2 5882
MD5 7917bf5ac68090fb6fcfe784a4807463 files/python-selinux-2.10.c.bz2 5624
diff --git a/dev-python/python-selinux/files/digest-python-selinux-2.13 b/dev-python/python-selinux/files/digest-python-selinux-2.13
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/dev-python/python-selinux/files/digest-python-selinux-2.13
diff --git a/dev-python/python-selinux/files/python-selinux-2.13.c.bz2 b/dev-python/python-selinux/files/python-selinux-2.13.c.bz2
new file mode 100644
index 000000000000..47493667e5b0
--- /dev/null
+++ b/dev-python/python-selinux/files/python-selinux-2.13.c.bz2
Binary files differ
diff --git a/dev-python/python-selinux/python-selinux-2.13.ebuild b/dev-python/python-selinux/python-selinux-2.13.ebuild
new file mode 100644
index 000000000000..15b29abf9467
--- /dev/null
+++ b/dev-python/python-selinux/python-selinux-2.13.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/python-selinux-2.13.ebuild,v 1.1 2004/04/26 20:01:53 pebenito Exp $
+
+inherit python
+python_version
+
+DESCRIPTION="Python bindings for SELinux functions"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/selinux/"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~x86 ~ppc ~sparc"
+IUSE=""
+
+DEPEND="dev-lang/python
+ sys-libs/libselinux"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ mkdir -p ${S}
+ bzcat ${FILESDIR}/${P}.c.bz2 > ${S}/selinux.c
+}
+
+src_compile() {
+ cd ${S}
+ einfo "Compiling selinux.so for python ${PYVER}"
+ gcc -fPIC -shared -o selinux.so -I /usr/include/python${PYVER}/ selinux.c -lselinux || die
+}
+
+src_install() {
+ insinto /usr/lib/python${PYVER}/site-packages
+ doins selinux.so
+}