summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-28 20:03:20 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-28 20:03:20 +0000
commit48a42f19488ad683a6bba9f06967d6b1b58a8aca (patch)
tree66b23e77d1ad369d9098a883c32f16c539f50398 /dev-python/python-openid
parentVersion bump 2.8.3, fixes bug 316919 and 263839, ebuild submitted by me. (diff)
downloadhistorical-48a42f19488ad683a6bba9f06967d6b1b58a8aca.tar.gz
historical-48a42f19488ad683a6bba9f06967d6b1b58a8aca.tar.bz2
historical-48a42f19488ad683a6bba9f06967d6b1b58a8aca.zip
Delete older ebuild.
Diffstat (limited to 'dev-python/python-openid')
-rw-r--r--dev-python/python-openid/python-openid-2.2.4.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/dev-python/python-openid/python-openid-2.2.4.ebuild b/dev-python/python-openid/python-openid-2.2.4.ebuild
deleted file mode 100644
index cc89457c7271..000000000000
--- a/dev-python/python-openid/python-openid-2.2.4.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-openid/python-openid-2.2.4.ebuild,v 1.5 2010/06/28 19:42:27 arfrever Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2:2.5"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4 3.*"
-
-inherit eutils distutils
-
-DESCRIPTION="OpenID support for servers and consumers."
-HOMEPAGE="http://www.openidenabled.com/openid/libraries/python/"
-SRC_URI="http://www.openidenabled.com/files/${PN}/packages/${P}.tar.bz2"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples mysql postgres sqlite"
-
-RDEPEND="mysql? ( >=dev-python/mysql-python-1.2.2 )
- postgres? ( dev-python/psycopg )
- sqlite? ( || ( dev-lang/python[sqlite] >=dev-python/pysqlite-2 ) )"
-DEPEND="${RDEPEND}"
-
-PYTHON_MODNAME="openid"
-
-src_prepare() {
- distutils_src_prepare
-
- # Patch to fix confusion with localhost/127.0.0.1
- epatch "${FILESDIR}/${PN}-2.0.0-gentoo-test_fetchers.diff"
-
- # Disable broken tests from from examples/djopenid.
- sed -e "s/django_failures =.*/django_failures = 0/" -i admin/runtests || die "sed admin/runtests failed"
-}
-
-src_test() {
- # Remove test that requires running db server.
- sed -e '/storetest/d' -i admin/runtests
-
- testing() {
- "$(PYTHON)" admin/runtests
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- use doc && dohtml doc/*
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}