summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn N. Laliberte <allanonjl@gentoo.org>2006-05-24 14:46:25 +0000
committerJohn N. Laliberte <allanonjl@gentoo.org>2006-05-24 14:46:25 +0000
commit527855e440e3d42ede41d1c0d1ac3f75dc43758f (patch)
tree83cac39e3e703ad37cd129b477c06cc32e42a7a4 /dev-python/pyparted/pyparted-1.7.0.ebuild
parentStable on x86; bug #124650 (diff)
downloadhistorical-527855e440e3d42ede41d1c0d1ac3f75dc43758f.tar.gz
historical-527855e440e3d42ede41d1c0d1ac3f75dc43758f.tar.bz2
historical-527855e440e3d42ede41d1c0d1ac3f75dc43758f.zip
version bump. fix includes to always include parted.h
Package-Manager: portage-2.1_rc1-r3
Diffstat (limited to 'dev-python/pyparted/pyparted-1.7.0.ebuild')
-rw-r--r--dev-python/pyparted/pyparted-1.7.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/pyparted/pyparted-1.7.0.ebuild b/dev-python/pyparted/pyparted-1.7.0.ebuild
new file mode 100644
index 000000000000..c1fdd91dd4c5
--- /dev/null
+++ b/dev-python/pyparted/pyparted-1.7.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/pyparted-1.7.0.ebuild,v 1.1 2006/05/24 14:46:25 allanonjl Exp $
+
+RH_EXTRAVERSION="1"
+
+inherit eutils rpm flag-o-matic
+
+DESCRIPTION="Python bindings for parted"
+HOMEPAGE="http://fedora.redhat.com"
+SRC_URI="http://download.fedora.redhat.com/pub/fedora/linux/core/development/SRPMS/${P}-${RH_EXTRAVERSION}.src.rpm"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+# Needed to build...
+DEPEND="=dev-lang/python-2.4*
+ >=sys-apps/parted-1.7.0"
+
+src_unpack() {
+ rpm_src_unpack
+ cd "${S}"
+ sed -i -e 's:device.h:parted.h:' pydevice.h
+ sed -i -e 's:disk.h:parted.h:' pydisk.h pyfilesystem.h
+ sed -i -e 's:geom.h:parted.h:' pygeometry.h
+}
+
+src_compile() {
+ # -fPIC needed for compilation on amd64, applied globally as only one shared
+ # lib is produced by this package.
+ append-flags -fPIC
+
+ # This is needed otherwise it won't build
+ # If anyone wants to figure out why... go ahead!
+ export LDFLAGS="-ldl"
+ econf || die
+ emake || die
+}
+
+src_install () {
+ einstall || die "Install failed!"
+ dodoc AUTHORS COPYING README ChangeLog
+}