summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-30 03:09:24 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-30 03:09:24 +0000
commit6b939b46cd8452cdf706f8652b5f2001013757da (patch)
treeaf3f0aa8c4f9d761e4db86930f4d9d24a2875d65 /dev-python/pyclamav/pyclamav-0.4.1-r1.ebuild
parentDelete older ebuilds. (diff)
downloadhistorical-6b939b46cd8452cdf706f8652b5f2001013757da.tar.gz
historical-6b939b46cd8452cdf706f8652b5f2001013757da.tar.bz2
historical-6b939b46cd8452cdf706f8652b5f2001013757da.zip
Set SUPPORT_PYTHON_ABIS.
Package-Manager: portage-HEAD/cvs/Linux x86_64
Diffstat (limited to 'dev-python/pyclamav/pyclamav-0.4.1-r1.ebuild')
-rw-r--r--dev-python/pyclamav/pyclamav-0.4.1-r1.ebuild30
1 files changed, 16 insertions, 14 deletions
diff --git a/dev-python/pyclamav/pyclamav-0.4.1-r1.ebuild b/dev-python/pyclamav/pyclamav-0.4.1-r1.ebuild
index 7e96b5c9dc21..78295c45870f 100644
--- a/dev-python/pyclamav/pyclamav-0.4.1-r1.ebuild
+++ b/dev-python/pyclamav/pyclamav-0.4.1-r1.ebuild
@@ -1,34 +1,36 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyclamav/pyclamav-0.4.1-r1.ebuild,v 1.2 2009/05/18 15:45:12 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyclamav/pyclamav-0.4.1-r1.ebuild,v 1.3 2010/06/30 03:09:24 arfrever Exp $
-EAPI=2
-
-NEED_PYTHON=2.2
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="1"
inherit distutils eutils
DESCRIPTION="Python binding for libclamav"
-HOMEPAGE="http://xael.org/norman/python/pyclamav/"
+HOMEPAGE="http://xael.org/norman/python/pyclamav/ http://pypi.python.org/pypi/pyclamav"
SRC_URI="http://xael.org/norman/python/${PN}/${P}.tar.gz"
+
LICENSE="GPL-2"
-KEYWORDS="~amd64 ~ia64 ~ppc x86"
-DEPEND=">=app-antivirus/clamav-0.90"
SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc x86"
IUSE=""
+DEPEND=">=app-antivirus/clamav-0.90"
+RDEPEND="${DEPEND}"
+
src_prepare() {
+ distutils_src_prepare
+
# Patch from Debian to build w/ >=clamav-0.95
epatch "${FILESDIR}/${P}-clamav-0.95.patch"
}
src_install() {
distutils_src_install
- insinto /usr/share/doc/${PF} && doins example.py
-}
-pkg_postinst() {
- elog "Due to removal of cl_scanbuff in libclamav, pyclamav.scanthis()"
- elog "has been removed in this release. Authors strongly encourage to use"
- elog "pyClamd (http://xael.org/norman/python/pyclamd)."
+ insinto /usr/share/doc/${PF}
+ doins example.py
}