summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-09-17 18:29:56 +0000
committerAli Polatel <hawking@gentoo.org>2008-09-17 18:29:56 +0000
commit2e5bbd86f56b4d460d8c43c15f10ca772081d422 (patch)
tree0f0e081625162c1a823bb74bf7763878837e6f76 /dev-python/foolscap/foolscap-0.3.1.ebuild
parentVersion bump. (diff)
downloadhistorical-2e5bbd86f56b4d460d8c43c15f10ca772081d422.tar.gz
historical-2e5bbd86f56b4d460d8c43c15f10ca772081d422.tar.bz2
historical-2e5bbd86f56b4d460d8c43c15f10ca772081d422.zip
Added dev-python/foolscap
Package-Manager: portage--svn/cvs/Linux 2.6.26-gentoo x86_64
Diffstat (limited to 'dev-python/foolscap/foolscap-0.3.1.ebuild')
-rw-r--r--dev-python/foolscap/foolscap-0.3.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/foolscap/foolscap-0.3.1.ebuild b/dev-python/foolscap/foolscap-0.3.1.ebuild
new file mode 100644
index 000000000000..896af07414e4
--- /dev/null
+++ b/dev-python/foolscap/foolscap-0.3.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/foolscap/foolscap-0.3.1.ebuild,v 1.1 2008/09/17 18:29:56 hawking Exp $
+
+inherit distutils
+
+DESCRIPTION="The next-generation RPC protocol, intended to replace Perspective Broker."
+HOMEPAGE="http://foolscap.lothar.com/trac"
+SRC_URI="http://${PN}.lothar.com/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+DEPEND="dev-python/setuptools"
+RDEPEND=">=dev-python/twisted-2.4.0"
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dodoc doc/*.txt || die "dodoc failed"
+ dohtml -A py,tpl,xhtml -r doc/* || die "dohtml failed"
+ fi
+}
+
+src_test() {
+ PYTHONPATH=. trial ${PN} || die "tests failed"
+}