summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLukasz Strzygowski <lucass@gentoo.org>2005-11-12 09:04:11 +0000
committerLukasz Strzygowski <lucass@gentoo.org>2005-11-12 09:04:11 +0000
commitaf2f77c03e7f64bbb224212542f69a931cefef01 (patch)
tree2d1f8a115f0a56c8ab8d09f1a4169de4c4d0a3ce /dev-python/dnspython/dnspython-1.3.5.ebuild
parentold (diff)
downloadhistorical-af2f77c03e7f64bbb224212542f69a931cefef01.tar.gz
historical-af2f77c03e7f64bbb224212542f69a931cefef01.tar.bz2
historical-af2f77c03e7f64bbb224212542f69a931cefef01.zip
Version bump. Closing bug #112239.
Package-Manager: portage-2.0.53_rc7
Diffstat (limited to 'dev-python/dnspython/dnspython-1.3.5.ebuild')
-rw-r--r--dev-python/dnspython/dnspython-1.3.5.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/dnspython/dnspython-1.3.5.ebuild b/dev-python/dnspython/dnspython-1.3.5.ebuild
new file mode 100644
index 000000000000..5f074c09887e
--- /dev/null
+++ b/dev-python/dnspython/dnspython-1.3.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dnspython/dnspython-1.3.5.ebuild,v 1.1 2005/11/12 09:04:11 lucass Exp $
+
+inherit distutils
+
+DESCRIPTION="DNS toolkit for Python."
+HOMEPAGE="http://www.dnspython.org/"
+SRC_URI="http://www.dnspython.org/kits/stable/${P}.tar.gz"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+DEPEND="virtual/python
+ sys-devel/make"
+
+src_install() {
+ distutils_src_install
+ dodoc TODO
+ dodir /usr/share/doc/${P}
+
+ cp -r examples ${D}/usr/share/doc/${P}
+ dodir /usr/share/${PN}
+ cp -r tests ${D}/usr/share/${PN}
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Documentation is sparse at the moment. Use pydoc,"
+ einfo "or read the HTML documentation at the dnspython's home page."
+ einfo
+}
+
+src_test() {
+ export PYTHONPATH="${S}/build/lib:${PYTHONPATH}"
+ cd tests
+ make || die "Unit tests failed!"
+}
+