summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-02 19:28:51 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-02 19:28:51 +0000
commit9dfcbe4d6a6d07c79c033f37a2810e3e2f59d481 (patch)
treec64f98917f9e589810d7fbdad257fd2f5056274f /dev-python/django
parentVersion bump (diff)
downloadhistorical-9dfcbe4d6a6d07c79c033f37a2810e3e2f59d481.tar.gz
historical-9dfcbe4d6a6d07c79c033f37a2810e3e2f59d481.tar.bz2
historical-9dfcbe4d6a6d07c79c033f37a2810e3e2f59d481.zip
Update.
Diffstat (limited to 'dev-python/django')
-rw-r--r--dev-python/django/django-9999.ebuild17
1 files changed, 11 insertions, 6 deletions
diff --git a/dev-python/django/django-9999.ebuild b/dev-python/django/django-9999.ebuild
index 0cf480f6c2c9..b98c02c3a853 100644
--- a/dev-python/django/django-9999.ebuild
+++ b/dev-python/django/django-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-9999.ebuild,v 1.3 2009/05/18 14:58:48 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-9999.ebuild,v 1.4 2009/08/02 19:28:51 arfrever Exp $
EAPI="2"
@@ -17,18 +17,22 @@ IUSE="doc examples mysql postgres sqlite test"
RDEPEND="dev-python/imaging
sqlite? ( || (
+ >=dev-lang/python-2.5[sqlite] )
( dev-python/pysqlite:2 <dev-lang/python-2.5 )
- >=dev-lang/python-2.5[sqlite] ) )
- test? ( || (
- ( dev-python/pysqlite:2 <dev-lang/python-2.5 )
- >=dev-lang/python-2.5[sqlite] ) )
+ )
postgres? ( dev-python/psycopg )
mysql? ( >=dev-python/mysql-python-1.2.1_p2 )"
DEPEND="${RDEPEND}
- doc? ( >=dev-python/sphinx-0.3 )"
+ doc? ( >=dev-python/sphinx-0.3 )
+ test? ( || (
+ >=dev-lang/python-2.5[sqlite] )
+ ( dev-python/pysqlite:2 <dev-lang/python-2.5 )
+ )"
S="${WORKDIR}"
+PYTHON_MODNAME="django"
+
DOCS="docs/*.txt AUTHORS"
src_compile() {
@@ -45,6 +49,7 @@ src_test() {
einfo "Running tests."
cat >> tests/settings.py << __EOF__
DATABASE_ENGINE='sqlite3'
+DATABASE_NAME='test.db'
ROOT_URLCONF='tests/urls.py'
SITE_ID=1
__EOF__