summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-04-23 15:17:53 +0000
committerMike Frysinger <vapier@gentoo.org>2003-04-23 15:17:53 +0000
commit76fe6b0c1bb8f99b40b19bed2491d0218aa9d830 (patch)
treea055eecaa7289f9910be6358654e33105601dcdc /dev-python/PyQt
parenttouchups (diff)
downloadhistorical-76fe6b0c1bb8f99b40b19bed2491d0218aa9d830.tar.gz
historical-76fe6b0c1bb8f99b40b19bed2491d0218aa9d830.tar.bz2
historical-76fe6b0c1bb8f99b40b19bed2491d0218aa9d830.zip
touchups
Diffstat (limited to 'dev-python/PyQt')
-rw-r--r--dev-python/PyQt/PyQt-2.4.ebuild14
-rw-r--r--dev-python/PyQt/PyQt-3.4.ebuild4
-rw-r--r--dev-python/PyQt/PyQt-3.5-r1.ebuild7
-rw-r--r--dev-python/PyQt/PyQt-3.5.ebuild11
4 files changed, 17 insertions, 19 deletions
diff --git a/dev-python/PyQt/PyQt-2.4.ebuild b/dev-python/PyQt/PyQt-2.4.ebuild
index 4d5a797463e1..6ed9a7bfc61f 100644
--- a/dev-python/PyQt/PyQt-2.4.ebuild
+++ b/dev-python/PyQt/PyQt-2.4.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-2.4.ebuild,v 1.15 2003/02/13 11:32:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-2.4.ebuild,v 1.16 2003/04/23 15:17:14 vapier Exp $
-S=${WORKDIR}/${P}
-DESCRIPTION="PyQt is a set of Python bindings for the Qt Toolkit."
+DESCRIPTION="set of Python bindings for the Qt Toolkit"
SRC_URI="http://www.river-bank.demon.co.uk/software/${P}.tar.gz"
HOMEPAGE="http://www.thekompany.com/projects/pykde/"
+
SLOT="0"
LICENSE="MIT"
KEYWORDS="x86 sparc alpha"
@@ -15,10 +15,10 @@ DEPEND="=x11-libs/qt-2*
virtual/python"
src_compile() {
- ./configure --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- --with-doc-install=/usr/share/doc \
+ ./configure --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --with-doc-install=/usr/share/doc \
--with-qt-dir=/usr/qt/2
assert
diff --git a/dev-python/PyQt/PyQt-3.4.ebuild b/dev-python/PyQt/PyQt-3.4.ebuild
index 45d251327e17..472dfb6f6745 100644
--- a/dev-python/PyQt/PyQt-3.4.ebuild
+++ b/dev-python/PyQt/PyQt-3.4.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.4.ebuild,v 1.7 2003/02/13 11:32:49 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.4.ebuild,v 1.8 2003/04/23 15:17:14 vapier Exp $
S="${WORKDIR}/PyQt-x11-gpl-${PV}"
-DESCRIPTION="PyQt is a set of Python bindings for the QT 3.x Toolkit"
+DESCRIPTION="set of Python bindings for the QT 3.x Toolkit"
SRC_URI="http://www.river-bank.demon.co.uk/download/PyQt/PyQt-x11-gpl-${PV}.tar.gz"
HOMEPAGE="http://www.riverbankcomputing.co.uk/pyqt/"
diff --git a/dev-python/PyQt/PyQt-3.5-r1.ebuild b/dev-python/PyQt/PyQt-3.5-r1.ebuild
index 05b34e87e622..3cced1e5ddb2 100644
--- a/dev-python/PyQt/PyQt-3.5-r1.ebuild
+++ b/dev-python/PyQt/PyQt-3.5-r1.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.5-r1.ebuild,v 1.6 2003/04/17 12:55:49 brain Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.5-r1.ebuild,v 1.7 2003/04/23 15:17:14 vapier Exp $
inherit eutils
-IUSE=""
S="${WORKDIR}/PyQt-x11-gpl-${PV}"
-DESCRIPTION="PyQt is a set of Python bindings for the QT 3.x Toolkit"
+DESCRIPTION="set of Python bindings for the QT 3.x Toolkit"
SRC_URI="http://www.river-bank.demon.co.uk/download/PyQt/PyQt-x11-gpl-${PV}.tar.gz"
HOMEPAGE="http://www.riverbankcomputing.co.uk/pyqt/"
+
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 ~ppc ~sparc ~alpha"
@@ -25,7 +25,6 @@ src_unpack() {
epatch $FILESDIR/qt3.1.2-compilation-fix-3.5.diff
}
-
src_compile() {
# standard qt sandbox problem workaround
[ -d "$QTDIR/etc/settings" ] && addwrite "$QTDIR/etc/settings"
diff --git a/dev-python/PyQt/PyQt-3.5.ebuild b/dev-python/PyQt/PyQt-3.5.ebuild
index a532b486521a..3aaa61db0e12 100644
--- a/dev-python/PyQt/PyQt-3.5.ebuild
+++ b/dev-python/PyQt/PyQt-3.5.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.5.ebuild,v 1.3 2003/02/28 16:54:59 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.5.ebuild,v 1.4 2003/04/23 15:17:14 vapier Exp $
+
+inherit eutils
S="${WORKDIR}/PyQt-x11-gpl-${PV}"
-DESCRIPTION="PyQt is a set of Python bindings for the QT 3.x Toolkit"
+DESCRIPTION="set of Python bindings for the QT 3.x Toolkit"
SRC_URI="http://www.river-bank.demon.co.uk/download/PyQt/PyQt-x11-gpl-${PV}.tar.gz"
HOMEPAGE="http://www.riverbankcomputing.co.uk/pyqt/"
@@ -18,14 +20,11 @@ DEPEND="virtual/glibc
=dev-python/sip-${PV}"
src_unpack() {
-
unpack PyQt-x11-gpl-${PV}.tar.gz
cd ${S}
- patch -p0 < ${FILESDIR}/license-3.5.diff
-
+ epatch ${FILESDIR}/license-3.5.diff
}
-
src_compile() {
dodir /usr/lib/python2.2/site-packages
dodir /usr/include/python2.2