summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2007-11-15 19:01:51 +0000
committerMarkus Ullmann <jokey@gentoo.org>2007-11-15 19:01:51 +0000
commit73e6aed0dd9c05835fa26649d3d64966a5ec1524 (patch)
tree94ce5f88b2a16138c6283b31feab59627d696878 /dev-php
parentInitial import from project overlay (diff)
downloadhistorical-73e6aed0dd9c05835fa26649d3d64966a5ec1524.tar.gz
historical-73e6aed0dd9c05835fa26649d3d64966a5ec1524.tar.bz2
historical-73e6aed0dd9c05835fa26649d3d64966a5ec1524.zip
Version bump from project overlay
Package-Manager: portage-2.1.3.19
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/PEAR-PHP_CompatInfo/ChangeLog12
-rw-r--r--dev-php/PEAR-PHP_CompatInfo/PEAR-PHP_CompatInfo-1.5.0.ebuild25
-rw-r--r--dev-php/PEAR-PHP_CompatInfo/files/digest-PEAR-PHP_CompatInfo-1.5.03
-rw-r--r--dev-php/xdebug-client/ChangeLog11
-rw-r--r--dev-php/xdebug-client/files/digest-xdebug-client-2.0.23
-rw-r--r--dev-php/xdebug-client/xdebug-client-2.0.2.ebuild34
6 files changed, 86 insertions, 2 deletions
diff --git a/dev-php/PEAR-PHP_CompatInfo/ChangeLog b/dev-php/PEAR-PHP_CompatInfo/ChangeLog
index 4b826f6f4742..d849e829abf2 100644
--- a/dev-php/PEAR-PHP_CompatInfo/ChangeLog
+++ b/dev-php/PEAR-PHP_CompatInfo/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-php/PEAR-PHP_CompatInfo
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-PHP_CompatInfo/ChangeLog,v 1.1 2007/08/30 12:33:18 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-PHP_CompatInfo/ChangeLog,v 1.2 2007/11/15 18:58:30 jokey Exp $
+
+*PEAR-PHP_CompatInfo-1.5.0 (15 Nov 2007)
+
+ 15 Nov 2007; Markus Ullmann <jokey@gentoo.org>
+ +PEAR-PHP_CompatInfo-1.5.0.ebuild:
+ Version bump from project overlay
+
+ 15 Nov 2007; Jakub Moc <jakub@gentoo.org>
+ +PEAR-PHP_CompatInfo-1.5.0.ebuild:
+ Version bump; fix DOS line breaks.
*PEAR-PHP_CompatInfo-1.4.3 (30 Aug 2007)
diff --git a/dev-php/PEAR-PHP_CompatInfo/PEAR-PHP_CompatInfo-1.5.0.ebuild b/dev-php/PEAR-PHP_CompatInfo/PEAR-PHP_CompatInfo-1.5.0.ebuild
new file mode 100644
index 000000000000..c9a712e77992
--- /dev/null
+++ b/dev-php/PEAR-PHP_CompatInfo/PEAR-PHP_CompatInfo-1.5.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-PHP_CompatInfo/PEAR-PHP_CompatInfo-1.5.0.ebuild,v 1.1 2007/11/15 18:58:30 jokey Exp $
+
+inherit php-pear-r1 depend.php eutils
+
+DESCRIPTION="Find out the minimum version and the extensions required for a piece of code to run."
+
+LICENSE="PHP"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="minimal"
+
+RDEPEND="!minimal? ( >=dev-php/PEAR-Console_Table-1.0.5
+ >=dev-php/PEAR-Console_Getargs-1.3.3 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ edos2unix $(find . -type f -print)
+}
+
+pkg_setup() {
+ require_php_with_use tokenizer
+}
diff --git a/dev-php/PEAR-PHP_CompatInfo/files/digest-PEAR-PHP_CompatInfo-1.5.0 b/dev-php/PEAR-PHP_CompatInfo/files/digest-PEAR-PHP_CompatInfo-1.5.0
new file mode 100644
index 000000000000..b4a763259f6d
--- /dev/null
+++ b/dev-php/PEAR-PHP_CompatInfo/files/digest-PEAR-PHP_CompatInfo-1.5.0
@@ -0,0 +1,3 @@
+MD5 42f2eab3fd5e51d366f6711b4f4bb7e1 PHP_CompatInfo-1.5.0.tgz 119525
+RMD160 86e9a2d9a19bcda19f9914de865fe9db9bda70fe PHP_CompatInfo-1.5.0.tgz 119525
+SHA256 3d8391a54857f1846dd881fdea42bbf4417089f8082658c2f080400cc6a43d22 PHP_CompatInfo-1.5.0.tgz 119525
diff --git a/dev-php/xdebug-client/ChangeLog b/dev-php/xdebug-client/ChangeLog
index 5bb0a7c26fe4..33af0b15c284 100644
--- a/dev-php/xdebug-client/ChangeLog
+++ b/dev-php/xdebug-client/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-php/xdebug-client
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug-client/ChangeLog,v 1.7 2007/10/28 11:45:27 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug-client/ChangeLog,v 1.8 2007/11/15 19:01:50 jokey Exp $
+
+*xdebug-client-2.0.2 (15 Nov 2007)
+
+ 15 Nov 2007; Markus Ullmann <jokey@gentoo.org>
+ +xdebug-client-2.0.2.ebuild:
+ Version bump from project overlay
+
+ 12 Nov 2007; Jakub Moc <jakub@gentoo.org> +xdebug-client-2.0.2.ebuild:
+ Version bump
*xdebug-client-2.0.1 (28 Oct 2007)
diff --git a/dev-php/xdebug-client/files/digest-xdebug-client-2.0.2 b/dev-php/xdebug-client/files/digest-xdebug-client-2.0.2
new file mode 100644
index 000000000000..a7f55a44523d
--- /dev/null
+++ b/dev-php/xdebug-client/files/digest-xdebug-client-2.0.2
@@ -0,0 +1,3 @@
+MD5 b994465f9941db4e7ffa4f8b81fa5c3d xdebug-2.0.2.tgz 279621
+RMD160 c9477d1e760ba9b7a5a8322a3e306d00a0321788 xdebug-2.0.2.tgz 279621
+SHA256 2cee0c176d9cea4d20bea3d57e46f92fa09cf38f678659dd0022e789dcee0bc0 xdebug-2.0.2.tgz 279621
diff --git a/dev-php/xdebug-client/xdebug-client-2.0.2.ebuild b/dev-php/xdebug-client/xdebug-client-2.0.2.ebuild
new file mode 100644
index 000000000000..88e2312accb0
--- /dev/null
+++ b/dev-php/xdebug-client/xdebug-client-2.0.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug-client/xdebug-client-2.0.2.ebuild,v 1.1 2007/11/15 19:01:50 jokey Exp $
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+MY_PV="${PV/_/}"
+MY_PV="${MY_PV/rc/RC}"
+
+DESCRIPTION="Xdebug client for the Common Debugger Protocol (DBGP)."
+HOMEPAGE="http://www.xdebug.org/"
+SRC_URI="http://pecl.php.net/get/xdebug-${MY_PV}.tgz"
+LICENSE="Xdebug"
+SLOT="0"
+IUSE="libedit"
+
+S="${WORKDIR}/xdebug-${MY_PV}/debugclient"
+
+DEPEND="libedit? ( || ( dev-libs/libedit sys-freebsd/freebsd-lib ) )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ chmod +x "${S}"/configure
+}
+
+src_compile() {
+ econf $(use_with libedit) --disable-dependency-tracking
+ emake || die "Build of debug client failed!"
+}
+
+src_install() {
+ newbin debugclient xdebug
+}