summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-12-24 14:54:13 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-12-24 14:54:13 +0000
commita15945cdab2719cb95424b79d14c485f1c5fb149 (patch)
treee10d80bad50b8ad80426222dcd0a318771108c71 /dev-php5/pecl-yaz
parentGet rid of sql dep and assistant build, it's in another package now (diff)
downloadhistorical-a15945cdab2719cb95424b79d14c485f1c5fb149.tar.gz
historical-a15945cdab2719cb95424b79d14c485f1c5fb149.tar.bz2
historical-a15945cdab2719cb95424b79d14c485f1c5fb149.zip
Version bump from the php-overlay
Package-Manager: portage-2.1.3.19
Diffstat (limited to 'dev-php5/pecl-yaz')
-rw-r--r--dev-php5/pecl-yaz/ChangeLog10
-rw-r--r--dev-php5/pecl-yaz/files/digest-pecl-yaz-1.0.133
-rw-r--r--dev-php5/pecl-yaz/pecl-yaz-1.0.13.ebuild27
3 files changed, 39 insertions, 1 deletions
diff --git a/dev-php5/pecl-yaz/ChangeLog b/dev-php5/pecl-yaz/ChangeLog
index ae6f61f997c9..e66bdffb6445 100644
--- a/dev-php5/pecl-yaz/ChangeLog
+++ b/dev-php5/pecl-yaz/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-php5/pecl-yaz
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-yaz/ChangeLog,v 1.25 2007/12/06 01:22:27 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-yaz/ChangeLog,v 1.26 2007/12/24 14:46:30 armin76 Exp $
+
+*pecl-yaz-1.0.13 (24 Dec 2007)
+
+ 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> +pecl-yaz-1.0.13.ebuild:
+ Version bump from the php-overlay
+
+ 18 Dec 2007; Jakub Moc <jakub@gentoo.org> +pecl-yaz-1.0.13.ebuild:
+ Version bump
06 Dec 2007; Markus Ullmann <jokey@gentoo.org> pecl-yaz-1.0.8.ebuild:
LICENSE fix from project overlay
diff --git a/dev-php5/pecl-yaz/files/digest-pecl-yaz-1.0.13 b/dev-php5/pecl-yaz/files/digest-pecl-yaz-1.0.13
new file mode 100644
index 000000000000..b816b590ef18
--- /dev/null
+++ b/dev-php5/pecl-yaz/files/digest-pecl-yaz-1.0.13
@@ -0,0 +1,3 @@
+MD5 ee2c198d0920a0849c97b8454ac2a71d yaz-1.0.13.tgz 16537
+RMD160 f3c106a52d8292f1c190842a210bfbcdedd8367b yaz-1.0.13.tgz 16537
+SHA256 e5c97d13d73ff821690c29b9365ac52eefa62f36dad1cbf74d18b1d08c2c1681 yaz-1.0.13.tgz 16537
diff --git a/dev-php5/pecl-yaz/pecl-yaz-1.0.13.ebuild b/dev-php5/pecl-yaz/pecl-yaz-1.0.13.ebuild
new file mode 100644
index 000000000000..b1ff2a3db851
--- /dev/null
+++ b/dev-php5/pecl-yaz/pecl-yaz-1.0.13.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-yaz/pecl-yaz-1.0.13.ebuild,v 1.1 2007/12/24 14:46:30 armin76 Exp $
+
+PHP_EXT_NAME="yaz"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="README"
+
+inherit php-ext-pecl-r1
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+DESCRIPTION="This extension implements a Z39.50 client for PHP using the YAZ toolkit."
+LICENSE="PHP-3"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-libs/yaz-3.0.2"
+RDEPEND="${DEPEND}"
+
+need_php_by_category
+
+src_compile() {
+ my_conf="--with-yaz=/usr"
+ php-ext-pecl-r1_src_compile
+}