summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Bergmann <sebastian@gentoo.org>2006-09-05 03:59:51 +0000
committerSebastian Bergmann <sebastian@gentoo.org>2006-09-05 03:59:51 +0000
commit0887dd4969bced7c35953f23ba84661c6eb8e77c (patch)
tree85ab01270f832a03fac33d0f0c7f4c2333d465e9 /dev-php5/pecl-apc
parentjbig-kit-1.6-r1 was stabilized the other day, removing mask. (diff)
downloadhistorical-0887dd4969bced7c35953f23ba84661c6eb8e77c.tar.gz
historical-0887dd4969bced7c35953f23ba84661c6eb8e77c.tar.bz2
historical-0887dd4969bced7c35953f23ba84661c6eb8e77c.zip
Version bump.
Package-Manager: portage-2.1.1_rc1-r3
Diffstat (limited to 'dev-php5/pecl-apc')
-rw-r--r--dev-php5/pecl-apc/ChangeLog8
-rw-r--r--dev-php5/pecl-apc/files/digest-pecl-apc-3.0.123
-rw-r--r--dev-php5/pecl-apc/pecl-apc-3.0.12.ebuild74
3 files changed, 84 insertions, 1 deletions
diff --git a/dev-php5/pecl-apc/ChangeLog b/dev-php5/pecl-apc/ChangeLog
index f1f4443dcec3..f35e93c06f67 100644
--- a/dev-php5/pecl-apc/ChangeLog
+++ b/dev-php5/pecl-apc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php5/pecl-apc
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-apc/ChangeLog,v 1.12 2006/08/22 13:28:05 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-apc/ChangeLog,v 1.13 2006/09/05 03:59:51 sebastian Exp $
+
+*pecl-apc-3.0.12 (05 Sep 2006)
+
+ 05 Sep 2006; Sebastian Bergmann <sebastian@gentoo.org>
+ -pecl-apc-3.0.11.ebuild, +pecl-apc-3.0.12.ebuild:
+ Version bump.
22 Aug 2006; Luca Longinotti <chtekk@gentoo.org> pecl-apc-3.0.11.ebuild:
Fix bug #144681.
diff --git a/dev-php5/pecl-apc/files/digest-pecl-apc-3.0.12 b/dev-php5/pecl-apc/files/digest-pecl-apc-3.0.12
new file mode 100644
index 000000000000..bcca40840742
--- /dev/null
+++ b/dev-php5/pecl-apc/files/digest-pecl-apc-3.0.12
@@ -0,0 +1,3 @@
+MD5 4a9d556e965966ae448655d4d5599dd1 APC-3.0.12.tgz 94754
+RMD160 6c0926a5b1fd9398b8bdc346a5494693257b5b83 APC-3.0.12.tgz 94754
+SHA256 0f2f4f52c775fdf7ce591cd969d13042dc3571a4e0d3daafbfe806f399506d7e APC-3.0.12.tgz 94754
diff --git a/dev-php5/pecl-apc/pecl-apc-3.0.12.ebuild b/dev-php5/pecl-apc/pecl-apc-3.0.12.ebuild
new file mode 100644
index 000000000000..d417d36bcb00
--- /dev/null
+++ b/dev-php5/pecl-apc/pecl-apc-3.0.12.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-apc/pecl-apc-3.0.12.ebuild,v 1.1 2006/09/05 03:59:51 sebastian Exp $
+
+PHP_EXT_NAME="apc"
+PHP_EXT_PECL_PKG="APC"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+inherit php-ext-pecl-r1 confutils
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+DESCRIPTION="A free, open, and robust framework for caching and optimizing PHP intermediate code."
+LICENSE="PHP"
+SLOT="0"
+IUSE="mmap"
+
+DEPEND="${DEPEND} >=dev-lang/php-5.1.1"
+
+need_php_by_category
+
+pkg_setup() {
+ has_php
+
+ require_php_sapi_from cgi apache apache2
+}
+
+src_compile() {
+ has_php
+
+ # PECL-APC does not work with Zend Thread Safety (ZTS)
+ # so abort if we are using PHP compiled with ZTS.
+ if has_zts ; then
+ eerror "PECL-APC doesn't work with a ZTS enabled PHP."
+ eerror "Please disable ZTS by turning the 'threads'"
+ eerror "USE flag off when you compile dev-lang/php."
+ die "PECL-APC does not support ZTS"
+ fi
+
+ my_conf="--enable-apc"
+ enable_extension_enable "apc-mmap" "mmap" 0
+ enable_extension_with_built_with =${PHP_PKG} apache2 apxs2 /usr/sbin/apxs2 "optimisation for apache2"
+ enable_extension_with_built_with =${PHP_PKG} apache apxs /usr/sbin/apxs "optimisation for apache1"
+
+ php-ext-pecl-r1_src_compile
+}
+
+src_install() {
+ php-ext-pecl-r1_src_install
+ dodoc-php CHANGELOG INSTALL LICENSE NOTICE
+
+ php-ext-base-r1_addtoinifiles "apc.enabled" '"1"'
+ php-ext-base-r1_addtoinifiles "apc.shm_segments" '"1"'
+ php-ext-base-r1_addtoinifiles "apc.shm_size" '"30"'
+ php-ext-base-r1_addtoinifiles "apc.optimization" '"0"'
+ php-ext-base-r1_addtoinifiles "apc.num_files_hint" '"1000"'
+ php-ext-base-r1_addtoinifiles "apc.ttl" '"0"'
+ php-ext-base-r1_addtoinifiles "apc.gc_ttl" '"3600"'
+ php-ext-base-r1_addtoinifiles "apc.cache_by_default" '"1"'
+ php-ext-base-r1_addtoinifiles "apc.filters" '""'
+ php-ext-base-r1_addtoinifiles "apc.mmap_file_mask" '""'
+ php-ext-base-r1_addtoinifiles "apc.slam_defense" '"0"'
+ php-ext-base-r1_addtoinifiles "apc.file_update_protection" '"2"'
+ php-ext-base-r1_addtoinifiles "apc.stat" '"1"'
+
+ dodir "${PHP_EXT_SHARED_DIR}"
+ insinto "${PHP_EXT_SHARED_DIR}"
+ doins apc.php
+}
+
+pkg_postinst() {
+ einfo "The apc.php file shipped with this release of PECL-APC was"
+ einfo "installed into /usr/share/php5/apc/."
+}