summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2010-10-11 20:14:33 +0000
committerOle Markus With <olemarkus@gentoo.org>2010-10-11 20:14:33 +0000
commitce09685128d94799ba05b164f240d3ac4694582e (patch)
tree7dc19687ba5b51c245027709b1e30c8d19c2f0f9 /dev-php/PEAR-Auth
parentRemove unused patches by jalan (bug #340168). (diff)
downloadhistorical-ce09685128d94799ba05b164f240d3ac4694582e.tar.gz
historical-ce09685128d94799ba05b164f240d3ac4694582e.tar.bz2
historical-ce09685128d94799ba05b164f240d3ac4694582e.zip
Made PEAR_Auth installable. Fixed problem with has_version
Package-Manager: portage-2.1.8.3/cvs/Linux i686
Diffstat (limited to 'dev-php/PEAR-Auth')
-rw-r--r--dev-php/PEAR-Auth/Manifest2
-rw-r--r--dev-php/PEAR-Auth/PEAR-Auth-1.6.2-r1.ebuild7
2 files changed, 5 insertions, 4 deletions
diff --git a/dev-php/PEAR-Auth/Manifest b/dev-php/PEAR-Auth/Manifest
index 0e3a439cac90..9484a0502a5c 100644
--- a/dev-php/PEAR-Auth/Manifest
+++ b/dev-php/PEAR-Auth/Manifest
@@ -1,6 +1,6 @@
DIST Auth-1.5.4.tgz 54478 RMD160 514c124e31d156be26e9e948c00886e72c1cd05b SHA1 9894f577826e9f12c58cdb280263a5a8fc10afaa SHA256 e9fd129cb640dea441c3f5d26e114642ef9fd68097a0d7a8cd30350123f39421
DIST Auth-1.6.2.tgz 56036 RMD160 15ecc892c6c0d6b3568314783b3310c03fdfbb5a SHA1 34b3e8356678b46752ff7fe14d489110b2a9c827 SHA256 c0080812b1e959492dab12c98d15f499a80a600e435ccc68d2d903309c5f3050
EBUILD PEAR-Auth-1.5.4.ebuild 1098 RMD160 ac43d8e5b85205b1763ecf68393bc57c8087f51b SHA1 43ac3cc7adf1588afabdc97dbaf551462f2fca68 SHA256 8fbeeacced2dd2dedd722210a557454047ad6b7fb69b20155074899a6566fe86
-EBUILD PEAR-Auth-1.6.2-r1.ebuild 1031 RMD160 f5066d1b784db43954f0f1d529b41f6b2352e9b6 SHA1 336523474d0a74a809d88996422133dc6dfc0616 SHA256 c5aed2d3e4b94f0a698eb45cc89e4cdf59c79e662a8c05fc12d62b723f90ae64
+EBUILD PEAR-Auth-1.6.2-r1.ebuild 1052 RMD160 1333c9d6e64a5c729c10d433d81c0a7c86751a8c SHA1 35561c1682507cdbb03d9d25d0ee6046ee0010d1 SHA256 ad9fa37daae307747153ded73abe616b6f2f9ff9cabf735862a8193fa561b2ec
MISC ChangeLog 5885 RMD160 c05674bac76de351bd1dd413a3bc83b469607842 SHA1 dc191aaad2accf8ba0148b87e9005748a10eb4d7 SHA256 2bd0b2859875b9eed8652a017b08a3569b8b35bceab724eebf5c81ea8499f2b4
MISC metadata.xml 157 RMD160 a98db3a086fae3c09a903dadbc05f60443ec4b1a SHA1 ddaa23cc35eb917bf8962b652442bebb1ce0f440 SHA256 54f8878ca0228e380abbaa4b529806b5533a6b9b51b3b16c0909e906586a91a1
diff --git a/dev-php/PEAR-Auth/PEAR-Auth-1.6.2-r1.ebuild b/dev-php/PEAR-Auth/PEAR-Auth-1.6.2-r1.ebuild
index 6252790fbff2..7b843eaedb4f 100644
--- a/dev-php/PEAR-Auth/PEAR-Auth-1.6.2-r1.ebuild
+++ b/dev-php/PEAR-Auth/PEAR-Auth-1.6.2-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Auth/PEAR-Auth-1.6.2-r1.ebuild,v 1.2 2010/10/11 19:36:40 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Auth/PEAR-Auth-1.6.2-r1.ebuild,v 1.3 2010/10/11 20:14:33 olemarkus Exp $
EAPI="2"
-inherit php-pear-r1 eutils
+inherit php-pear-r1 depend.php eutils
DESCRIPTION="Provides methods for creating an authentication system using PHP."
LICENSE="PHP-3.01"
@@ -23,7 +23,8 @@ RDEPEND="!minimal? ( >=dev-php/PEAR-Log-1.9.10
# >=dev-php/PEAR-HTTP_Client-1.1.0
pkg_postinst() {
- if ! use minimal && ! has_version "${PHP_PKG}[imap,soap]" ; then
+ has_php
+ if ! use minimal && ! has_version "=${PHP_PKG}[imap,soap]" ; then
elog "${PN} can optionally use php's imap and soap features."
elog "If you want those, recompile ${PHP_PKG} with these flags in USE."
fi