summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2002-12-22 02:25:19 +0000
committerMichael Cummings <mcummings@gentoo.org>2002-12-22 02:25:19 +0000
commit392c67678d5f3557751f981a256430b5f67af73a (patch)
tree58cf6479d51e83de4bf1d139badd060d98d1464f /dev-perl
parentdep for bioperl, bug 11498 (diff)
downloadhistorical-392c67678d5f3557751f981a256430b5f67af73a.tar.gz
historical-392c67678d5f3557751f981a256430b5f67af73a.tar.bz2
historical-392c67678d5f3557751f981a256430b5f67af73a.zip
Dep for bioperl, bug 11498
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/SOAP-Lite/ChangeLog11
-rw-r--r--dev-perl/SOAP-Lite/SOAP-Lite-0.55.ebuild28
-rw-r--r--dev-perl/SOAP-Lite/files/digest-SOAP-Lite-0.551
-rw-r--r--dev-perl/Text-Shellwords/ChangeLog11
-rw-r--r--dev-perl/Text-Shellwords/Text-Shellwords-1.00.ebuild24
-rw-r--r--dev-perl/Text-Shellwords/files/digest-Text-Shellwords-1.001
6 files changed, 76 insertions, 0 deletions
diff --git a/dev-perl/SOAP-Lite/ChangeLog b/dev-perl/SOAP-Lite/ChangeLog
new file mode 100644
index 000000000000..8c6842d2a409
--- /dev/null
+++ b/dev-perl/SOAP-Lite/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-perl/SOAP-Lite
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/SOAP-Lite/ChangeLog,v 1.1 2002/12/22 02:21:01 mcummings Exp $
+
+*SOAP-Lite-0.55 (21 Dec 2002)
+
+ 21 Dec 2002; Michael Cummings <mcummings@gentoo.org>
+ SOAP-Lite-0.55:
+
+ Initial import. Ebuild submitted by Gontran Zepeda <gontran@gontran.net>
+ Dep for bioperl, bug 11498
diff --git a/dev-perl/SOAP-Lite/SOAP-Lite-0.55.ebuild b/dev-perl/SOAP-Lite/SOAP-Lite-0.55.ebuild
new file mode 100644
index 000000000000..33aa90a85639
--- /dev/null
+++ b/dev-perl/SOAP-Lite/SOAP-Lite-0.55.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header $
+
+IUSE=""
+
+inherit perl-module
+
+MY_P=SOAP-Lite-${PV}
+S=${WORKDIR}/${P}
+DESCRIPTION="Provides a simple and lightweight interface to the SOAP protocol (sic) both on client and server side."
+
+SRC_URI="http://cpan.valueclick.com/modules/by-module/SOAP/${P}.tar.gz"
+HOMEPAGE="http://cpan.valueclick.com/modules/by-module/SOAP/${P}.readme"
+
+SLOT="0"
+LICENSE="Artistic | GPL-2"
+KEYWORDS="x86 ~ppc ~sparc ~sparc64 ~alpha"
+
+DEPEND="${DEPEND}
+ dev-perl/XML-Parser
+ dev-perl/MIME-Lite
+ dev-perl/MIME-tools"
+
+src_compile() {
+ (echo yes) | perl-module_src_compile || perl-module_src_compile || die "compile failed"
+ perl-module_src_test || die "test failed"
+}
diff --git a/dev-perl/SOAP-Lite/files/digest-SOAP-Lite-0.55 b/dev-perl/SOAP-Lite/files/digest-SOAP-Lite-0.55
new file mode 100644
index 000000000000..7d507d0845a4
--- /dev/null
+++ b/dev-perl/SOAP-Lite/files/digest-SOAP-Lite-0.55
@@ -0,0 +1 @@
+MD5 77618ef6822aa10eaa8770cc20f0d794 SOAP-Lite-0.55.tar.gz 167076
diff --git a/dev-perl/Text-Shellwords/ChangeLog b/dev-perl/Text-Shellwords/ChangeLog
new file mode 100644
index 000000000000..e53d349a2e4d
--- /dev/null
+++ b/dev-perl/Text-Shellwords/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-perl/Text-Shellwords
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Text-Shellwords/ChangeLog,v 1.1 2002/12/22 02:25:18 mcummings Exp $
+
+*Text-Shellwords-1.00 (21 Dec 2002)
+
+ 21 Dec 2002; Michael Cummings <mcummings@gentoo.org>
+ Text-Shellwords-1.00.ebuild:
+
+ Initial import. Ebuild submitted by Gontran Zepeda <gontran@gontran.net>
+ Dep for bioperl, bug 11498
diff --git a/dev-perl/Text-Shellwords/Text-Shellwords-1.00.ebuild b/dev-perl/Text-Shellwords/Text-Shellwords-1.00.ebuild
new file mode 100644
index 000000000000..6006bfcd1779
--- /dev/null
+++ b/dev-perl/Text-Shellwords/Text-Shellwords-1.00.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header $
+
+IUSE=""
+
+inherit perl-module
+
+MY_P=Text-Shellwords-${PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Provides shellwords() routine which parses lines of text and returns a set of tokens using the same rules that the Unix shell does."
+
+SRC_URI="http://www.cpan.org/modules/by-module/Text/${MY_P}.tar.gz"
+HOMEPAGE="http://www.cpan.org/modules/by-module/Text/${MY_P}.readme"
+
+SLOT="0"
+LICENSE="Artistic | GPL-2"
+KEYWORDS="x86 ~ppc ~sparc ~sparc64 ~alpha"
+
+src_compile() {
+ perl-module_src_compile
+ perl-module_src_test || die "test failed"
+}
diff --git a/dev-perl/Text-Shellwords/files/digest-Text-Shellwords-1.00 b/dev-perl/Text-Shellwords/files/digest-Text-Shellwords-1.00
new file mode 100644
index 000000000000..38eaeb9833bf
--- /dev/null
+++ b/dev-perl/Text-Shellwords/files/digest-Text-Shellwords-1.00
@@ -0,0 +1 @@
+MD5 016f95c2e40a760d261772a40025e543 Text-Shellwords-1.00.tar.gz 1985