summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2006-01-16 20:56:43 +0000
committerMichael Cummings <mcummings@gentoo.org>2006-01-16 20:56:43 +0000
commit96d6bff1527ed51f7c293edf1096d810b3b4a58c (patch)
tree33f5f354c6b0103e32cad41a99e0e34a913e344e /dev-perl/PDL/PDL-2.4.2.ebuild
parentStable on sparc (diff)
downloadhistorical-96d6bff1527ed51f7c293edf1096d810b3b4a58c.tar.gz
historical-96d6bff1527ed51f7c293edf1096d810b3b4a58c.tar.bz2
historical-96d6bff1527ed51f7c293edf1096d810b3b4a58c.zip
Bug 107375, added badval support
Package-Manager: portage-2.1_pre3-r1
Diffstat (limited to 'dev-perl/PDL/PDL-2.4.2.ebuild')
-rw-r--r--dev-perl/PDL/PDL-2.4.2.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/dev-perl/PDL/PDL-2.4.2.ebuild b/dev-perl/PDL/PDL-2.4.2.ebuild
index 9902e445e1bf..f64d0759d0ae 100644
--- a/dev-perl/PDL/PDL-2.4.2.ebuild
+++ b/dev-perl/PDL/PDL-2.4.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/PDL/PDL-2.4.2.ebuild,v 1.9 2005/12/29 18:17:36 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/PDL/PDL-2.4.2.ebuild,v 1.10 2006/01/16 20:56:43 mcummings Exp $
inherit perl-module eutils
@@ -11,7 +11,7 @@ SRC_URI="mirror://cpan/authors/id/C/CS/CSOE/${P}.tar.gz"
LICENSE="Artistic as-is"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ppc sparc x86"
-IUSE="opengl"
+IUSE="opengl badval"
DEPEND=">=sys-libs/ncurses-5.2
perl-core/Filter
@@ -43,6 +43,12 @@ src_unpack() {
${FILESDIR}/perldl.conf > ${S}/perldl.conf
fi
+ if use badval ; then
+ sed -i -e "s:WITH_BADVAL => 0:WITH_BADVAL => 1:" \
+ ${S}/perldl.conf
+ fi
+
+
# Unconditional -fPIC for the lib (#55238)
sed -i -e "s/mycompiler -c -o/mycompiler -fPIC -c -o/" ${S}/Lib/Slatec/Makefile.PL
}