summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2003-10-23 04:45:36 +0000
committerGeorge Shapovalov <george@gentoo.org>2003-10-23 04:45:36 +0000
commit3cdb99eddd760ca5e839fef4197437f341eb6816 (patch)
tree1592df44271a09607e8734aa1958fd1e9d7c2698 /dev-ml/ulex/files
parentfirst version in. ulex: a lexer generator for unicode (diff)
downloadhistorical-3cdb99eddd760ca5e839fef4197437f341eb6816.tar.gz
historical-3cdb99eddd760ca5e839fef4197437f341eb6816.tar.bz2
historical-3cdb99eddd760ca5e839fef4197437f341eb6816.zip
first version in. ulex: a lexer generator for unicode
Diffstat (limited to 'dev-ml/ulex/files')
-rw-r--r--dev-ml/ulex/files/digest-ulex-0.21
-rw-r--r--dev-ml/ulex/files/ulex-0.2-Makefile.patch34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-ml/ulex/files/digest-ulex-0.2 b/dev-ml/ulex/files/digest-ulex-0.2
new file mode 100644
index 000000000000..7905d1cba24b
--- /dev/null
+++ b/dev-ml/ulex/files/digest-ulex-0.2
@@ -0,0 +1 @@
+MD5 dde239249b8eec4e07f546c9516da392 ulex-0.2.tar.gz 22886
diff --git a/dev-ml/ulex/files/ulex-0.2-Makefile.patch b/dev-ml/ulex/files/ulex-0.2-Makefile.patch
new file mode 100644
index 000000000000..6bf29cf81910
--- /dev/null
+++ b/dev-ml/ulex/files/ulex-0.2-Makefile.patch
@@ -0,0 +1,34 @@
+--- /home/mat/tmp/ulex-0.2/Makefile 2003-09-23 00:59:22.000000000 +0200
++++ Makefile 2003-09-28 21:39:51.000000000 +0200
+@@ -5,18 +5,25 @@
+
+
+ install: all
+- ocamlfind install ulex META $(wildcard *.cmi) $(wildcard *.a) $(wildcard *.cma) $(wildcard *.cmxa)
++ ocamlfind install ulex META $(wildcard *.cmi) $(wildcard *.a) $(wildcard *.cma) $(wildcard *.cmxa) $(wildcard *.mli)
+
+ uninstall:
+ ocamlfind remove ulex
+
+-ULEXING = utf8.mli utf8.ml ulexing.mli ulexing.ml
++ULEXING = utf8.ml ulexing.ml
+ ULEX = cset.ml ulex.mli ulex.ml pa_ulex.ml
+
+-ulexing.cma: $(ULEXING)
+- ocamlc -a -o ulexing.cma $(ULEXING)
+-ulexing.cmxa: $(ULEXING)
+- ocamlopt -a -o ulexing.cmxa $(ULEXING)
++%.cmo: %.mli %.ml
++ ocamlc -c -o $@ $+
++
++%.cmx: %.mli %.ml
++ ocamlopt -c -o $@ $+
++
++ulexing.cma: $(ULEXING:.ml=.cmo)
++ ocamlc -linkall -a -o ulexing.cma $+
++
++ulexing.cmxa: $(ULEXING:.ml=.cmx)
++ ocamlopt -linkall -a -o ulexing.cmxa $+
+
+ pa_ulex.cma: $(ULEX)
+ ocamlc -a -o pa_ulex.cma -pp 'camlp4o pa_extend.cmo q_MLast.cmo' -I +camlp4 $(ULEX)