summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-02-03 07:32:46 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-02-03 07:32:46 +0000
commit39b6c132ae992c2877561308b1b96a7c8142bf3e (patch)
tree9f5b79c6a1d41442cc3650eecc3e40b47495b24e /dev-lisp
parentAdded keyword ~amd64. Bug # 40145. (diff)
downloadhistorical-39b6c132ae992c2877561308b1b96a7c8142bf3e.tar.gz
historical-39b6c132ae992c2877561308b1b96a7c8142bf3e.tar.bz2
historical-39b6c132ae992c2877561308b1b96a7c8142bf3e.zip
*** empty log message ***
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/cl-ftp/ChangeLog9
-rw-r--r--dev-lisp/cl-ftp/Manifest3
-rw-r--r--dev-lisp/cl-ftp/cl-ftp-1.3.1.ebuild36
-rw-r--r--dev-lisp/cl-ftp/files/digest-cl-ftp-1.3.11
-rw-r--r--dev-lisp/cl-ftp/metadata.xml10
5 files changed, 59 insertions, 0 deletions
diff --git a/dev-lisp/cl-ftp/ChangeLog b/dev-lisp/cl-ftp/ChangeLog
new file mode 100644
index 000000000000..3a39140ec26c
--- /dev/null
+++ b/dev-lisp/cl-ftp/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-lisp/cl-ftp
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-ftp/ChangeLog,v 1.1 2004/02/03 07:32:46 mkennedy Exp $
+
+*cl-ftp-1.3.1 (03 Feb 2004)
+
+ 03 Feb 2004; <mkennedy@gentoo.org> cl-ftp-1.3.1.ebuild, metadata.xml:
+ Initial port. Ebuild contributed by Andrei Barbu <teval@myrealbox.com>
+
diff --git a/dev-lisp/cl-ftp/Manifest b/dev-lisp/cl-ftp/Manifest
new file mode 100644
index 000000000000..83326fee9083
--- /dev/null
+++ b/dev-lisp/cl-ftp/Manifest
@@ -0,0 +1,3 @@
+MD5 dfccaa6651a4c131425a9887e83f8d55 metadata.xml 408
+MD5 fee3689e27b0a8ab92d6771741257636 cl-ftp-1.3.1.ebuild 951
+MD5 e0d45f55c24f45825f574161e7d0afac files/digest-cl-ftp-1.3.1 63
diff --git a/dev-lisp/cl-ftp/cl-ftp-1.3.1.ebuild b/dev-lisp/cl-ftp/cl-ftp-1.3.1.ebuild
new file mode 100644
index 000000000000..fbc177ad9ee9
--- /dev/null
+++ b/dev-lisp/cl-ftp/cl-ftp-1.3.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-ftp/cl-ftp-1.3.1.ebuild,v 1.1 2004/02/03 07:32:46 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="CL-FTP is a Networking Library that provides FTP client (for now) functionality to Common Lisp programs."
+HOMEPAGE="http://www.mapcar.org/~mrd/cl-ftp/
+ http://packages.debian.org/unstable/devel/cl-ftp
+ http://www.cliki.net/CL-FTP"
+SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-ftp/${PN}_${PV}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86"
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp
+ dev-lisp/cl-acl-compat
+ dev-lisp/cl-split-sequence"
+
+S=${WORKDIR}/${P}
+
+CLPACKAGE=ftp
+
+src_install() {
+ common-lisp-install *.lisp *.asd
+ common-lisp-system-symlink
+ dodoc LICENSE
+}
+
+pkg_preinst() {
+ rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
+}
+
+pkg_postrm() {
+ rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
+}
diff --git a/dev-lisp/cl-ftp/files/digest-cl-ftp-1.3.1 b/dev-lisp/cl-ftp/files/digest-cl-ftp-1.3.1
new file mode 100644
index 000000000000..cbc0a2b7abe7
--- /dev/null
+++ b/dev-lisp/cl-ftp/files/digest-cl-ftp-1.3.1
@@ -0,0 +1 @@
+MD5 09015aee311804cd0e91fc0148e0ce35 cl-ftp_1.3.1.tar.gz 11292
diff --git a/dev-lisp/cl-ftp/metadata.xml b/dev-lisp/cl-ftp/metadata.xml
new file mode 100644
index 000000000000..286f2ae0ff06
--- /dev/null
+++ b/dev-lisp/cl-ftp/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+<longdescription>
+CL-FTP is a library which provides FTP client functionality (for now)
+to a Common Lisp program. CL-FTP uses the ACL-COMPAT package for
+network sockets and the SPLIT-SEQUENCE package for some parsing needs.
+</longdescription>
+</pkgmetadata>