summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-25 21:01:56 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-25 21:01:56 +0000
commitce1b59767ec11fee6577bc2d441009900ab0f95e (patch)
tree28a782c43e72d1d99f5cba10239e573337771049 /dev-lisp/sbcl
parentVersion bump. (diff)
downloadhistorical-ce1b59767ec11fee6577bc2d441009900ab0f95e.tar.gz
historical-ce1b59767ec11fee6577bc2d441009900ab0f95e.tar.bz2
historical-ce1b59767ec11fee6577bc2d441009900ab0f95e.zip
add inherit eutils
Diffstat (limited to 'dev-lisp/sbcl')
-rw-r--r--dev-lisp/sbcl/sbcl-0.8.7-r1.ebuild16
-rw-r--r--dev-lisp/sbcl/sbcl-0.8.7.ebuild16
-rw-r--r--dev-lisp/sbcl/sbcl-0.8.8.ebuild16
-rw-r--r--dev-lisp/sbcl/sbcl-0.8.9.ebuild16
4 files changed, 32 insertions, 32 deletions
diff --git a/dev-lisp/sbcl/sbcl-0.8.7-r1.ebuild b/dev-lisp/sbcl/sbcl-0.8.7-r1.ebuild
index 8eba9d331151..2e9cbfec0aff 100644
--- a/dev-lisp/sbcl/sbcl-0.8.7-r1.ebuild
+++ b/dev-lisp/sbcl/sbcl-0.8.7-r1.ebuild
@@ -1,17 +1,16 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-0.8.7-r1.ebuild,v 1.1 2004/01/29 03:54:31 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-0.8.7-r1.ebuild,v 1.2 2004/04/25 21:00:02 vapier Exp $
-inherit common-lisp-common
+inherit common-lisp-common eutils
-DESCRIPTION="Steel Bank Common Lisp (SBCL) is an implementation of ANSI Common Lisp."
-HOMEPAGE="http://sbcl.sourceforge.net/"
-IUSE="threads"
BV_X86=0.8.1
BV_PPC=0.7.13
BV_SPARC=0.7.13
BV_MIPS=0.7.10
DEB_PV=1
+DESCRIPTION="Steel Bank Common Lisp (SBCL) is an implementation of ANSI Common Lisp."
+HOMEPAGE="http://sbcl.sourceforge.net/"
SRC_URI="http://ftp.debian.org/debian/pool/main/s/sbcl/sbcl_${PV}.orig.tar.gz
mirror://sourceforge/sbcl/${P}-html.tar.bz2
http://ftp.debian.org/debian/pool/main/s/sbcl/sbcl_${PV}-${DEB_PV}.diff.gz
@@ -19,13 +18,14 @@ SRC_URI="http://ftp.debian.org/debian/pool/main/s/sbcl/sbcl_${PV}.orig.tar.gz
ppc? ( mirror://sourceforge/sbcl/${PN}-${BV_PPC}-binary-linux-ppc.tar.bz2 )
sparc? ( mirror://sourceforge/sbcl/${PN}-${BV_SPARC}-sparc-linux-binary.tar.bz2 )
mips? ( mirror://sourceforge/sbcl/${PN}-${BV_MIPS}-mips-linux-binary.tar.gz )"
+
LICENSE="MIT"
SLOT="0"
KEYWORDS="x86 ~ppc ~sparc ~mips"
-PROVIDE="virtual/commonlisp"
-DEPEND="dev-lisp/common-lisp-controller"
+IUSE="threads"
-S=${WORKDIR}/${P}
+DEPEND="dev-lisp/common-lisp-controller"
+PROVIDE="virtual/commonlisp"
src_unpack() {
if use x86; then
diff --git a/dev-lisp/sbcl/sbcl-0.8.7.ebuild b/dev-lisp/sbcl/sbcl-0.8.7.ebuild
index 05f13ebdb784..c0bb98c4e746 100644
--- a/dev-lisp/sbcl/sbcl-0.8.7.ebuild
+++ b/dev-lisp/sbcl/sbcl-0.8.7.ebuild
@@ -1,17 +1,16 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-0.8.7.ebuild,v 1.1 2004/01/12 09:41:24 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-0.8.7.ebuild,v 1.2 2004/04/25 21:00:23 vapier Exp $
-inherit common-lisp-common
+inherit common-lisp-common eutils
-DESCRIPTION="Steel Bank Common Lisp (SBCL) is a Open Source development system for ANSI Common Lisp. It provides an interactive environment including an integrated native compiler, interpreter, and debugger."
-HOMEPAGE="http://sbcl.sourceforge.net/"
-IUSE="threads"
BV_X86=0.8.1
BV_PPC=0.7.13
BV_SPARC=0.7.13
BV_MIPS=0.7.10
DEB_PV=1
+DESCRIPTION="Steel Bank Common Lisp (SBCL) is a Open Source development system for ANSI Common Lisp. It provides an interactive environment including an integrated native compiler, interpreter, and debugger."
+HOMEPAGE="http://sbcl.sourceforge.net/"
SRC_URI="http://ftp.debian.org/debian/pool/main/s/sbcl/sbcl_${PV}.orig.tar.gz
mirror://sourceforge/sbcl/${P}-html.tar.bz2
http://ftp.debian.org/debian/pool/main/s/sbcl/sbcl_${PV}-${DEB_PV}.diff.gz
@@ -19,13 +18,14 @@ SRC_URI="http://ftp.debian.org/debian/pool/main/s/sbcl/sbcl_${PV}.orig.tar.gz
ppc? ( mirror://sourceforge/sbcl/${PN}-${BV_PPC}-binary-linux-ppc.tar.bz2 )
sparc? ( mirror://sourceforge/sbcl/${PN}-${BV_SPARC}-sparc-linux-binary.tar.bz2 )
mips? ( mirror://sourceforge/sbcl/${PN}-${BV_MIPS}-mips-linux-binary.tar.gz )"
+
LICENSE="MIT"
SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~mips"
-PROVIDE="virtual/commonlisp"
-DEPEND="dev-lisp/common-lisp-controller"
+IUSE="threads"
-S=${WORKDIR}/${P}
+DEPEND="dev-lisp/common-lisp-controller"
+PROVIDE="virtual/commonlisp"
src_unpack() {
if use x86; then
diff --git a/dev-lisp/sbcl/sbcl-0.8.8.ebuild b/dev-lisp/sbcl/sbcl-0.8.8.ebuild
index e4ff5e3a5ecf..1d7fd6ee0e44 100644
--- a/dev-lisp/sbcl/sbcl-0.8.8.ebuild
+++ b/dev-lisp/sbcl/sbcl-0.8.8.ebuild
@@ -1,29 +1,29 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-0.8.8.ebuild,v 1.4 2004/03/24 21:52:12 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-0.8.8.ebuild,v 1.5 2004/04/25 21:01:38 vapier Exp $
-inherit common-lisp-common
+inherit common-lisp-common eutils
-DESCRIPTION="Steel Bank Common Lisp (SBCL) is an implementation of ANSI Common Lisp."
-HOMEPAGE="http://sbcl.sourceforge.net/"
-IUSE="threads"
BV_X86=0.8.1
BV_PPC=0.7.13
BV_SPARC=0.7.13
BV_MIPS=0.7.10
+DESCRIPTION="Steel Bank Common Lisp (SBCL) is an implementation of ANSI Common Lisp."
+HOMEPAGE="http://sbcl.sourceforge.net/"
SRC_URI="mirror://sourceforge/sbcl/${P}-source.tar.bz2
mirror://sourceforge/sbcl/${P}-html.tar.bz2
x86? ( mirror://sourceforge/sbcl/${PN}-${BV_X86}-x86-linux-binary.tar.bz2 )
ppc? ( mirror://sourceforge/sbcl/${PN}-${BV_PPC}-binary-linux-ppc.tar.bz2 )
sparc? ( mirror://sourceforge/sbcl/${PN}-${BV_SPARC}-sparc-linux-binary.tar.bz2 )
mips? ( mirror://sourceforge/sbcl/${PN}-${BV_MIPS}-mips-linux-binary.tar.gz )"
+
LICENSE="MIT"
SLOT="0"
KEYWORDS="x86 ~ppc ~sparc ~mips"
-PROVIDE="virtual/commonlisp"
-DEPEND="dev-lisp/common-lisp-controller"
+IUSE="threads"
-S=${WORKDIR}/${P}
+DEPEND="dev-lisp/common-lisp-controller"
+PROVIDE="virtual/commonlisp"
src_unpack() {
if use x86; then
diff --git a/dev-lisp/sbcl/sbcl-0.8.9.ebuild b/dev-lisp/sbcl/sbcl-0.8.9.ebuild
index 2f9c38217b08..b9265f24f472 100644
--- a/dev-lisp/sbcl/sbcl-0.8.9.ebuild
+++ b/dev-lisp/sbcl/sbcl-0.8.9.ebuild
@@ -1,29 +1,29 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-0.8.9.ebuild,v 1.1 2004/03/25 21:09:35 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-0.8.9.ebuild,v 1.2 2004/04/25 21:01:56 vapier Exp $
-inherit common-lisp-common
+inherit common-lisp-common eutils
-DESCRIPTION="Steel Bank Common Lisp (SBCL) is an implementation of ANSI Common Lisp."
-HOMEPAGE="http://sbcl.sourceforge.net/"
-IUSE="threads"
BV_X86=0.8.1
BV_PPC=0.7.13
BV_SPARC=0.7.13
BV_MIPS=0.7.10
+DESCRIPTION="Steel Bank Common Lisp (SBCL) is an implementation of ANSI Common Lisp."
+HOMEPAGE="http://sbcl.sourceforge.net/"
SRC_URI="mirror://sourceforge/sbcl/${P}-source.tar.bz2
mirror://sourceforge/sbcl/${P}-html.tar.bz2
x86? ( mirror://sourceforge/sbcl/${PN}-${BV_X86}-x86-linux-binary.tar.bz2 )
ppc? ( mirror://sourceforge/sbcl/${PN}-${BV_PPC}-binary-linux-ppc.tar.bz2 )
sparc? ( mirror://sourceforge/sbcl/${PN}-${BV_SPARC}-sparc-linux-binary.tar.bz2 )
mips? ( mirror://sourceforge/sbcl/${PN}-${BV_MIPS}-mips-linux-binary.tar.gz )"
+
LICENSE="MIT"
SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~mips"
-PROVIDE="virtual/commonlisp"
-DEPEND="dev-lisp/common-lisp-controller"
+IUSE="threads"
-S=${WORKDIR}/${P}
+DEPEND="dev-lisp/common-lisp-controller"
+PROVIDE="virtual/commonlisp"
src_unpack() {
if use x86; then