summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-02-12 09:13:21 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-02-12 09:13:21 +0000
commit5ac964845b215505f8e7dca14719e32ce27b6cf5 (patch)
tree3d3e3a2ef62c1f538eec3c7d9fca33ad0180e87c /dev-lisp/cl-xml/cl-xml-2-r1.ebuild
parentBump to 0.5 (diff)
downloadhistorical-5ac964845b215505f8e7dca14719e32ce27b6cf5.tar.gz
historical-5ac964845b215505f8e7dca14719e32ce27b6cf5.tar.bz2
historical-5ac964845b215505f8e7dca14719e32ce27b6cf5.zip
Fire in the hole!
Diffstat (limited to 'dev-lisp/cl-xml/cl-xml-2-r1.ebuild')
-rw-r--r--dev-lisp/cl-xml/cl-xml-2-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-lisp/cl-xml/cl-xml-2-r1.ebuild b/dev-lisp/cl-xml/cl-xml-2-r1.ebuild
new file mode 100644
index 000000000000..5c0a1aed3297
--- /dev/null
+++ b/dev-lisp/cl-xml/cl-xml-2-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-xml/cl-xml-2-r1.ebuild,v 1.1 2004/02/12 09:13:21 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="A Simple XML Parser for Common Lisp"
+HOMEPAGE="http://homepage.mac.com/svc/xml/readme.html"
+SRC_URI="mirror://gentoo/xml-${PV}.tar.gz"
+LICENSE="LLGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp"
+
+S=${WORKDIR}/xml
+
+CLPACKAGE='xml-parser-only xml'
+
+src_install() {
+ insinto /usr/share/common-lisp/source/xml
+ doins *.asd *.lisp
+ dodir /usr/share/common-lisp/systems
+ for package in ${CLPACKAGE}; do
+ dosym /usr/share/common-lisp/source/xml/${package}.asd \
+ /usr/share/common-lisp/systems/${package}.asd
+ done
+ dohtml *.html
+ insinto /usr/share/common-lisp/source/${CLPACKAGE}/test
+ doins test/*.{lisp,xml}
+}