summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-02-10 09:18:30 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-02-10 09:18:30 +0000
commit0d2dfd2d08f449866805e76e8d14d3b6407b6a64 (patch)
tree33a5af374b0d315cabeeb12326e6ae35a6082790 /dev-lisp/cl-aspectl/cl-aspectl-0.6.4.ebuild
parentx86 for chrpath (diff)
downloadhistorical-0d2dfd2d08f449866805e76e8d14d3b6407b6a64.tar.gz
historical-0d2dfd2d08f449866805e76e8d14d3b6407b6a64.tar.bz2
historical-0d2dfd2d08f449866805e76e8d14d3b6407b6a64.zip
controler refresh
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'dev-lisp/cl-aspectl/cl-aspectl-0.6.4.ebuild')
-rw-r--r--dev-lisp/cl-aspectl/cl-aspectl-0.6.4.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-lisp/cl-aspectl/cl-aspectl-0.6.4.ebuild b/dev-lisp/cl-aspectl/cl-aspectl-0.6.4.ebuild
new file mode 100644
index 000000000000..661e0741f2ae
--- /dev/null
+++ b/dev-lisp/cl-aspectl/cl-aspectl-0.6.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-aspectl/cl-aspectl-0.6.4.ebuild,v 1.1 2005/02/10 09:18:30 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="AspectL is a library that provides aspect-oriented extensions for Common Lisp/CLOS."
+HOMEPAGE="http://common-lisp.net/project/aspectl/"
+SRC_URI="http://common-lisp.net/project/aspectl/downloads/aspectl-${PV}.zip"
+
+LICENSE="CCPL-Attribution-2.0"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp"
+
+CLPACKAGE=aspectl
+
+S=${WORKDIR}/aspectl-${PV}
+
+src_install() {
+ common-lisp-install *.lisp *.asd
+ common-lisp-system-symlink
+ dohtml *.html *.css
+ docinto tests
+ dodoc tests/*
+}