summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-30 09:13:23 +0000
committerJustin Lecher <jlec@gentoo.org>2010-06-30 09:13:23 +0000
commite0379989fcae59e91c867097de3f716530e60742 (patch)
tree26e720f0714e312ecd126bdc24bd1d142eef7459 /dev-libs
parentFix building with -Wl,--as-needed wrt #325969 by Christian Faulhammer. (diff)
downloadhistorical-e0379989fcae59e91c867097de3f716530e60742.tar.gz
historical-e0379989fcae59e91c867097de3f716530e60742.tar.bz2
historical-e0379989fcae59e91c867097de3f716530e60742.zip
New addition
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/excelformat/ChangeLog10
-rw-r--r--dev-libs/excelformat/Manifest15
-rw-r--r--dev-libs/excelformat/excelformat-100112.ebuild45
-rw-r--r--dev-libs/excelformat/files/100112-gcc.patch12
-rw-r--r--dev-libs/excelformat/metadata.xml7
5 files changed, 89 insertions, 0 deletions
diff --git a/dev-libs/excelformat/ChangeLog b/dev-libs/excelformat/ChangeLog
new file mode 100644
index 000000000000..19f91698e62e
--- /dev/null
+++ b/dev-libs/excelformat/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-libs/excelformat
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/excelformat/ChangeLog,v 1.1 2010/06/30 09:13:22 jlec Exp $
+
+*excelformat-100112 (30 Jun 2010)
+
+ 30 Jun 2010; Justin Lecher <jlec@gentoo.org> +files/100112-gcc.patch,
+ +excelformat-100112.ebuild, +metadata.xml:
+ New addition
+
diff --git a/dev-libs/excelformat/Manifest b/dev-libs/excelformat/Manifest
new file mode 100644
index 000000000000..fb019a243b46
--- /dev/null
+++ b/dev-libs/excelformat/Manifest
@@ -0,0 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+AUX 100112-gcc.patch 256 RMD160 f1207116dde63ba89e137f0eae432e0fcf065eb0 SHA1 f4395187907f35dcf0ed98025c4c72c290acae82 SHA256 05a2918d94be02cf3b790383749cdc92031105802d62f94388f63d1de108d3dc
+DIST excelformat-100112.zip 56615 RMD160 aa15ac6924a5c7b885267c9b10f296bdfa1420c6 SHA1 c7d76abb111f53b8d62376478b8b9f2bd0091eff SHA256 8f71372d565f2a1415cc4a90dbc92c8ce55fd345aaa43a998519baf0662b1ffd
+EBUILD excelformat-100112.ebuild 1106 RMD160 73fc16b5baa7123ae9fa686d5209a1ff0742b459 SHA1 81ab18a8d5781005e9bba69c86f5c5233de6ad62 SHA256 f2f00c22b22a2424e1725d335d706d52c4af6b04dfad10312438013a4d4c9141
+MISC ChangeLog 379 RMD160 fa4693eff18c3d14a45d9bde51d5583309314b60 SHA1 a89eadc1a64d267482b2e7ad7c3991b765df18dd SHA256 94e5082cb17076a2ac3acdc69851cc24476f5150032ab4383d8cac090418d1dd
+MISC metadata.xml 145 RMD160 2e7ada6742a72006db41663232e12148c16a450b SHA1 bbc985b1d57c9235b4edc5dafa8cef63c9bc75a4 SHA256 09d48eadcc7f4b36d3191106359307f8a4943d1314d7a47ec2be3c6eb3eb63c8
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.15 (GNU/Linux)
+
+iEYEARECAAYFAkwrCrgACgkQgAnW8HDreRZnDACff7z5iodHwRZvsEfXnoSOiomm
+rcMAoLMYKJ1VB/+MVasUxaNAYvibwDHF
+=oCEg
+-----END PGP SIGNATURE-----
diff --git a/dev-libs/excelformat/excelformat-100112.ebuild b/dev-libs/excelformat/excelformat-100112.ebuild
new file mode 100644
index 000000000000..c9301540ab66
--- /dev/null
+++ b/dev-libs/excelformat/excelformat-100112.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/excelformat/excelformat-100112.ebuild,v 1.1 2010/06/30 09:13:22 jlec Exp $
+
+EAPI="3"
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Library for reading, writing, and editing of XLS (BIFF8 format) files"
+HOMEPAGE="http://www.codeproject.com/KB/office/ExcelFormat.aspx"
+SRC_URI="mirror://gentoo/${P}.zip"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="CPOL"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+app-arch/unzip"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ edos2unix *
+ epatch "${FILESDIR}"/${PV}-gcc.patch
+}
+
+src_compile() {
+ for i in *.cpp; do
+ cmd="$(tc-getCXX) ${CXXFLAGS} -trigraphs -c $i"
+ einfo ${cmd}
+ ${cmd} || die
+ done
+ cmd="$(tc-getCXX) ${LDFLAGS} -Wl,-soname,libExcelFormat.so.0 -o libExcelFormat.so.0.0.0 `ls *.o`"
+ einfo ${cmd}
+ ${cmd} || die
+}
+
+src_install() {
+ insinto /usr/include/
+ doins BasicExcel.hpp ExcelFormat.h || die
+ dolib.so libExcelFormat.so.0.0.0 || die
+ dosym libExcelFormat.so.0.0.0 /usr/$(get_libdir)/libExcelFormat.so || die
+}
diff --git a/dev-libs/excelformat/files/100112-gcc.patch b/dev-libs/excelformat/files/100112-gcc.patch
new file mode 100644
index 000000000000..9d2c9841f059
--- /dev/null
+++ b/dev-libs/excelformat/files/100112-gcc.patch
@@ -0,0 +1,12 @@
+diff --git a/BasicExcel.cpp b/BasicExcel.cpp
+index 0cf56d9..e41dc3f 100644
+--- a/BasicExcel.cpp
++++ b/BasicExcel.cpp
+@@ -1,5 +1,7 @@
+ #include "ExcelFormat.h"
+
++#include <cstring>
++
+ #if _MSC_VER>=1400 // VS 2005
+ #include <share.h> // _SH_DENYRW
+ #endif
diff --git a/dev-libs/excelformat/metadata.xml b/dev-libs/excelformat/metadata.xml
new file mode 100644
index 000000000000..7190ba7dbb8d
--- /dev/null
+++ b/dev-libs/excelformat/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+ <email>jlec@gentoo.org</email>
+</maintainer>
+</pkgmetadata>