summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-04-05 00:51:45 +0000
committerMike Frysinger <vapier@gentoo.org>2011-04-05 00:51:45 +0000
commita424a19c18a0c2bf0f01f9073ace6df50926612b (patch)
tree9ace3bacf31f9f79f219a1cd2af096af5be3ed65 /dev-libs
parentStable for HPPA (bug #361525). (diff)
downloadhistorical-a424a19c18a0c2bf0f01f9073ace6df50926612b.tar.gz
historical-a424a19c18a0c2bf0f01f9073ace6df50926612b.tar.bz2
historical-a424a19c18a0c2bf0f01f9073ace6df50926612b.zip
old
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/mpfr/files/2.4.1/patch01123
-rw-r--r--dev-libs/mpfr/files/2.4.1/patch0245
-rw-r--r--dev-libs/mpfr/files/2.4.1/patch0325
-rw-r--r--dev-libs/mpfr/files/2.4.1/patch0445
-rw-r--r--dev-libs/mpfr/files/2.4.1/patch0547
-rw-r--r--dev-libs/mpfr/mpfr-2.4.1_p5.ebuild50
-rw-r--r--dev-libs/mpfr/mpfr-3.0.0.ebuild60
7 files changed, 0 insertions, 395 deletions
diff --git a/dev-libs/mpfr/files/2.4.1/patch01 b/dev-libs/mpfr/files/2.4.1/patch01
deleted file mode 100644
index ae927889388f..000000000000
--- a/dev-libs/mpfr/files/2.4.1/patch01
+++ /dev/null
@@ -1,123 +0,0 @@
-diff -Naurd mpfr-2.4.1-a/PATCHES mpfr-2.4.1-b/PATCHES
---- mpfr-2.4.1-a/PATCHES 2009-02-20 09:43:17.000000000 +0000
-+++ mpfr-2.4.1-b/PATCHES 2009-02-27 16:56:29.000000000 +0000
-@@ -0,0 +1 @@
-+remainder-neg
-diff -Naurd mpfr-2.4.1-a/VERSION mpfr-2.4.1-b/VERSION
---- mpfr-2.4.1-a/VERSION 2009-02-25 16:16:08.000000000 +0000
-+++ mpfr-2.4.1-b/VERSION 2009-02-27 16:55:37.000000000 +0000
-@@ -1 +1 @@
--2.4.1
-+2.4.1-p1
-diff -Naurd mpfr-2.4.1-a/mpfr.h mpfr-2.4.1-b/mpfr.h
---- mpfr-2.4.1-a/mpfr.h 2009-02-25 16:16:08.000000000 +0000
-+++ mpfr-2.4.1-b/mpfr.h 2009-02-27 16:55:38.000000000 +0000
-@@ -27,7 +27,7 @@
- #define MPFR_VERSION_MAJOR 2
- #define MPFR_VERSION_MINOR 4
- #define MPFR_VERSION_PATCHLEVEL 1
--#define MPFR_VERSION_STRING "2.4.1"
-+#define MPFR_VERSION_STRING "2.4.1-p1"
-
- /* Macros dealing with MPFR VERSION */
- #define MPFR_VERSION_NUM(a,b,c) (((a) << 16L) | ((b) << 8) | (c))
-diff -Naurd mpfr-2.4.1-a/rem1.c mpfr-2.4.1-b/rem1.c
---- mpfr-2.4.1-a/rem1.c 2009-02-20 09:43:17.000000000 +0000
-+++ mpfr-2.4.1-b/rem1.c 2009-02-27 16:55:15.000000000 +0000
-@@ -170,7 +170,12 @@
- }
-
- if (mpz_cmp_ui (r, 0) == 0)
-- inex = mpfr_set_ui (rem, 0, GMP_RNDN);
-+ {
-+ inex = mpfr_set_ui (rem, 0, GMP_RNDN);
-+ /* take into account sign of x */
-+ if (signx < 0)
-+ mpfr_neg (rem, rem, GMP_RNDN);
-+ }
- else
- {
- if (rnd_q == GMP_RNDN)
-@@ -190,6 +195,9 @@
- *quo += 1;
- }
- }
-+ /* take into account sign of x */
-+ if (signx < 0)
-+ mpz_neg (r, r);
- inex = mpfr_set_z (rem, r, rnd);
- /* if ex > ey, rem should be multiplied by 2^ey, else by 2^ex */
- MPFR_EXP (rem) += (ex > ey) ? ey : ex;
-@@ -198,13 +206,6 @@
- if (quo)
- *quo *= sign;
-
-- /* take into account sign of x */
-- if (signx < 0)
-- {
-- mpfr_neg (rem, rem, GMP_RNDN);
-- inex = -inex;
-- }
--
- mpz_clear (mx);
- mpz_clear (my);
- mpz_clear (r);
-diff -Naurd mpfr-2.4.1-a/tests/tremquo.c mpfr-2.4.1-b/tests/tremquo.c
---- mpfr-2.4.1-a/tests/tremquo.c 2009-02-20 09:43:15.000000000 +0000
-+++ mpfr-2.4.1-b/tests/tremquo.c 2009-02-27 16:55:15.000000000 +0000
-@@ -25,6 +25,36 @@
-
- #include "mpfr-test.h"
-
-+static void
-+bug20090227 (void)
-+{
-+ mpfr_t x, y, r1, r2;
-+ int inex1, inex2;
-+
-+ mpfr_init2 (x, 118);
-+ mpfr_init2 (y, 181);
-+ mpfr_init2 (r1, 140);
-+ mpfr_init2 (r2, 140);
-+ mpfr_set_si (x, -1, GMP_RNDN);
-+ mpfr_set_str_binary (y, "1.100100100001111110110101010001000100001011010001100001000110100110001001100011001100010100010111000000011011100000111001101000100101001000000100100111000001000100010100110011111010");
-+ inex1 = mpfr_remainder (r1, x, y, GMP_RNDU);
-+ /* since the quotient is -1, r1 is the rounding of x+y */
-+ inex2 = mpfr_add (r2, x, y, GMP_RNDU);
-+ if (mpfr_cmp (r1, r2))
-+ {
-+ printf ("Error in mpfr_remainder (bug20090227)\n");
-+ printf ("Expected ");
-+ mpfr_dump (r2);
-+ printf ("Got ");
-+ mpfr_dump (r1);
-+ exit (1);
-+ }
-+ mpfr_clear (x);
-+ mpfr_clear (y);
-+ mpfr_clear (r1);
-+ mpfr_clear (r2);
-+}
-+
- int
- main (int argc, char *argv[])
- {
-@@ -50,6 +80,8 @@
-
- tests_start_mpfr ();
-
-+ bug20090227 ();
-+
- mpfr_init (x);
- mpfr_init (y);
- mpfr_init (r);
-diff -Naurd mpfr-2.4.1-a/version.c mpfr-2.4.1-b/version.c
---- mpfr-2.4.1-a/version.c 2009-02-25 16:16:08.000000000 +0000
-+++ mpfr-2.4.1-b/version.c 2009-02-27 16:55:38.000000000 +0000
-@@ -25,5 +25,5 @@
- const char *
- mpfr_get_version (void)
- {
-- return "2.4.1";
-+ return "2.4.1-p1";
- }
diff --git a/dev-libs/mpfr/files/2.4.1/patch02 b/dev-libs/mpfr/files/2.4.1/patch02
deleted file mode 100644
index c6b6aaccde55..000000000000
--- a/dev-libs/mpfr/files/2.4.1/patch02
+++ /dev/null
@@ -1,45 +0,0 @@
-diff -Naurd mpfr-2.4.1-a/PATCHES mpfr-2.4.1-b/PATCHES
---- mpfr-2.4.1-a/PATCHES 2009-03-04 13:15:05.000000000 +0000
-+++ mpfr-2.4.1-b/PATCHES 2009-03-04 13:17:04.000000000 +0000
-@@ -0,0 +1 @@
-+assert
-diff -Naurd mpfr-2.4.1-a/VERSION mpfr-2.4.1-b/VERSION
---- mpfr-2.4.1-a/VERSION 2009-02-27 16:55:37.000000000 +0000
-+++ mpfr-2.4.1-b/VERSION 2009-03-04 13:16:46.000000000 +0000
-@@ -1 +1 @@
--2.4.1-p1
-+2.4.1-p2
-diff -Naurd mpfr-2.4.1-a/mpfr-gmp.c mpfr-2.4.1-b/mpfr-gmp.c
---- mpfr-2.4.1-a/mpfr-gmp.c 2009-02-20 09:43:17.000000000 +0000
-+++ mpfr-2.4.1-b/mpfr-gmp.c 2009-03-04 13:16:39.000000000 +0000
-@@ -301,7 +301,7 @@
- if (linenum != -1)
- fprintf (stderr, "%d: ", linenum);
- }
-- fprintf (stderr, " assertion failed: %s\n", expr);
-+ fprintf (stderr, "MPFR assertion failed: %s\n", expr);
- abort();
- }
-
-diff -Naurd mpfr-2.4.1-a/mpfr.h mpfr-2.4.1-b/mpfr.h
---- mpfr-2.4.1-a/mpfr.h 2009-02-27 16:55:38.000000000 +0000
-+++ mpfr-2.4.1-b/mpfr.h 2009-03-04 13:16:46.000000000 +0000
-@@ -27,7 +27,7 @@
- #define MPFR_VERSION_MAJOR 2
- #define MPFR_VERSION_MINOR 4
- #define MPFR_VERSION_PATCHLEVEL 1
--#define MPFR_VERSION_STRING "2.4.1-p1"
-+#define MPFR_VERSION_STRING "2.4.1-p2"
-
- /* Macros dealing with MPFR VERSION */
- #define MPFR_VERSION_NUM(a,b,c) (((a) << 16L) | ((b) << 8) | (c))
-diff -Naurd mpfr-2.4.1-a/version.c mpfr-2.4.1-b/version.c
---- mpfr-2.4.1-a/version.c 2009-02-27 16:55:38.000000000 +0000
-+++ mpfr-2.4.1-b/version.c 2009-03-04 13:16:46.000000000 +0000
-@@ -25,5 +25,5 @@
- const char *
- mpfr_get_version (void)
- {
-- return "2.4.1-p1";
-+ return "2.4.1-p2";
- }
diff --git a/dev-libs/mpfr/files/2.4.1/patch03 b/dev-libs/mpfr/files/2.4.1/patch03
deleted file mode 100644
index e85136a5621e..000000000000
--- a/dev-libs/mpfr/files/2.4.1/patch03
+++ /dev/null
@@ -1,25 +0,0 @@
-diff -Naurd mpfr-2.4.1-a/tests/tfprintf.c mpfr-2.4.1-b/tests/tfprintf.c
---- mpfr-2.4.1-a/tests/tfprintf.c 2009-02-20 09:43:15.000000000 +0000
-+++ mpfr-2.4.1-b/tests/tfprintf.c 2009-03-10 01:12:45.000000000 +0000
-@@ -195,7 +195,7 @@
- check_vfprintf (fout, "a. %Pu, b. %c, c. %Zi%Zn", prec, ch, mpz, &mpz);
- check_length_with_cmp (6, mpz, 17, mpz_cmp_ui (mpz, 17), Zi);
- check_vfprintf (fout, "%% a. %#.0RNg, b. %Qx%Rn, c. %p", mpfr, mpq, &mpfr,
-- &i);
-+ (void *) &i);
- check_length_with_cmp (7, mpfr, 16, mpfr_cmp_ui (mpfr, 16), Rg);
-
- #ifndef NPRINTF_T
-diff -Naurd mpfr-2.4.1-a/tests/tprintf.c mpfr-2.4.1-b/tests/tprintf.c
---- mpfr-2.4.1-a/tests/tprintf.c 2009-02-20 09:43:15.000000000 +0000
-+++ mpfr-2.4.1-b/tests/tprintf.c 2009-03-10 01:12:45.000000000 +0000
-@@ -191,7 +191,8 @@
- check_length (5, sz, 34, zu);
- check_vprintf ("a. %Pu, b. %c, c. %RUG, d. %Zi%Zn", prec, ch, mpfr, mpz, &mpz);
- check_length_with_cmp (6, mpz, 24, mpz_cmp_ui (mpz, 24), Zi);
-- check_vprintf ("%% a. %#.0RNg, b. %Qx%Rn c. %p", mpfr, mpq, &mpfr, &i);
-+ check_vprintf ("%% a. %#.0RNg, b. %Qx%Rn c. %p",
-+ mpfr, mpq, &mpfr, (void *) &i);
- check_length_with_cmp (7, mpfr, 16, mpfr_cmp_ui (mpfr, 16), Rg);
-
- #ifndef NPRINTF_T
diff --git a/dev-libs/mpfr/files/2.4.1/patch04 b/dev-libs/mpfr/files/2.4.1/patch04
deleted file mode 100644
index 08e21f25def7..000000000000
--- a/dev-libs/mpfr/files/2.4.1/patch04
+++ /dev/null
@@ -1,45 +0,0 @@
-diff -Naurd mpfr-2.4.1-a/PATCHES mpfr-2.4.1-b/PATCHES
---- mpfr-2.4.1-a/PATCHES 2009-03-10 01:44:39.000000000 +0000
-+++ mpfr-2.4.1-b/PATCHES 2009-03-10 01:44:40.000000000 +0000
-@@ -0,0 +1 @@
-+vasprintf-mp_limb_t
-diff -Naurd mpfr-2.4.1-a/VERSION mpfr-2.4.1-b/VERSION
---- mpfr-2.4.1-a/VERSION 2009-03-04 13:16:46.000000000 +0000
-+++ mpfr-2.4.1-b/VERSION 2009-03-10 01:44:40.000000000 +0000
-@@ -1 +1 @@
--2.4.1-p2
-+2.4.1-p4
-diff -Naurd mpfr-2.4.1-a/mpfr.h mpfr-2.4.1-b/mpfr.h
---- mpfr-2.4.1-a/mpfr.h 2009-03-04 13:16:46.000000000 +0000
-+++ mpfr-2.4.1-b/mpfr.h 2009-03-10 01:44:40.000000000 +0000
-@@ -27,7 +27,7 @@
- #define MPFR_VERSION_MAJOR 2
- #define MPFR_VERSION_MINOR 4
- #define MPFR_VERSION_PATCHLEVEL 1
--#define MPFR_VERSION_STRING "2.4.1-p2"
-+#define MPFR_VERSION_STRING "2.4.1-p4"
-
- /* Macros dealing with MPFR VERSION */
- #define MPFR_VERSION_NUM(a,b,c) (((a) << 16L) | ((b) << 8) | (c))
-diff -Naurd mpfr-2.4.1-a/vasprintf.c mpfr-2.4.1-b/vasprintf.c
---- mpfr-2.4.1-a/vasprintf.c 2009-02-20 09:43:17.000000000 +0000
-+++ mpfr-2.4.1-b/vasprintf.c 2009-03-10 01:44:40.000000000 +0000
-@@ -398,7 +398,7 @@
- (void) va_arg ((ap), mpq_srcptr); \
- break; \
- case MP_LIMB_ARG: \
-- (void) va_arg ((ap), mp_ptr); \
-+ (void) va_arg ((ap), mp_limb_t); \
- break; \
- case MP_LIMB_ARRAY_ARG: \
- (void) va_arg ((ap), mp_ptr); \
-diff -Naurd mpfr-2.4.1-a/version.c mpfr-2.4.1-b/version.c
---- mpfr-2.4.1-a/version.c 2009-03-04 13:16:46.000000000 +0000
-+++ mpfr-2.4.1-b/version.c 2009-03-10 01:44:40.000000000 +0000
-@@ -25,5 +25,5 @@
- const char *
- mpfr_get_version (void)
- {
-- return "2.4.1-p2";
-+ return "2.4.1-p4";
- }
diff --git a/dev-libs/mpfr/files/2.4.1/patch05 b/dev-libs/mpfr/files/2.4.1/patch05
deleted file mode 100644
index 710c698d8898..000000000000
--- a/dev-libs/mpfr/files/2.4.1/patch05
+++ /dev/null
@@ -1,47 +0,0 @@
-diff -Naurd mpfr-2.4.1-a/PATCHES mpfr-2.4.1-b/PATCHES
---- mpfr-2.4.1-a/PATCHES 2009-03-13 02:50:47.000000000 +0000
-+++ mpfr-2.4.1-b/PATCHES 2009-03-13 02:50:48.000000000 +0000
-@@ -0,0 +1 @@
-+zeta_ui-shift
-diff -Naurd mpfr-2.4.1-a/VERSION mpfr-2.4.1-b/VERSION
---- mpfr-2.4.1-a/VERSION 2009-03-10 01:44:40.000000000 +0000
-+++ mpfr-2.4.1-b/VERSION 2009-03-13 02:50:48.000000000 +0000
-@@ -1 +1 @@
--2.4.1-p4
-+2.4.1-p5
-diff -Naurd mpfr-2.4.1-a/mpfr.h mpfr-2.4.1-b/mpfr.h
---- mpfr-2.4.1-a/mpfr.h 2009-03-10 01:44:40.000000000 +0000
-+++ mpfr-2.4.1-b/mpfr.h 2009-03-13 02:50:48.000000000 +0000
-@@ -27,7 +27,7 @@
- #define MPFR_VERSION_MAJOR 2
- #define MPFR_VERSION_MINOR 4
- #define MPFR_VERSION_PATCHLEVEL 1
--#define MPFR_VERSION_STRING "2.4.1-p4"
-+#define MPFR_VERSION_STRING "2.4.1-p5"
-
- /* Macros dealing with MPFR VERSION */
- #define MPFR_VERSION_NUM(a,b,c) (((a) << 16L) | ((b) << 8) | (c))
-diff -Naurd mpfr-2.4.1-a/version.c mpfr-2.4.1-b/version.c
---- mpfr-2.4.1-a/version.c 2009-03-10 01:44:40.000000000 +0000
-+++ mpfr-2.4.1-b/version.c 2009-03-13 02:50:48.000000000 +0000
-@@ -25,5 +25,5 @@
- const char *
- mpfr_get_version (void)
- {
-- return "2.4.1-p4";
-+ return "2.4.1-p5";
- }
-diff -Naurd mpfr-2.4.1-a/zeta_ui.c mpfr-2.4.1-b/zeta_ui.c
---- mpfr-2.4.1-a/zeta_ui.c 2009-02-20 09:43:17.000000000 +0000
-+++ mpfr-2.4.1-b/zeta_ui.c 2009-03-13 02:50:48.000000000 +0000
-@@ -177,7 +177,9 @@
- mpz_mul_ui (t, t, 2 * k - 1);
- }
- mpz_div_2exp (t, t, 1);
-- if (n < 1UL << (BITS_PER_MP_LIMB / 2))
-+ /* Warning: the test below assumes that an unsigned long
-+ has no padding bits. */
-+ if (n < 1UL << ((sizeof(unsigned long) * CHAR_BIT) / 2))
- /* (n - k + 1) * (n + k - 1) < n^2 */
- mpz_divexact_ui (t, t, (n - k + 1) * (n + k - 1));
- else
diff --git a/dev-libs/mpfr/mpfr-2.4.1_p5.ebuild b/dev-libs/mpfr/mpfr-2.4.1_p5.ebuild
deleted file mode 100644
index 6038776a9160..000000000000
--- a/dev-libs/mpfr/mpfr-2.4.1_p5.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/mpfr/mpfr-2.4.1_p5.ebuild,v 1.10 2010/01/29 19:56:06 armin76 Exp $
-
-# NOTE: we cannot depend on autotools here starting with gcc-4.3.x
-inherit eutils
-
-MY_PV=${PV/_p*}
-MY_P=${PN}-${MY_PV}
-PLEVEL=${PV/*p}
-DESCRIPTION="library for multiple-precision floating-point computations with exact rounding"
-HOMEPAGE="http://www.mpfr.org/"
-SRC_URI="http://www.mpfr.org/mpfr-current/${MY_P}.tar.lzma"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE=""
-
-RDEPEND=">=dev-libs/gmp-4.1.4-r2"
-DEPEND="${RDEPEND}
- || ( app-arch/xz-utils app-arch/lzma-utils )"
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- [[ -d ${FILESDIR}/${PV} ]] && epatch "${FILESDIR}"/${PV}/*.patch
- [[ ${PLEVEL} == ${PV} ]] && return 0
- for ((i=1; i<=PLEVEL; ++i)) ; do
- patch=patch$(printf '%02d' ${i})
- if [[ -f ${FILESDIR}/${MY_PV}/${patch} ]] ; then
- epatch "${FILESDIR}"/${MY_PV}/${patch}
- elif [[ -f ${DISTDIR}/${PN}-${MY_PV}_p${i} ]] ; then
- epatch "${DISTDIR}"/${PN}-${MY_PV}_p${i}
- else
- ewarn "${DISTDIR}/${PN}-${MY_PV}_p${i}"
- die "patch ${i} missing - please report to bugs.gentoo.org"
- fi
- done
- sed -i '/if test/s:==:=:' configure #261016
- find . -type f -print0 | xargs -0 touch -r configure
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die
- dodoc AUTHORS BUGS ChangeLog NEWS README TODO
- dohtml *.html
-}
diff --git a/dev-libs/mpfr/mpfr-3.0.0.ebuild b/dev-libs/mpfr/mpfr-3.0.0.ebuild
deleted file mode 100644
index 15b77012fac3..000000000000
--- a/dev-libs/mpfr/mpfr-3.0.0.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/mpfr/mpfr-3.0.0.ebuild,v 1.2 2010/06/20 09:13:43 vapier Exp $
-
-# NOTE: we cannot depend on autotools here starting with gcc-4.3.x
-inherit eutils
-
-MY_PV=${PV/_p*}
-MY_P=${PN}-${MY_PV}
-PLEVEL=${PV/*p}
-DESCRIPTION="library for multiple-precision floating-point computations with exact rounding"
-HOMEPAGE="http://www.mpfr.org/"
-SRC_URI="http://www.mpfr.org/mpfr-current/${MY_P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE=""
-
-RDEPEND=">=dev-libs/gmp-4.1.4-r2"
-DEPEND="${RDEPEND}"
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- [[ -d ${FILESDIR}/${PV} ]] && epatch "${FILESDIR}"/${PV}/*.patch
- [[ ${PLEVEL} == ${PV} ]] && return 0
- for ((i=1; i<=PLEVEL; ++i)) ; do
- patch=patch$(printf '%02d' ${i})
- if [[ -f ${FILESDIR}/${MY_PV}/${patch} ]] ; then
- epatch "${FILESDIR}"/${MY_PV}/${patch}
- elif [[ -f ${DISTDIR}/${PN}-${MY_PV}_p${i} ]] ; then
- epatch "${DISTDIR}"/${PN}-${MY_PV}_p${i}
- else
- ewarn "${DISTDIR}/${PN}-${MY_PV}_p${i}"
- die "patch ${i} missing - please report to bugs.gentoo.org"
- fi
- done
- sed -i '/if test/s:==:=:' configure #261016
- find . -type f -print0 | xargs -0 touch -r configure
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die
- rm "${D}"/usr/share/doc/${PN}/*.html || die
- mv "${D}"/usr/share/doc/{${PN},${PF}} || die
- dodoc AUTHORS BUGS ChangeLog NEWS README TODO
- dohtml *.html
- prepalldocs
-}
-
-pkg_preinst() {
- preserve_old_lib /usr/$(get_libdir)/libmpfr.so.1
-}
-
-pkg_postinst() {
- preserve_old_lib_notify /usr/$(get_libdir)/libmpfr.so.1
-}