summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2015-01-16 16:23:18 +0000
committerThomas Sachau <tommy@gentoo.org>2015-01-16 16:23:18 +0000
commit3466d94a7ee56d7508ca9c7b8389d0623c00b3ae (patch)
treeec85b7885859bb1c7218b9a8e457b741086eed9e /dev-libs/poco/poco-1.3.3_p1.ebuild
parentversion bump for #536754. (diff)
downloadhistorical-3466d94a7ee56d7508ca9c7b8389d0623c00b3ae.tar.gz
historical-3466d94a7ee56d7508ca9c7b8389d0623c00b3ae.tar.bz2
historical-3466d94a7ee56d7508ca9c7b8389d0623c00b3ae.zip
Remove old versions
Package-Manager: portage-2.2.15/cvs/Linux x86_64 Manifest-Sign-Key: 0x35899067
Diffstat (limited to 'dev-libs/poco/poco-1.3.3_p1.ebuild')
-rw-r--r--dev-libs/poco/poco-1.3.3_p1.ebuild118
1 files changed, 0 insertions, 118 deletions
diff --git a/dev-libs/poco/poco-1.3.3_p1.ebuild b/dev-libs/poco/poco-1.3.3_p1.ebuild
deleted file mode 100644
index 4bd95748fd9d..000000000000
--- a/dev-libs/poco/poco-1.3.3_p1.ebuild
+++ /dev/null
@@ -1,118 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/poco/poco-1.3.3_p1.ebuild,v 1.7 2014/08/10 20:38:45 slyfox Exp $
-
-EAPI="2"
-
-inherit eutils toolchain-funcs flag-o-matic multilib versionator
-
-MY_P="${P/_}"
-MY_DOCP="${PN}-$(get_version_component_range 1-3)-doc"
-
-DESCRIPTION="C++ class libraries to simplify the development of network-centric, portable applications"
-HOMEPAGE="http://pocoproject.org/"
-SRC_URI="mirror://sourceforge/poco/${MY_P}-all.tar.bz2
- doc? ( mirror://sourceforge/poco/${MY_DOCP}.tar.gz )"
-LICENSE="Boost-1.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples iodbc mysql odbc sqlite ssl test"
-
-DEPEND="dev-libs/libpcre
- dev-libs/expat
- sys-libs/zlib
- mysql? ( dev-db/mysql )
- odbc? ( iodbc? ( dev-db/libiodbc )
- !iodbc? ( dev-db/unixODBC ) )
- ssl? ( dev-libs/openssl )
- sqlite? ( dev-db/sqlite:3 )"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}-all"
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${PV}-gentoo.patch \
- "${FILESDIR}"/${PV}-unbundle_libs.patch \
- "${FILESDIR}"/${PV}-gcc44.patch \
- "${FILESDIR}"/${PV}-openssl-1.patch
-}
-
-src_configure() {
- targets="all"
- odbc="unixodbc"
-
- if use ssl; then
- targets="${targets} NetSSL_OpenSSL-libexec Crypto-libexec"
- echo NetSSL_OpenSSL >> components
- echo Crypto >> components
- fi
- if use odbc; then
- targets="${targets} Data/ODBC-libexec"
- echo Data/ODBC >> components
- if use iodbc; then
- append-flags "-I/usr/include/iodbc"
- odbc="iodbc"
- fi
- fi
- if use sqlite; then
- targets="${targets} Data/SQLite-libexec"
- echo Data/SQLite >> components
- fi
- if use mysql; then
- targets="${targets} Data/MySQL-libexec"
- echo Data/MySQL >> components
- fi
-
- if use test; then
- targets="${targets} cppunit tests"
- echo CppUnit >> components
- use ssl && targets="${targets} NetSSL_OpenSSL-tests Crypto-tests"
- use odbc && targets="${targets} Data/ODBC-tests"
- use sqlite && targets="${targets} Data/SQLite-tests"
- use mysql && targets="${targets} Data/MySQL-tests"
- fi
-
- local myconf
- use test || myconf="--no-tests"
- # not autoconf
- ./configure \
- --no-samples ${myconf} \
- --prefix=/usr \
- || die "configure failed"
-
- sed -i \
- -e "s|CC = .*|CC = $(tc-getCC)|" \
- -e "s|CXX = .*|CXX = $(tc-getCXX)|" \
- -e "s|RANLIB = .*|RANLIB = $(tc-getRANLIB)|" \
- -e "s|LIB = ar|LIB = $(tc-getAR)|" \
- -e "s|STRIP = .*|STRIP = /bin/true|" \
- -e "s|CFLAGS = |CFLAGS = ${CFLAGS}|" \
- -e "s|CXXFLAGS = |CXXFLAGS = ${CXXFLAGS} |" \
- -e "s|LINKFLAGS = |LINKFLAGS = ${LDFLAG} |" \
- -e 's|-O2||g' \
- build/config/Linux build/config/FreeBSD || die "sed failed"
-}
-
-src_compile() {
- emake POCO_PREFIX=/usr GENTOO_ODBC="${odbc}" LIBDIR="$(get_libdir)" ${targets} || die "emake failed"
-}
-
-src_install() {
- emake POCO_PREFIX=/usr LIBDIR="$(get_libdir)" DESTDIR="${D}" install || die "emake install failed"
-
- dodoc CHANGELOG CONTRIBUTORS NEWS README
-
- use doc && dohtml -r "${WORKDIR}/${MY_DOCP}"/*
-
- if use examples ; then
- for d in Net XML Data Util NetSSL_OpenSSL Foundation ; do
- insinto /usr/share/doc/${PF}/examples/${d}
- doins -r ${d}/samples
- done
- find "${D}/usr/share/doc/${PF}/examples" \
- -iname "*.sln" -or -iname "*.vcproj" -or \
- -iname "*.vmsbuild" -or -iname "*.properties" \
- | xargs rm
- fi
-}