summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gardiner <obz@gentoo.org>2004-08-22 17:35:54 +0000
committerMike Gardiner <obz@gentoo.org>2004-08-22 17:35:54 +0000
commit15a644eceb01dabb91bfc3c36fb342ccb10bc866 (patch)
treec0cc747058e7d5c370859dff236c65ec05ea2d25 /dev-libs/libxml2/libxml2-2.6.12.ebuild
parentStable on alpha. (diff)
downloadhistorical-15a644eceb01dabb91bfc3c36fb342ccb10bc866.tar.gz
historical-15a644eceb01dabb91bfc3c36fb342ccb10bc866.tar.bz2
historical-15a644eceb01dabb91bfc3c36fb342ccb10bc866.zip
New version 2.6.12
Diffstat (limited to 'dev-libs/libxml2/libxml2-2.6.12.ebuild')
-rw-r--r--dev-libs/libxml2/libxml2-2.6.12.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/dev-libs/libxml2/libxml2-2.6.12.ebuild b/dev-libs/libxml2/libxml2-2.6.12.ebuild
new file mode 100644
index 000000000000..105bbbaf779f
--- /dev/null
+++ b/dev-libs/libxml2/libxml2-2.6.12.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.6.12.ebuild,v 1.1 2004/08/22 17:35:54 obz Exp $
+
+inherit libtool gnome.org flag-o-matic gnuconfig
+
+DESCRIPTION="Version 2 of the library to manipulate XML files"
+HOMEPAGE="http://www.xmlsoft.org/"
+LICENSE="MIT"
+
+SLOT="2"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64 ~ppc64 ~s390"
+IUSE="python readline ipv6"
+
+DEPEND="sys-libs/zlib
+ python? ( dev-lang/python )
+ readline? ( sys-libs/readline )"
+
+src_unpack() {
+ unpack ${A}
+ gnuconfig_update ${S}
+}
+
+src_compile() {
+
+ # Please do not remove, as else we get references to PORTAGE_TMPDIR
+ # in /usr/lib/python?.?/site-packages/libxml2mod.la among things.
+ elibtoolize
+
+ # filter seemingly problematic CFLAGS (#26320)
+ filter-flags -fprefetch-loop-arrays -funroll-loops
+
+ # USE zlib support breaks gnome2
+ # (libgnomeprint for instance fails to compile with
+ # fresh install, and existing) - <azarah@gentoo.org> (22 Dec 2002).
+
+ econf --with-zlib \
+ `use_with python` \
+ `use_with readline` \
+ `use_enable ipv6` || die
+
+ emake || die
+
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS Copyright ChangeLog INSTALL NEWS README TODO
+
+}
+
+pkg_postinst() {
+
+ # need an XML catalog, so no-one writes to a non-existent one
+ CATALOG=/etc/xml/catalog
+ # we dont want to clobber an existing catalog though,
+ # only ensure that one is there
+ # <obz@gentoo.org>
+ if [ ! -e ${CATALOG} ]; then
+ [ -d /etc/xml ] || mkdir /etc/xml
+ /usr/bin/xmlcatalog --create > ${CATALOG}
+ einfo "Created XML catalog in ${CATALOG}"
+ fi
+
+}