summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2005-02-12 16:02:02 +0000
committerMamoru Komachi <usata@gentoo.org>2005-02-12 16:02:02 +0000
commit91a7ccbc9870a2d5939ff0759af0b1a4f0c949e1 (patch)
tree91dd3ccfff757e29c6772bd432ec4cf30494574d /dev-libs/libmoe/libmoe-1.5.8.ebuild
parentFix wrong commit. Sorry :( .Fix Wrong commit. Sorry :( . (diff)
downloadhistorical-91a7ccbc9870a2d5939ff0759af0b1a4f0c949e1.tar.gz
historical-91a7ccbc9870a2d5939ff0759af0b1a4f0c949e1.tar.bz2
historical-91a7ccbc9870a2d5939ff0759af0b1a4f0c949e1.zip
Version bumped. Removed old ebuild.
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'dev-libs/libmoe/libmoe-1.5.8.ebuild')
-rw-r--r--dev-libs/libmoe/libmoe-1.5.8.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-libs/libmoe/libmoe-1.5.8.ebuild b/dev-libs/libmoe/libmoe-1.5.8.ebuild
new file mode 100644
index 000000000000..1798aa78bb27
--- /dev/null
+++ b/dev-libs/libmoe/libmoe-1.5.8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmoe/libmoe-1.5.8.ebuild,v 1.1 2005/02/12 16:02:02 usata Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="multi octet character encoding handling library"
+HOMEPAGE="http://pub.ks-and-ks.ne.jp/prog/libmoe/"
+SRC_URI="http://pub.ks-and-ks.ne.jp/prog/pub/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc -alpha"
+IUSE=""
+
+DEPEND="virtual/libc
+ dev-lang/perl"
+
+src_compile() {
+ emake CF="${CFLAGS} -I." \
+ LF="${LDFLAGS} -shared"\
+ CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ make DESTDIR=${D} \
+ PREFIX=/usr \
+ MAN=/usr/share/man \
+ install-lib install-man || die
+
+ exeinto /usr/bin
+ doexe mbconv
+
+ dolib.so libmoe.so.${PV} || die
+ dosym /usr/lib/libmoe.so.${PV} /usr/lib/libmoe.so.${PV%%.*}
+ dosym /usr/lib/libmoe.so.${PV} /usr/lib/libmoe.so.${PV%.*}
+ dosym /usr/lib/libmoe.so.${PV} /usr/lib/libmoe.so
+
+ dodoc ChangeLog libmoe.shtml
+}