summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2013-12-26 19:40:02 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2013-12-26 19:40:02 +0000
commit5534df4777f21b0f8d98daccc65e23959e266982 (patch)
treed3d666852d41da1dee3639dfc996e2eb1dd7e35c /dev-libs/klibc
parentvanilla-3.12.6 + genpatches-3.12-7 + grsecurity-3.0-3.12.6-201312251834 (diff)
downloadhistorical-5534df4777f21b0f8d98daccc65e23959e266982.tar.gz
historical-5534df4777f21b0f8d98daccc65e23959e266982.tar.bz2
historical-5534df4777f21b0f8d98daccc65e23959e266982.zip
Bug #485482: Enable building on mixed 64-bit kernel + 32-bit userland; patch by Denis Kaganovich <mahatma@bspu.unibel.by>.
Package-Manager: portage-2.2.7/cvs/Linux x86_64
Diffstat (limited to 'dev-libs/klibc')
-rw-r--r--dev-libs/klibc/ChangeLog6
-rw-r--r--dev-libs/klibc/klibc-2.0.2.ebuild9
2 files changed, 10 insertions, 5 deletions
diff --git a/dev-libs/klibc/ChangeLog b/dev-libs/klibc/ChangeLog
index 3c666ddfeb2f..9fb707b89584 100644
--- a/dev-libs/klibc/ChangeLog
+++ b/dev-libs/klibc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/klibc
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/klibc/ChangeLog,v 1.94 2013/12/26 19:33:20 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/klibc/ChangeLog,v 1.95 2013/12/26 19:40:02 robbat2 Exp $
+
+ 26 Dec 2013; Robin H. Johnson <robbat2@gentoo.org> klibc-2.0.2.ebuild:
+ Bug #485482: Enable building on mixed 64-bit kernel + 32-bit userland; patch
+ by Denis Kaganovich <mahatma@bspu.unibel.by>.
26 Dec 2013; Robin H. Johnson <robbat2@gentoo.org> klibc-2.0.2.ebuild:
Make repoman happy.
diff --git a/dev-libs/klibc/klibc-2.0.2.ebuild b/dev-libs/klibc/klibc-2.0.2.ebuild
index adb15bd9a0fc..8208133a39ce 100644
--- a/dev-libs/klibc/klibc-2.0.2.ebuild
+++ b/dev-libs/klibc/klibc-2.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/klibc/klibc-2.0.2.ebuild,v 1.2 2013/12/26 19:33:20 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/klibc/klibc-2.0.2.ebuild,v 1.3 2013/12/26 19:40:02 robbat2 Exp $
# Robin H. Johnson <robbat2@gentoo.org>, 12 Nov 2007:
# This still needs major work.
@@ -65,7 +65,8 @@ kernel_asm_arch() {
a="${1:${ARCH}}"
case ${a} in
# Merged arches
- x86|amd64) echo x86 ;;
+ x86) echo i386 ;; # for build on x86 userspace & 64bit kernel
+ amd64) echo x86 ;;
ppc*) echo powerpc ;;
# Non-merged
alpha|arm|ia64|m68k|mips|sh|sparc*) echo ${1} ;;
@@ -138,7 +139,7 @@ src_compile() {
unset KBUILD_OUTPUT # we are using a private copy
cd "${KS}"
- emake ${defconfig} CC="${CC}" HOSTCC="${HOSTCC}" || die "No defconfig"
+ emake ${defconfig} CC="${CC}" HOSTCC="${HOSTCC}" ARCH="${KLIBCASMARCH}" || die "No defconfig"
if [[ "${KLIBCARCH/arm}" != "${KLIBCARCH}" ]] && \
[[ "${CHOST/eabi}" != "${CHOST}" ]]; then
# The delete and insert are seperate statements
@@ -151,7 +152,7 @@ src_compile() {
"${KS}"/.config \
"${S}"/defconfig
fi
- emake prepare CC="${CC}" HOSTCC="${HOSTCC}" || die "Failed to prepare kernel sources for header usage"
+ emake prepare CC="${CC}" HOSTCC="${HOSTCC}" ARCH="${KLIBCASMARCH}" || die "Failed to prepare kernel sources for header usage"
cd "${S}"